aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-17 14:12:35 +0800
committerbapt <bapt@FreeBSD.org>2013-09-17 14:12:35 +0800
commit12e20b0674c48f693a78fe456f8afcfb71b9685b (patch)
treecb5f589849208faeb4439a9e84ed872d37762a4e /irc
parent8d3ae674ceb081425ad7cc938389bcae62407b66 (diff)
downloadfreebsd-ports-gnome-12e20b0674c48f693a78fe456f8afcfb71b9685b.tar.gz
freebsd-ports-gnome-12e20b0674c48f693a78fe456f8afcfb71b9685b.tar.zst
freebsd-ports-gnome-12e20b0674c48f693a78fe456f8afcfb71b9685b.zip
Convert to new perl framework
Submitted by: az
Diffstat (limited to 'irc')
-rw-r--r--irc/kvirc/Makefile6
-rw-r--r--irc/znc/Makefile10
2 files changed, 8 insertions, 8 deletions
diff --git a/irc/kvirc/Makefile b/irc/kvirc/Makefile
index e708e4f9003e..eb5d4603f383 100644
--- a/irc/kvirc/Makefile
+++ b/irc/kvirc/Makefile
@@ -23,10 +23,10 @@ CONFLICTS_INSTALL= kvirc-qt4-4.*
USE_BZIP2= yes
USE_OPENSSL= yes
-USE_PERL5_BUILD= yes
+USE_PERL5= build
USE_QT4= moc_build qmake_build rcc_build uic_build \
dbus gui network sql xml
-USES= cmake gettext
+USES= cmake gettext perl5
CMAKE_ARGS= -DWANT_ESD=no -DWANT_DOXYGEN=no \
-DMANDIR=${MANPREFIX}
INSTALLS_ICONS= yes
@@ -97,7 +97,7 @@ PLIST_SUB+= PYTHON="@comment "
.endif
.if ${PORT_OPTIONS:MPERL}
-USE_PERL5_RUN= yes
+USE_PERL5+= run
PLIST_SUB+= PERL=""
.else
CMAKE_ARGS+= -DWANT_PERL=no
diff --git a/irc/znc/Makefile b/irc/znc/Makefile
index 067251a66052..d9c8baacf1ce 100644
--- a/irc/znc/Makefile
+++ b/irc/znc/Makefile
@@ -15,9 +15,7 @@ LICENSE= GPLv2
FETCH_ARGS= -Fpr
GNU_CONFIGURE= yes
USE_RC_SUBR= znc
-USES= pkgconfig iconv
-USE_GMAKE= yes
-WANT_PERL= yes
+USES= pkgconfig iconv gmake
NO_OPTIONS_SORT= yes
@@ -50,8 +48,9 @@ PLIST_SUB+= OPENSSL="@comment "
.endif
.if ${PORT_OPTIONS:MPERL}
+USES+= perl5
+USE_PERL5+= run build
CONFIGURE_ARGS+= --enable-perl
-USE_PERL5= yes
PLIST_SUB+= PERL=""
BUILD_DEPENDS+= swig>=2.0.4:${PORTSDIR}/devel/swig20
.else
@@ -70,7 +69,8 @@ PLIST_SUB+= TCL="@comment "
.if ${PORT_OPTIONS:MPYTHON}
USE_PYTHON= 3.1-3.2
-USE_PERL5_BUILD= yes
+USES+= perl5
+USE_PERL5+= build
PLIST_SUB+= PYTHON=""
CONFIGURE_ARGS+= --enable-python=python-${PYTHON_VER}
BUILD_DEPENDS+= swig>=2.0.4:${PORTSDIR}/devel/swig20