aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2013-05-15 17:42:00 +0800
committergahr <gahr@FreeBSD.org>2013-05-15 17:42:00 +0800
commit14bed8edfc1e7889b53c71026c46dd77ee33b420 (patch)
treee08795944acd27d7a22fbd9655aefe3ca220b04d /irc
parent132b3d052a6358bf7e99fe3cd3ed2bcff83ee8d0 (diff)
downloadfreebsd-ports-gnome-14bed8edfc1e7889b53c71026c46dd77ee33b420.tar.gz
freebsd-ports-gnome-14bed8edfc1e7889b53c71026c46dd77ee33b420.tar.zst
freebsd-ports-gnome-14bed8edfc1e7889b53c71026c46dd77ee33b420.zip
- Fix build with Tcl/Tk 8.6
Reported by: miwi (Tcl/Tk 86 exp-run) Approved by: portmgr
Diffstat (limited to 'irc')
-rw-r--r--irc/eggdrop-devel/Makefile9
-rw-r--r--irc/eggdrop-devel/files/patch-src-match.c11
-rw-r--r--irc/eggdrop-devel/files/patch-src-net.c11
-rw-r--r--irc/eggdrop-devel/files/patch-src-tclhash.c11
-rw-r--r--irc/eggdrop/Makefile2
5 files changed, 39 insertions, 5 deletions
diff --git a/irc/eggdrop-devel/Makefile b/irc/eggdrop-devel/Makefile
index 0f476293a1f6..8c0a4eb8e381 100644
--- a/irc/eggdrop-devel/Makefile
+++ b/irc/eggdrop-devel/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: eggdrop-devel
-# Date created: June 13, 2011
-# Whom: Beech Rintoul <beech@FreeBSD.org>
-#
+# Created by: Beech Rintoul <beech@FreeBSD.org>
# $FreeBSD$
PORTNAME= eggdrop
@@ -20,6 +17,8 @@ LICENSE= GPLv2
USE_TCL= 85+
GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-tcllib=${LOCALBASE}/lib/libtcl${TCL_VER:S/.//}.so \
+ --with-tclinc=${LOCALBASE}/include/tcl${TCL_VER}/tcl.h
MAKE_JOBS_UNSAFE= yes
@@ -112,7 +111,7 @@ do-install:
@${MKDIR} ${DOCSDIR}/html
cd ${WRKSRC}/doc/html && ${INSTALL_DATA} *.html ${DOCSDIR}/html
@${MKDIR} ${DOCSDIR}/settings
- cd ${WRKSRC}/doc/settings && $(RM) -rf CVS \
+ cd ${WRKSRC}/doc/settings && ${RM} -rf CVS \
&& ${INSTALL_DATA} * ${DOCSDIR}/settings
.endif
@${CAT} ${PKGMESSAGE}
diff --git a/irc/eggdrop-devel/files/patch-src-match.c b/irc/eggdrop-devel/files/patch-src-match.c
new file mode 100644
index 000000000000..dfaf8d9e5af0
--- /dev/null
+++ b/irc/eggdrop-devel/files/patch-src-match.c
@@ -0,0 +1,11 @@
+--- src/match.c.orig 2013-05-13 15:17:47.000000000 +0200
++++ src/match.c 2013-05-13 15:17:24.000000000 +0200
+@@ -367,7 +367,7 @@
+ /* Inline for cron_match (obviously).
+ * Matches a single field of a crontab expression.
+ */
+-inline int cron_matchfld(char *mask, int match)
++int cron_matchfld(char *mask, int match)
+ {
+ int skip = 0, f, t;
+ char *p, *q;
diff --git a/irc/eggdrop-devel/files/patch-src-net.c b/irc/eggdrop-devel/files/patch-src-net.c
new file mode 100644
index 000000000000..bf4424fad930
--- /dev/null
+++ b/irc/eggdrop-devel/files/patch-src-net.c
@@ -0,0 +1,11 @@
+--- src/net.c.orig 2013-05-13 15:18:26.000000000 +0200
++++ src/net.c 2013-05-13 15:18:34.000000000 +0200
+@@ -560,7 +560,7 @@
+ /* Returns a socket number for a listening socket that will accept any
+ * connection -- port # is returned in port
+ */
+-inline int open_listen(int *port)
++int open_listen(int *port)
+ {
+ int sock;
+ sockname_t name;
diff --git a/irc/eggdrop-devel/files/patch-src-tclhash.c b/irc/eggdrop-devel/files/patch-src-tclhash.c
new file mode 100644
index 000000000000..7207b5099f22
--- /dev/null
+++ b/irc/eggdrop-devel/files/patch-src-tclhash.c
@@ -0,0 +1,11 @@
+--- src/tclhash.c.orig 2013-05-13 15:18:05.000000000 +0200
++++ src/tclhash.c 2013-05-13 15:18:12.000000000 +0200
+@@ -113,7 +113,7 @@
+ nfree(tl);
+ }
+
+-inline void garbage_collect_tclhash(void)
++void garbage_collect_tclhash(void)
+ {
+ tcl_bind_list_t *tl, *tl_next, *tl_prev;
+ tcl_bind_mask_t *tm, *tm_next, *tm_prev;
diff --git a/irc/eggdrop/Makefile b/irc/eggdrop/Makefile
index ffcc4315d3fd..42a8238c54b9 100644
--- a/irc/eggdrop/Makefile
+++ b/irc/eggdrop/Makefile
@@ -16,6 +16,8 @@ LICENSE= GPLv2
USE_TCL= 85+
GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-tcllib=${LOCALBASE}/lib/libtcl${TCL_VER:S/.//}.so \
+ --with-tclinc=${LOCALBASE}/include/tcl${TCL_VER}/tcl.h
MAKE_JOBS_UNSAFE= yes
MAN1= eggdrop.1