aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorcs <cs@FreeBSD.org>2012-10-07 21:30:18 +0800
committercs <cs@FreeBSD.org>2012-10-07 21:30:18 +0800
commit4a67dd759384364c5761fe7469d256f18798adc1 (patch)
tree8ff681bde3bcfdc17d90d17d57a808171ef122c3 /irc
parentbf1c6de4d1bc6cea8013e4b815ae8b0c5b39947e (diff)
downloadfreebsd-ports-gnome-4a67dd759384364c5761fe7469d256f18798adc1.tar.gz
freebsd-ports-gnome-4a67dd759384364c5761fe7469d256f18798adc1.tar.zst
freebsd-ports-gnome-4a67dd759384364c5761fe7469d256f18798adc1.zip
Patch to add chown modify at the end of the install. This will correctly assign
the owner of the config, log, and run directories for the owner specified by the port (by default this is ircd:ircd) PR: ports/172184 Submitted by: Jr Aquino <tanawts@gmail.com> (maintainer)
Diffstat (limited to 'irc')
-rw-r--r--irc/unreal/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/irc/unreal/Makefile b/irc/unreal/Makefile
index 186558aa1937..3ad1482541a2 100644
--- a/irc/unreal/Makefile
+++ b/irc/unreal/Makefile
@@ -176,6 +176,9 @@ post-install:
@[ -f ${CONFIGDIR}/help.conf ] || ${INSTALL_DATA} ${EXAMPLESDIR}/help.conf ${CONFIGDIR}
@[ -f ${CONFIGDIR}/spamfilter.conf ] || ${INSTALL_DATA} ${EXAMPLESDIR}/spamfilter.conf ${CONFIGDIR}
@[ -f ${CONFIGDIR}/unrealircd.conf ] || ${INSTALL_DATA} ${EXAMPLESDIR}/unrealircd.conf ${CONFIGDIR}
+ @${CHOWN} -R ${USERS}:${GROUPS} ${CONFIGDIR}
+ @${CHOWN} ${USERS}:${GROUPS} ${RUNDIR}
+ @${CHOWN} ${USERS}:${GROUPS} ${LOGDIR}
.if defined(WITH_SQLMOD)
@${CP} ${WRKSRC}/SQLMod/sample.conf ${CONFIGDIR}/m_sqlmod.conf
@${CP} ${WRKSRC}/SQLMod/Changes ${DOCSDIR}/Changes.sqlmod