aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2013-08-03 02:52:07 +0800
committermat <mat@FreeBSD.org>2013-08-03 02:52:07 +0800
commitf47f83f9c8923b3b0f740482331aab0d0aa669e9 (patch)
treea4a613f80a0e443c044c2319e43ce75e14c50813 /irc
parent16bdaae92136c316b9043fffbf5fb4438dce004e (diff)
downloadfreebsd-ports-gnome-f47f83f9c8923b3b0f740482331aab0d0aa669e9.tar.gz
freebsd-ports-gnome-f47f83f9c8923b3b0f740482331aab0d0aa669e9.tar.zst
freebsd-ports-gnome-f47f83f9c8923b3b0f740482331aab0d0aa669e9.zip
- Convert to new perl framework
- Trim Makefile header - Remove MAKE_JOBS_SAFE=yes, it's the default.
Diffstat (limited to 'irc')
-rw-r--r--irc/p5-AnyEvent-IRC/Makefile3
-rw-r--r--irc/p5-IRC-Bot-Hangman/Makefile3
-rw-r--r--irc/p5-POE-Component-IRC-Object/Makefile3
3 files changed, 6 insertions, 3 deletions
diff --git a/irc/p5-AnyEvent-IRC/Makefile b/irc/p5-AnyEvent-IRC/Makefile
index 6adaca195668..c192d352129b 100644
--- a/irc/p5-AnyEvent-IRC/Makefile
+++ b/irc/p5-AnyEvent-IRC/Makefile
@@ -14,7 +14,8 @@ BUILD_DEPENDS= p5-AnyEvent>=0:${PORTSDIR}/devel/p5-AnyEvent \
p5-Object-Event>=0.7:${PORTSDIR}/devel/p5-Object-Event
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= AnyEvent::IRC::Client.3 \
AnyEvent::IRC::Connection.3 \
diff --git a/irc/p5-IRC-Bot-Hangman/Makefile b/irc/p5-IRC-Bot-Hangman/Makefile
index a88f7de35606..360a77f8aea4 100644
--- a/irc/p5-IRC-Bot-Hangman/Makefile
+++ b/irc/p5-IRC-Bot-Hangman/Makefile
@@ -30,6 +30,7 @@ MAN3= IRC::Bot::Hangman.3 \
IRC::Bot::Hangman::WordList::Default.3 \
IRC::Bot::Hangman::WordList::TooEasy.3
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
.include <bsd.port.mk>
diff --git a/irc/p5-POE-Component-IRC-Object/Makefile b/irc/p5-POE-Component-IRC-Object/Makefile
index 2f1f397a20c3..0af56f199062 100644
--- a/irc/p5-POE-Component-IRC-Object/Makefile
+++ b/irc/p5-POE-Component-IRC-Object/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE \
RUN_DEPENDS:= ${BUILD_DEPENDS}
PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= POE::Component::IRC::Object.3