aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorclive <clive@FreeBSD.org>2002-07-09 04:28:55 +0800
committerclive <clive@FreeBSD.org>2002-07-09 04:28:55 +0800
commitff6669507ff08dac279af51c3d9eebf2d1b34709 (patch)
treea1833439ed715fb1daaef268ca52419d63c66718 /irc
parent5d322bebeaee7f13b1b72b59f3a15d73728feacb (diff)
downloadfreebsd-ports-gnome-ff6669507ff08dac279af51c3d9eebf2d1b34709.tar.gz
freebsd-ports-gnome-ff6669507ff08dac279af51c3d9eebf2d1b34709.tar.zst
freebsd-ports-gnome-ff6669507ff08dac279af51c3d9eebf2d1b34709.zip
- Added note about /detach not working if compiled with IPv6 support.
(Noticed by: Erwin Lansing <erwin@lansing.dk>) - Added WITH_XMMS knob - Made list of build Plugins static to keep plist correct. - Bumped Portrevision PR: ports/40153 Submitted by: Tilman Linneweh <tilman@arved.de> (MAINTAINER)
Diffstat (limited to 'irc')
-rw-r--r--irc/bitchx/Makefile25
-rw-r--r--irc/bitchx/pkg-plist1
2 files changed, 23 insertions, 3 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index 3c2e36bc06c6..898fc548891f 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -7,7 +7,7 @@
PORTNAME= BitchX
PORTVERSION= 1.0c19
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES+= irc gnome
MASTER_SITES= ftp://ftp.bitchx.com/pub/BitchX/source/ \
ftp://ftp.bitchx.org/pub/BitchX/source/ \
@@ -24,6 +24,9 @@ EXTRACT_ONLY= ircii-pana-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER?= freebsdports@arved.de
BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf
+.if defined(WITH_XMMS)
+LIB_DEPENDS+= xmms.3:${PORTSDIR}/audio/xmms
+.endif
WRKSRC= ${WRKDIR}/BitchX
USE_AUTOCONF= yes
@@ -70,12 +73,24 @@ CONFIGURE_ARGS+= --with-socks5=${LOCALBASE}
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include"
.endif
.if defined(WITH_PLUGINS)
-CONFIGURE_ARGS+=--with-plugins
+PLUGINS= abot,acro,aim,arcfour,autocycle,blowfish,cavlink,encrypt,fserv,hint,identd,nap,pkga,possum,qbx,qmail,scan,wavplay
PLIST_SUB+= PLUGINS:=""
.else
CONFIGURE_ARGS+=--without-plugins
PLIST_SUB+= PLUGINS:="@comment "
.endif
+.if defined(WITH_XMMS)
+PLUGINS= xmms
+PLIST_SUB+= XMMS:=""
+.else
+PLIST_SUB+= XMMS:="@comment "
+.endif
+.if (defined(WITH_XMMS) && defined(WITH_PLUGINS))
+PLUGINS= abot,acro,aim,arcfour,autocycle,blowfish,cavlink,encrypt,fserv,hint,identd,nap,pkga,possum,qbx,qmail,scan,wavplay,xmms
+.endif
+.if (defined(WITH_PLUGINS) || defined(WITH_XMMS))
+CONFIGURE_ARGS+=--with-plugins=${PLUGINS}
+.endif
pre-patch:
.if defined(WITH_LATIN)
@@ -86,8 +101,11 @@ pre-patch:
pre-extract:
@${ECHO_CMD} "Available switches:"
@${ECHO_CMD} "-------------------"
+.if !defined (WITH_XMMS)
+ @${ECHO_CMD} "WITH_XMMS - Building BitchX with XMMS-Plugin"
+.endif
.if !defined(WITH_PLUGINS)
- @${ECHO_CMD} "WITH_PLUGINS - Build the plugins"
+ @${ECHO_CMD} "WITH_PLUGINS - Building BitchX with some other plugins"
.endif
.if !defined(WITH_LATIN)
@${ECHO_CMD} "WITH_LATIN - Recommended if you are using an ISO-8859-1 display"
@@ -100,6 +118,7 @@ pre-extract:
.endif
.if !defined(WITH_IPV6)
@${ECHO_CMD} "WITH_IPV6 - Build BitchX with IPV6 support"
+ @${ECHO_CMD} " (Please Note: /detach is not working with IPv6)"
.endif
.if !defined(WITH_GNOME)
@${ECHO_CMD} "WITH_GNOME - Build BitchX with Gtk-Frontend"
diff --git a/irc/bitchx/pkg-plist b/irc/bitchx/pkg-plist
index 5c09bff10147..2f2659d301ba 100644
--- a/irc/bitchx/pkg-plist
+++ b/irc/bitchx/pkg-plist
@@ -935,6 +935,7 @@ share/bx/help/out
%%PLUGINS:%%share/bx/plugins/autocycle.so
%%PLUGINS:%%share/bx/plugins/cavlink.so
%%PLUGINS:%%share/bx/plugins/identd.so
+%%XMMS:%%share/bx/plugins/xmms.so
share/bx/script/actplug.gmz
share/bx/script/bxglobal
share/bx/script/bxtcl.tcl