aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-09-06 04:12:17 +0800
committerknu <knu@FreeBSD.org>2001-09-06 04:12:17 +0800
commit0d922a5e17dcf9206a0bbb7ff25fd9f5a9430e97 (patch)
tree0edca320c6595f6c88ed0960aef08f26765da016 /irc
parent4e0535cb4ccf0341bf804768ed2fc4247ce81785 (diff)
downloadfreebsd-ports-gnome-0d922a5e17dcf9206a0bbb7ff25fd9f5a9430e97.tar.gz
freebsd-ports-gnome-0d922a5e17dcf9206a0bbb7ff25fd9f5a9430e97.tar.zst
freebsd-ports-gnome-0d922a5e17dcf9206a0bbb7ff25fd9f5a9430e97.zip
Fix installation and packaging with GNOME.
Diffstat (limited to 'irc')
-rw-r--r--irc/xchat-gnome/Makefile8
-rw-r--r--irc/xchat/Makefile8
-rw-r--r--irc/xchat1/Makefile8
-rw-r--r--irc/xchat2/Makefile8
4 files changed, 12 insertions, 20 deletions
diff --git a/irc/xchat-gnome/Makefile b/irc/xchat-gnome/Makefile
index f08990a31183..57edd91041fc 100644
--- a/irc/xchat-gnome/Makefile
+++ b/irc/xchat-gnome/Makefile
@@ -34,7 +34,8 @@ CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_ARGS+= --disable-python \
--without-included-gettext \
--enable-nls \
- --enable-ipv6
+ --enable-ipv6 \
+ --datadir="${PREFIX}/share"
.include <bsd.port.pre.mk>
@@ -52,6 +53,7 @@ CONFIGURE_ARGS+= --enable-openssl
.if defined(HAVE_GNOME)
USE_GNOME= yes
CONFIGURE_ARGS+= --enable-gnome --enable-panel --enable-gdk-pixbuf
+MAKE_ARGS= icondir="${PREFIX}/share/gnome/pixmaps"
.else
CONFIGURE_ARGS+= --disable-gnome --disable-gdk-pixbuf
.endif
@@ -59,12 +61,8 @@ CONFIGURE_ARGS+= --disable-gnome --disable-gdk-pixbuf
post-patch:
@${PERL} -pi \
-e 's|-lpthread|${PTHREAD_LIBS}|g;' \
- -e 's|DATADIRNAME=lib|DATADIRNAME=share|g;' \
-e 's|iconv|giconv|;' \
${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi \
- -e 's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g;' \
- -e 's|\$$\(datadir\)/locale|\$$\(prefix\)/share/locale|g;'
@${PERL} -pi -e 's|iconv\.h|giconv.h|;' \
${WRKSRC}/src/common/jcode.c
diff --git a/irc/xchat/Makefile b/irc/xchat/Makefile
index f08990a31183..57edd91041fc 100644
--- a/irc/xchat/Makefile
+++ b/irc/xchat/Makefile
@@ -34,7 +34,8 @@ CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_ARGS+= --disable-python \
--without-included-gettext \
--enable-nls \
- --enable-ipv6
+ --enable-ipv6 \
+ --datadir="${PREFIX}/share"
.include <bsd.port.pre.mk>
@@ -52,6 +53,7 @@ CONFIGURE_ARGS+= --enable-openssl
.if defined(HAVE_GNOME)
USE_GNOME= yes
CONFIGURE_ARGS+= --enable-gnome --enable-panel --enable-gdk-pixbuf
+MAKE_ARGS= icondir="${PREFIX}/share/gnome/pixmaps"
.else
CONFIGURE_ARGS+= --disable-gnome --disable-gdk-pixbuf
.endif
@@ -59,12 +61,8 @@ CONFIGURE_ARGS+= --disable-gnome --disable-gdk-pixbuf
post-patch:
@${PERL} -pi \
-e 's|-lpthread|${PTHREAD_LIBS}|g;' \
- -e 's|DATADIRNAME=lib|DATADIRNAME=share|g;' \
-e 's|iconv|giconv|;' \
${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi \
- -e 's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g;' \
- -e 's|\$$\(datadir\)/locale|\$$\(prefix\)/share/locale|g;'
@${PERL} -pi -e 's|iconv\.h|giconv.h|;' \
${WRKSRC}/src/common/jcode.c
diff --git a/irc/xchat1/Makefile b/irc/xchat1/Makefile
index f08990a31183..57edd91041fc 100644
--- a/irc/xchat1/Makefile
+++ b/irc/xchat1/Makefile
@@ -34,7 +34,8 @@ CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_ARGS+= --disable-python \
--without-included-gettext \
--enable-nls \
- --enable-ipv6
+ --enable-ipv6 \
+ --datadir="${PREFIX}/share"
.include <bsd.port.pre.mk>
@@ -52,6 +53,7 @@ CONFIGURE_ARGS+= --enable-openssl
.if defined(HAVE_GNOME)
USE_GNOME= yes
CONFIGURE_ARGS+= --enable-gnome --enable-panel --enable-gdk-pixbuf
+MAKE_ARGS= icondir="${PREFIX}/share/gnome/pixmaps"
.else
CONFIGURE_ARGS+= --disable-gnome --disable-gdk-pixbuf
.endif
@@ -59,12 +61,8 @@ CONFIGURE_ARGS+= --disable-gnome --disable-gdk-pixbuf
post-patch:
@${PERL} -pi \
-e 's|-lpthread|${PTHREAD_LIBS}|g;' \
- -e 's|DATADIRNAME=lib|DATADIRNAME=share|g;' \
-e 's|iconv|giconv|;' \
${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi \
- -e 's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g;' \
- -e 's|\$$\(datadir\)/locale|\$$\(prefix\)/share/locale|g;'
@${PERL} -pi -e 's|iconv\.h|giconv.h|;' \
${WRKSRC}/src/common/jcode.c
diff --git a/irc/xchat2/Makefile b/irc/xchat2/Makefile
index f08990a31183..57edd91041fc 100644
--- a/irc/xchat2/Makefile
+++ b/irc/xchat2/Makefile
@@ -34,7 +34,8 @@ CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_ARGS+= --disable-python \
--without-included-gettext \
--enable-nls \
- --enable-ipv6
+ --enable-ipv6 \
+ --datadir="${PREFIX}/share"
.include <bsd.port.pre.mk>
@@ -52,6 +53,7 @@ CONFIGURE_ARGS+= --enable-openssl
.if defined(HAVE_GNOME)
USE_GNOME= yes
CONFIGURE_ARGS+= --enable-gnome --enable-panel --enable-gdk-pixbuf
+MAKE_ARGS= icondir="${PREFIX}/share/gnome/pixmaps"
.else
CONFIGURE_ARGS+= --disable-gnome --disable-gdk-pixbuf
.endif
@@ -59,12 +61,8 @@ CONFIGURE_ARGS+= --disable-gnome --disable-gdk-pixbuf
post-patch:
@${PERL} -pi \
-e 's|-lpthread|${PTHREAD_LIBS}|g;' \
- -e 's|DATADIRNAME=lib|DATADIRNAME=share|g;' \
-e 's|iconv|giconv|;' \
${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi \
- -e 's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g;' \
- -e 's|\$$\(datadir\)/locale|\$$\(prefix\)/share/locale|g;'
@${PERL} -pi -e 's|iconv\.h|giconv.h|;' \
${WRKSRC}/src/common/jcode.c