aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2012-07-27 19:03:38 +0800
committermakc <makc@FreeBSD.org>2012-07-27 19:03:38 +0800
commit7e9888a561c1f2a53cfeca5bf54f5278294df386 (patch)
tree167ee4bd8c4cd737246cf4e2c40f36e42042084e /irc
parent7c887ca2a204b4cd88ce46806edb8ea718e69d9e (diff)
downloadfreebsd-ports-gnome-7e9888a561c1f2a53cfeca5bf54f5278294df386.tar.gz
freebsd-ports-gnome-7e9888a561c1f2a53cfeca5bf54f5278294df386.tar.zst
freebsd-ports-gnome-7e9888a561c1f2a53cfeca5bf54f5278294df386.zip
- Convert my ports to new options framework
- use CONFLICTS_INSTALL - other minor changes
Diffstat (limited to 'irc')
-rw-r--r--irc/kvirc/Makefile33
-rw-r--r--irc/quassel/Makefile28
2 files changed, 32 insertions, 29 deletions
diff --git a/irc/kvirc/Makefile b/irc/kvirc/Makefile
index be16a197b93a..d6212ad892fa 100644
--- a/irc/kvirc/Makefile
+++ b/irc/kvirc/Makefile
@@ -23,7 +23,7 @@ MAINTAINER= makc@FreeBSD.org
COMMENT?= IRC client for KDE4
.if !defined(PKGNAMESUFFIX)
-CONFLICTS= kvirc-qt4-4.*
+CONFLICTS_INSTALL= kvirc-qt4-4.*
.endif
USE_BZIP2= yes
@@ -42,14 +42,17 @@ MAKE_JOBS_SAFE= yes
MAN1= kvirc.1
MANLANG= "" de fr it
-OPTIONS= AUDIOFILE "Support for various audio formats" off \
- DEBUG "Build with debug support" off \
- GSM "u-law to gsm audio converter support" off \
- PERL "Perl scripting support" off \
- PYTHON "Python scripting support" off
+OPTIONS_DEFINE= AUDIOFILE GSM PERL PYTHON
+
+AUDIOFILE_DESC= Support for various audio formats
+GSM_DESC= u-law to gsm audio converter support
+PERL_DESC= Perl scripting support
+PYTHON_DESC= Python scripting support
+
.if defined(PKGNAMESUFFIX)
-OPTIONS+= PHONON "Build with Phonon support" off \
- WEBKIT "Build with QtWebkit support" off
+OPTIONS_DEFINE+= PHONON WEBKIT
+PHONON_DESC= Build with Phonon support
+WEBKIT_DESC= Build with QtWebkit support
.endif
PLIST_SUB+= VER="${PORTVERSION:R}"
@@ -59,12 +62,12 @@ PLIST_SUB+= VER="${PORTVERSION:R}"
.if defined(PKGNAMESUFFIX)
CMAKE_ARGS+= -DWITHOUT_KDE4=yes
PLIST_SUB+= QT="" KDE="@comment "
-. if defined(WITH_PHONON)
+. if ${PORT_OPTIONS:MPHONON}
USE_QT4+= phonon
. else
CMAKE_ARGS+= -DWITHOUT_PHONON=yes
. endif
-. if defined(WITH_WEBKIT)
+. if ${PORT_OPTIONS:MWEBKIT}
USE_QT4+= webkit
. else
CMAKE_ARGS+= -DWITHOUT_QTWEBKIT=yes
@@ -79,20 +82,20 @@ CMAKE_ARGS+= -DWITH_DEBUG=yes -DVERBOSE=yes
.endif
#audio support
-.if defined(WITH_AUDIOFILE)
+.if ${PORT_OPTIONS:MAUDIOFILE}
LIB_DEPENDS+= audiofile.0:${PORTSDIR}/audio/libaudiofile
.else
CMAKE_ARGS+= -DWITHOUT_AUDIOFILE=yes
.endif
-.if defined(WITH_GSM)
+.if ${PORT_OPTIONS:MGSM}
LIB_DEPENDS+= gsm.1:${PORTSDIR}/audio/gsm
.else
CMAKE_ARGS+= -DWITHOUT_GSM=yes
.endif
#scripting support
-.if defined(WITH_PYTHON)
+.if ${PORT_OPTIONS:MPYTHON}
USE_PYTHON= yes
PLIST_SUB+= PYTHON=""
.else
@@ -100,7 +103,7 @@ CMAKE_ARGS+= -DWITHOUT_PYTHON=yes
PLIST_SUB+= PYTHON="@comment "
.endif
-.if defined(WITH_PERL)
+.if ${PORT_OPTIONS:MPERL}
USE_PERL5_RUN= yes
PLIST_SUB+= PERL=""
.else
@@ -108,7 +111,7 @@ CMAKE_ARGS+= -DWITHOUT_PERL=yes
PLIST_SUB+= PERL="@comment "
.endif
-.if defined(WITH_PERL)
+.if ${PORT_OPTIONS:MPERL}
pre-everything::
@${ECHO_CMD} "====================================================="
@${ECHO_CMD} " To enable perl scripting you need to rebuild"
diff --git a/irc/quassel/Makefile b/irc/quassel/Makefile
index 9e2c19b8ea4c..060a0975034a 100644
--- a/irc/quassel/Makefile
+++ b/irc/quassel/Makefile
@@ -21,9 +21,13 @@ USE_CMAKE= yes
USE_QT4= qmake_build moc_build rcc_build uic_build
MAKE_JOBS_SAFE= yes
-OPTIONS= MONO "Quassel standalone client" on \
- CORE "Quassel core" on \
- CLIENT "Quassel client" on
+OPTIONS_MULTI= MODULE
+OPTIONS_MULTI_MODULE= MONO CORE CLIENT
+OPTIONS_DEFAULT= ${OPTIONS_MULTI_MODULE}
+
+MONO_DESC= Quassel standalone client
+CORE_DESC= Quassel core
+CLIENT_DESC= Quassel client
CMAKE_ARGS+= -DWANT_MONO=${QUASSEL_MONO} \
-DWANT_CORE=${QUASSEL_CORE} \
@@ -32,21 +36,17 @@ CMAKE_ARGS+= -DWANT_MONO=${QUASSEL_MONO} \
.include <bsd.port.options.mk>
-.if defined(WITHOUT_MONO) && defined(WITHOUT_CORE) && defined(WITHOUT_CLIENT)
-IGNORE= needs at least one Quassel component. Please, rerun 'make config'
-.endif
-
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_QT4+= linguist_build
.endif
-.if defined(WITHOUT_MONO) && defined(WITHOUT_CLIENT)
+.if !${PORT_OPTIONS:MMONO} && !${PORT_OPTIONS:MCLIENT}
PLIST_SUB+= MONO_OR_CLIENT="@comment "
.else
PLIST_SUB+= MONO_OR_CLIENT=""
.endif
-.if !defined(WITHOUT_MONO)
+.if ${PORT_OPTIONS:MMONO}
USE_QT4+= dbus gui network script sql xml webkit
QUASSEL_MONO= ON
PLIST_SUB+= MONO=""
@@ -55,7 +55,7 @@ QUASSEL_MONO= OFF
PLIST_SUB+= MONO="@comment "
.endif
-.if !defined(WITHOUT_CORE)
+.if ${PORT_OPTIONS:MCORE}
USE_QT4+= network script sql sql-sqlite3_run
QUASSEL_CORE= ON
PLIST_SUB+= CORE=""
@@ -69,7 +69,7 @@ QUASSEL_CORE= OFF
PLIST_SUB+= CORE="@comment "
.endif
-.if !defined(WITHOUT_CLIENT)
+.if ${PORT_OPTIONS:MCLIENT}
USE_QT4+= dbus gui network xml webkit
QUASSEL_CLIENT= ON
PLIST_SUB+= CLIENT=""
@@ -79,13 +79,13 @@ PLIST_SUB+= CLIENT="@comment "
.endif
pre-configure:
-.if defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
${REINPLACE_CMD} -e '/add_subdirectory(i18n)/d' \
${WRKSRC}/CMakeLists.txt
.endif
post-install:
-.if !defined(WITHOUT_CORE)
+.if ${PORT_OPTIONS:MCORE}
@${CAT} ${PKGMESSAGE}
.endif