aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2007-10-02 23:00:14 +0800
committerkevlo <kevlo@FreeBSD.org>2007-10-02 23:00:14 +0800
commitc43c5022b3a3563d2ee578cd86888f8542e9d3fd (patch)
treebe1d635f939f83d6d669a069773aa285448a5843 /irc
parent55fbc64d1f1cda80113a3ad8de58f7300e13b2d6 (diff)
downloadfreebsd-ports-gnome-c43c5022b3a3563d2ee578cd86888f8542e9d3fd.tar.gz
freebsd-ports-gnome-c43c5022b3a3563d2ee578cd86888f8542e9d3fd.tar.zst
freebsd-ports-gnome-c43c5022b3a3563d2ee578cd86888f8542e9d3fd.zip
- Fix build with gcc4.
- Drop maintainer.
Diffstat (limited to 'irc')
-rw-r--r--irc/quirc/Makefile14
-rw-r--r--irc/quirc/files/patch-format.cc11
2 files changed, 12 insertions, 13 deletions
diff --git a/irc/quirc/Makefile b/irc/quirc/Makefile
index 771749c8e04d..625a10a5c9eb 100644
--- a/irc/quirc/Makefile
+++ b/irc/quirc/Makefile
@@ -7,11 +7,11 @@
PORTNAME= quirc
PORTVERSION= 0.9.84
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= irc tk84
MASTER_SITES= ${MASTER_SITE_LOCAL:S/$/:local/}
-MAINTAINER= kevlo@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= An irc client for the X Window System that uses TCL/TK
LIB_DEPENDS= tk84.1:${PORTSDIR}/x11-toolkits/tk84
@@ -45,12 +45,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-.if ${ARCH} == "amd64" || ${ARCH} == "sparc64"
-BROKEN= Does not compile with GCC 4.2
-.endif
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/irc/quirc/files/patch-format.cc b/irc/quirc/files/patch-format.cc
index b2c258ab06f2..e43ad0f228c0 100644
--- a/irc/quirc/files/patch-format.cc
+++ b/irc/quirc/files/patch-format.cc
@@ -1,8 +1,15 @@
---- format.cc.orig Mon Jan 12 18:32:01 2004
-+++ format.cc Tue Feb 3 23:19:28 2004
+--- format.cc.orig 2004-01-12 17:32:01.000000000 +0800
++++ format.cc 2007-10-02 22:46:34.000000000 +0800
@@ -1,4 +1,5 @@
#include <stdarg.h>
+#include <sys/types.h>
#include "quirc.h"
#include "hash.h"
+@@ -405,5 +406,5 @@
+ }
+
+ int fexists(const char *type) {
+- return (int)hash_get(&formats,type);
++ return (int)*hash_get(&formats,type);
+ }