aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-10 21:54:26 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-10 21:54:26 +0800
commit591689f7f7301da41e08d95976e1318322254d75 (patch)
tree3a1e73b4128190b7ed7020b2113a1d94d76b0e93 /irc
parent241bc346167b5bfc4beac8d3b3044454cf6b0f87 (diff)
downloadfreebsd-ports-gnome-591689f7f7301da41e08d95976e1318322254d75.tar.gz
freebsd-ports-gnome-591689f7f7301da41e08d95976e1318322254d75.tar.zst
freebsd-ports-gnome-591689f7f7301da41e08d95976e1318322254d75.zip
According to the Porter's Handbook (5.12.2.3.) default options must be added to
OPTIONS_DEFINE. This policy has been implemented only recently that's why we have many ports violating this policy. This patch adds the default options specified in the Porter's Handbook to OPTIONS_DEFINE where they are being used. Ports maintained by gnome@FreeBSD.org, kde@FreeBSD.org and x11@FreeBSD.org have been excluded. Approved by: portmgr (bapt)
Diffstat (limited to 'irc')
-rw-r--r--irc/charybdis/Makefile2
-rw-r--r--irc/darkbot/Makefile2
-rw-r--r--irc/ii/Makefile3
-rw-r--r--irc/iroffer-lamm/Makefile2
-rw-r--r--irc/iroffer/Makefile2
-rw-r--r--irc/quirc/Makefile3
-rw-r--r--irc/rbot/Makefile2
-rw-r--r--irc/ruby-rica/Makefile2
-rw-r--r--irc/slirc/Makefile2
-rw-r--r--irc/tircproxy/Makefile2
-rw-r--r--irc/xchat-fish/Makefile2
-rw-r--r--irc/xchat-mircryption/Makefile2
-rw-r--r--irc/xchat-ruby/Makefile2
13 files changed, 28 insertions, 0 deletions
diff --git a/irc/charybdis/Makefile b/irc/charybdis/Makefile
index c8a5dcfeb78c..642dfc818227 100644
--- a/irc/charybdis/Makefile
+++ b/irc/charybdis/Makefile
@@ -37,6 +37,8 @@ CONFIGURE_ARGS= --with-confdir=${ETCDIR} \
--with-moduledir=${DATADIR}/modules \
--enable-kqueue
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
diff --git a/irc/darkbot/Makefile b/irc/darkbot/Makefile
index b12ac7e5e7ee..41d719c1d4c7 100644
--- a/irc/darkbot/Makefile
+++ b/irc/darkbot/Makefile
@@ -19,6 +19,8 @@ PORTDOCS= README
PLIST_FILES= bin/darkbot %%ETCDIR%%/logs/.pkgcreate man/man1/darkbot.1.gz
PLIST_DIRSTRY= %%ETCDIR%%/logs/ %%ETCDIR%%/dat/ %%ETCDIR%%
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
pre-configure:
diff --git a/irc/ii/Makefile b/irc/ii/Makefile
index c6621e94275c..c4d6d2a03a53 100644
--- a/irc/ii/Makefile
+++ b/irc/ii/Makefile
@@ -21,6 +21,9 @@ MAKE_ARGS= -E CC
.endif
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
do-install:
diff --git a/irc/iroffer-lamm/Makefile b/irc/iroffer-lamm/Makefile
index 936fd99b6bdd..eb1d9f5c45db 100644
--- a/irc/iroffer-lamm/Makefile
+++ b/irc/iroffer-lamm/Makefile
@@ -18,6 +18,8 @@ CONFLICTS= iroffer-1.* iroffer-dinoex-3.*
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Configure
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/irc/iroffer/Makefile b/irc/iroffer/Makefile
index b12712e96105..19d4b1800dca 100644
--- a/irc/iroffer/Makefile
+++ b/irc/iroffer/Makefile
@@ -18,6 +18,8 @@ CONFLICTS= iroffer-lamm-1.* iroffer-dinoex-3.*
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Configure
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/irc/quirc/Makefile b/irc/quirc/Makefile
index f03649d92d56..84ed7593b026 100644
--- a/irc/quirc/Makefile
+++ b/irc/quirc/Makefile
@@ -20,6 +20,9 @@ MYPORTDOCS= AUTHORS ChangeLog FAQ NEWS README doc/color.txt \
doc/quedit.txt doc/rfc1459.txt doc/tdcc.txt
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
CONFIGURE_ARGS= --with-wish=${WISH} \
diff --git a/irc/rbot/Makefile b/irc/rbot/Makefile
index ef86a73ec94b..6dcf5880846c 100644
--- a/irc/rbot/Makefile
+++ b/irc/rbot/Makefile
@@ -23,6 +23,8 @@ SUB_FILES= pkg-message
PORTDOCS= REQUIREMENTS ChangeLog
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
pre-install:
diff --git a/irc/ruby-rica/Makefile b/irc/ruby-rica/Makefile
index 193b0a5840b9..1f25ae843cf7 100644
--- a/irc/ruby-rica/Makefile
+++ b/irc/ruby-rica/Makefile
@@ -26,6 +26,8 @@ MODULES= rica.rb \
DOCS= CHANGES README classes_and_methods.txt event.lst *.png
EXAMPLES= erica.* ricaco.rb rica-example.rb
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
do-install:
diff --git a/irc/slirc/Makefile b/irc/slirc/Makefile
index 254b16779212..c600cdf47558 100644
--- a/irc/slirc/Makefile
+++ b/irc/slirc/Makefile
@@ -46,6 +46,8 @@ NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e "s,/usr/local,${LOCALBASE}," ${WRKSRC}/Makefile ${WRKSRC}/scripts/init.sl
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-install:
.if ${PORT_OPTIONS:MDOCS}
diff --git a/irc/tircproxy/Makefile b/irc/tircproxy/Makefile
index d7f3bd29b8f9..819b9ccfba5f 100644
--- a/irc/tircproxy/Makefile
+++ b/irc/tircproxy/Makefile
@@ -13,6 +13,8 @@ COMMENT= IRC proxy server
WRKSRC= ${WRKDIR}/tircproxy-0.4
GNU_CONFIGURE= YES
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
diff --git a/irc/xchat-fish/Makefile b/irc/xchat-fish/Makefile
index 034a3ef41b75..4db4a995feb2 100644
--- a/irc/xchat-fish/Makefile
+++ b/irc/xchat-fish/Makefile
@@ -29,6 +29,8 @@ PLIST_FILES= lib/xchat/plugins/xfish.so
PORTDOCS= FiSH-xchat.txt \
FiSH-xchat_History.txt
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/irc/xchat-mircryption/Makefile b/irc/xchat-mircryption/Makefile
index 0023eda77bd0..11eab9beb15c 100644
--- a/irc/xchat-mircryption/Makefile
+++ b/irc/xchat-mircryption/Makefile
@@ -31,6 +31,8 @@ PLIST_FILES= lib/xchat/plugins/mircryption.so
PORTDOCS= README.txt
PORTEXAMPLES= mcps_masterkey_on_start.pl
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/irc/xchat-ruby/Makefile b/irc/xchat-ruby/Makefile
index 5968697feff6..9e14f0653447 100644
--- a/irc/xchat-ruby/Makefile
+++ b/irc/xchat-ruby/Makefile
@@ -25,6 +25,8 @@ PLIST_FILES= lib/xchat/plugins/xchat-ruby.so
PORTDOCS= README ChangeLog
PORTEXAMPLES= embedify.rb TimerSample.rb JFilter.rb JBanner.rb
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
post-patch: