aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorromain <romain@FreeBSD.org>2010-06-05 21:13:38 +0800
committerromain <romain@FreeBSD.org>2010-06-05 21:13:38 +0800
commit7a6b1216de87fb2538939cefbe66f06262f7cf85 (patch)
tree8d674635ef990d0147ff70e6ce0cbd9aff9f5d3f /irc
parent043f4eec228c6c8e5e09704663cfd1087d072b93 (diff)
downloadfreebsd-ports-gnome-7a6b1216de87fb2538939cefbe66f06262f7cf85.tar.gz
freebsd-ports-gnome-7a6b1216de87fb2538939cefbe66f06262f7cf85.tar.zst
freebsd-ports-gnome-7a6b1216de87fb2538939cefbe66f06262f7cf85.zip
SmartIrc4net is a multi-threaded and thread-safe IRC library written in C#. It
allows you to communicate with IRC servers. The API features full channel syncing and is splitted in 3 layers: IrcConnection, IrcCommands and IrcClient. WWW: http://smartirc4net.meebey.net/jaws/ PR: ports/141443 Submitted by: Romain Tartiere <romain at blogreen.org>
Diffstat (limited to 'irc')
-rw-r--r--irc/Makefile1
-rw-r--r--irc/smartirc4net/Makefile23
-rw-r--r--irc/smartirc4net/distinfo3
-rw-r--r--irc/smartirc4net/pkg-descr5
-rw-r--r--irc/smartirc4net/pkg-plist8
5 files changed, 40 insertions, 0 deletions
diff --git a/irc/Makefile b/irc/Makefile
index dcc781d2d207..1454014c58fe 100644
--- a/irc/Makefile
+++ b/irc/Makefile
@@ -126,6 +126,7 @@
SUBDIR += simpleirc
SUBDIR += sirc
SUBDIR += slirc
+ SUBDIR += smartirc4net
SUBDIR += solid-ircd
SUBDIR += srvx
SUBDIR += talksoup
diff --git a/irc/smartirc4net/Makefile b/irc/smartirc4net/Makefile
new file mode 100644
index 000000000000..2c07ab677771
--- /dev/null
+++ b/irc/smartirc4net/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: smartirc4net
+# Date created: 2009-08-25
+# Whom: Romain Tartiere <romain@blogreen.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= smartirc4net
+PORTVERSION= 0.4.5.1
+CATEGORIES= irc
+MASTER_SITES= http://www.smuxi.org/jaws/data/files/
+
+MAINTAINER= romain@blogreen.org
+COMMENT= Multi-layered IRC library
+
+BUILD_DEPENDS= mono:${PORTSDIR}/lang/mono
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack
+
+.include <bsd.port.mk>
diff --git a/irc/smartirc4net/distinfo b/irc/smartirc4net/distinfo
new file mode 100644
index 000000000000..46f1baf44299
--- /dev/null
+++ b/irc/smartirc4net/distinfo
@@ -0,0 +1,3 @@
+MD5 (smartirc4net-0.4.5.1.tar.gz) = a0f091d3796e6dce4c5158d973a937ee
+SHA256 (smartirc4net-0.4.5.1.tar.gz) = 56403be3be7c541828d6eabac70ffdcf49d8ce8c9506ac92160300a0d6823bc9
+SIZE (smartirc4net-0.4.5.1.tar.gz) = 112374
diff --git a/irc/smartirc4net/pkg-descr b/irc/smartirc4net/pkg-descr
new file mode 100644
index 000000000000..a65d81e37313
--- /dev/null
+++ b/irc/smartirc4net/pkg-descr
@@ -0,0 +1,5 @@
+SmartIrc4net is a multi-threaded and thread-safe IRC library written in C#. It
+allows you to communicate with IRC servers. The API features full channel
+syncing and is splitted in 3 layers: IrcConnection, IrcCommands and IrcClient.
+
+WWW: http://smartirc4net.meebey.net/jaws/
diff --git a/irc/smartirc4net/pkg-plist b/irc/smartirc4net/pkg-plist
new file mode 100644
index 000000000000..8519349737a8
--- /dev/null
+++ b/irc/smartirc4net/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+lib/smartirc4net/Meebey.SmartIrc4net.dll
+lib/mono/gac/Meebey.SmartIrc4net/0.4.5.0__7868485fbf407e0f/Meebey.SmartIrc4net.dll
+lib/mono/gac/Meebey.SmartIrc4net/0.4.5.0__7868485fbf407e0f/Meebey.SmartIrc4net.dll.mdb
+libdata/pkgconfig/smartirc4net.pc
+@dirrm lib/mono/gac/Meebey.SmartIrc4net/0.4.5.0__7868485fbf407e0f
+@dirrm lib/mono/gac/Meebey.SmartIrc4net
+@dirrm lib/smartirc4net
-0/+2 * Update to 5.0.5.jkim2016-02-161-4/+4 * Update Calligra to 2.9.11.rakuco2016-02-092-3/+2 * Update Calligra to 2.9.10.rakuco2015-12-223-26/+38 * Update to 5.0.4.jkim2015-12-181-4/+4 * Update to 5.0.3.jkim2015-11-041-4/+4 * Update to 5.0.2.jkim2015-09-242-6/+6 * Update LibreOffice to 5.0.1.jkim2015-09-021-4/+4 * Correct the pathname in user-instructions given by the port andmi2015-07-271-1/+1 * - Add NO_ARCHsunpoet2015-07-181-0/+1 * - Add NO_ARCHsunpoet2015-07-181-0/+1 * - Add NO_ARCHsunpoet2015-07-181-0/+1 * Update to 4.3.7.jkim2015-04-261-4/+4 * Make fonts repecting XDGbapt2015-03-224-18/+13 * Update KDE SC to 4.14.3alonso2015-03-122-2/+3 * - Update to 4.3.6.jkim2015-02-211-4/+4 * cleanup plistbapt2014-12-214-4/+0 * Update to 4.3.5.jkim2014-12-191-4/+4 * Update to 4.3.4.jkim2014-11-271-4/+4 * Cleanup plistantoine2014-11-122-5/+0 * Update to 4.3.3.jkim2014-11-011-4/+4 * Update to 1.8.0bapt2014-10-312-3/+3 * Update to 1.8.0bapt2014-10-312-3/+6 * KDE/FreeBSD team presents KDE SC 4.14.2 and KDE Workspace 4.11.13!makc2014-10-193-304/+86 * Update to 4.3.2.jkim2014-10-172-5/+4 * Update the default version of GCC in the Ports Collection from GCC 4.7.4gerald2014-09-113-2/+3 * Upgrade OpenEXR and ilmbase to 2.2.0.mandree2014-08-162-1/+2 * Remove indefinite articles and trailing periods from COMMENT, plusolgeni2014-08-033-3/+3 * Convert a bunch of EXTRACT_SUFX=... into USES=tar:...adamw2014-07-302-4/+2 * Modernize LIB_DEPENDSbapt2014-07-151-1/+1 * Stagify.vanilla2014-07-021-8/+4 * Update to 4.2.5.jkim2014-06-241-4/+4 * Update to libreoffice 4.2.4bapt2014-06-111-4/+4 * Support staging.mi2014-06-102-3/+2 * Remove the NO_STAGE. This port is as stage-ready as graphics/gd.mi2014-06-101-2/+1 * KDE/FreeBSD team presents KDE SC 4.12.5 and KDE Workspace 4.11.9!makc2014-05-111-2/+2 * Update to 4.1.6.jkim2014-05-071-4/+4 * KDE/FreeBSD team presents KDE SC 4.12.4 and KDE Workspace 4.11.8!makc2014-04-031-2/+2 * - Update to 1.7.1sunpoet2014-03-312-3/+3 * - Update to 1.7.1sunpoet2014-03-312-3/+3 * Convert u* and v* to USES=zipbapt2014-03-112-2/+2 * KDE/FreeBSD team presents KDE SC 4.12.3 and KDE Workspace 4.11.7!makc2014-03-052-11/+11 * Update to 4.1.5. It is partially based on the following PR.jkim2014-02-261-4/+4 * - Bump PORTREVISION after KDE4_PREFIX changemakc2014-02-181-0/+1 * KDE/FreeBSD team presents KDE SC 4.12.2 and KDE Workspace 4.11.6!makc2014-02-184-103/+168 * Remove ispell which is deprecated for long, consider using aspell instead or ...bapt2014-01-296-58/+0 * - Update to 1.7.0sunpoet2013-12-302-4/+3 * - Update to 1.7.0sunpoet2013-12-302-4/+6 * - Update Calligra Suite to 2.7.5.avilla2013-12-173-3/+8 * - use STAGEDIRdinoex2013-11-291-1/+0 * - Use single space after WWW:sunpoet2013-11-182-2/+2 * Stagifybapt2013-11-041-4/+3 * Stagifybapt2013-11-041-3/+2 * Support stage, use bsdtar to extractbapt2013-11-041-3/+2 * Stagifybapt2013-11-041-1/+0 * - Update to 4.0.6.jkim2013-10-262-5/+4 * Fix NO_STAGE attributionbapt2013-09-231-1/+1 * Add NO_STAGE all over the place in preparation for the staging support (cat: ...bapt2013-09-2112-30/+16 * - Use USES=gmakesunpoet2013-09-171-2/+1 * Convert to new perl frameworkbapt2013-09-171-2/+1 * 1. Introduce using iconv with arguments:bsam2013-09-021-3/+1 * Update to 4.0.5.jkim2013-08-231-4/+4 * ukrainian/webalizer: Fix gd dependencymarino2013-08-181-6/+2 * - Convert to new perl frameworkaz2013-08-042-3/+4 * KDE3 and QT3 expired on 2013-07-01, remove these ports.rene2013-07-275-674/+0 * Mark job unsafe and convert to USES=gmakebapt2013-07-101-6/+4 * Fix INDEX by really fixing the kde4-l10n portsbapt2013-07-101-0/+1 * KDE4 l10n fixes.rakuco2013-07-102-3/+1 * Update the KDE Software Compilation to 4.10.5.rakuco2013-07-051-2/+2 * Update to KDE SC 4.10.4, proudly presented by the KDE on FreeBSD team.rakuco2013-07-031-2/+2 * Update to 4.0.4.jkim2013-06-201-4/+4 * - Don't remove directories not created by this portmiwi2013-06-191-2/+0 * KDE/FreeBSD team presents KDE SC 4.10.3 ports!makc2013-05-192-4/+2 * Update to 4.0.3.jkim2013-05-101-4/+4 * Add some shebangfix to allow building most of the ports tree without /usr/bin...bapt2013-05-071-5/+2 * - Convert USE_GETTEXT to USES (part 2)ak2013-04-241-1/+1 * Update to 4.0.2.jkim2013-04-171-4/+4 * - Update Calligra and l10n ports to 2.6.2:avilla2013-03-302-5/+8 * KDE/FreeBSD team presents KDE SC 4.10.1 ports!makc2013-03-274-43/+97 * Update to 4.0.1.jkim2013-03-091-4/+4 * Merge from area51 repository:makc2013-02-052-3/+3 * Update to 3.6.5.jkim2013-02-051-4/+4 * KDE/FreeBSD team presents KDE SC 4.9.5 ports!makc2013-02-044-32/+147 * - Deprecate QT3, KDE3 and unmaintained ports depending on them. QT 3.3.8beat2012-12-301-0/+3 * - Update to 3.5.7.jkim2012-10-272-9/+4 * - Update Calligra Suite to 2.5.2.avilla2012-09-171-2/+2 * - Update Calligra to 2.5.1.avilla2012-09-012-7/+2 * The KDE/FreeBSD team is pleased to announce version 2.5 of Calligra,avilla2012-08-262-15/+3 * - Update to 3.5.6.jkim2012-08-241-4/+4 * - Update LibreOffice and the language packs to 3.5.5.jkim2012-07-181-4/+4 * - Update Calligra to 2.4.3.avilla2012-07-051-2/+2 * - The FreeBSD Office team is proud to announce LibreOffice.org 3.5.4 releasefluffy2012-07-011-4/+4 * KDE/FreeBSD team presents KDE SC 4.8.4, probably the last release in 4.8.x se...makc2012-06-153-3/+33 * - update png to 1.5.10dinoex2012-06-012-1/+2 * - Remove koffice-i18n ports, as they are not very useful withoutavilla2012-05-315-64/+0 * The KDE/FreeBSD team is pleased to announce Calligra Suite 2.4.2, KDEavilla2012-05-319-238/+129 * KDE/FreeBSD team presents long awaited KDE SC 4.8.3!makc2012-05-254-20/+263 * - upgrade to 3.5.2bapt2012-04-234-0/+22 * - Bump PORTREVISION to chase the update of multimedia/libvpxashish2012-02-161-0/+1 * The KDE/FreeBSD team is pleased to announce KDE SC 4.7.4, whichavilla2012-01-252-2/+35 * - Pass maintainership to office@FreeBSD.orgsunpoet2011-11-291-1/+1 * The KDE on FreeBSD team is pleased to update the KDE4 ports to 4.7.3.rakuco2011-11-141-2/+2 * Mark as broken on powerpc-9: does not install.linimon2011-11-111-1/+7 * The KDE/FreeBSD team is pleased to announce KDE Software Compilationavilla2011-10-172-14/+60 * - Set DIST_SUBDIR: move dist files to DISTDIR/mythessunpoet2011-08-182-2/+3 * - Set DIST_SUBDIR: move dist files to DISTDIR/hyphensunpoet2011-08-182-2/+3 * - Set DIST_SUBDIR: move dist files to DISTDIR/hunspellsunpoet2011-08-182-2/+3 * - Change MASTER_SITES to my LOCAL to avoid implicit change of non-versionedsunpoet2011-08-182-4/+4 * - Set WRKSRCsunpoet2011-08-131-1/+2 * - Unify COMMENT and pkg-descrsunpoet2011-08-132-2/+2 * - Move language prefix to PKGNAMEPREFIXsunpoet2011-07-293-20/+20 * - Fix typosunpoet2011-07-251-1/+1 * Pass matainership to the new office teambapt2011-07-223-3/+3 * Add some locales thesaurusbapt2011-07-214-0/+40 * Add Ukrainian hyphenation rulesbapt2011-07-214-0/+33 * Add ukrainian hunspell dictionnarybapt2011-07-204-0/+41 * Reset maintainership de jure. In fact KDE 3 has not been maintained by our teammakc2011-07-082-2/+2 * Update KDE Software Compilation ports to 4.6.5makc2011-07-083-3/+155 * The FreeBSD KDE Team is pleased to announce KDE SC 4.6.4. Read fullavilla2011-06-141-2/+2 * Update KDE Software Compilation ports to 4.6.3makc2011-05-172-2/+56 * - Update KOffice to 2.3.3.avilla2011-04-132-4/+4 * The FreeBSD KDE Team is pleased to announce April updates for KDEavilla2011-04-071-2/+2 * - Update KOffice to 2.3.1.avilla2011-03-254-6/+30 * The FreeBSD KDE Team is pleased to announce KDE SC 4.6.1 and KDE PIMavilla2011-03-252-25/+67 * - Get Rid MD5 supportmiwi2011-03-195-5/+0 * - Remove unnecessary PKGNAMEPREFIX declarationsunpoet2011-01-094-4/+0 * - The KDE FreeBSD team is proud to announce the release of KDE 4.5.5fluffy2011-01-082-2/+30 * KDE FreeBSD team presents KDE SC 4.5.4.makc2010-12-033-7/+3 * Reset anray@FreeBSD.org due to maintainer-timeouts and no response to email.linimon2010-12-021-1/+1 * KDE FreeBSD team presents KDE SC 4.5.3.makc2010-11-042-3/+11 * KDE FreeBSD team presents KDE SC 4.5.2.makc2010-10-062-7/+12 * Autotools update. Read ports/UPDATING 20100915 for details.ade2010-09-162-4/+2 * KDE FreeBSD team presents KDE SC 4.5.1.makc2010-09-033-385/+76 * Update KOffice l10n ports to 2.2.2makc2010-08-284-24/+8 * Present KDE SC 4.4.5 for FreeBSD.makc2010-06-301-3/+3 * - Update KOffice (and its l10n packs) to 2.2.0 releasefluffy2010-06-194-26/+66 * Present KDE SC 4.4.4 for FreeBSD.makc2010-06-021-3/+3 * Bounce PORTREVISION for gettext-related ports. Have fun, ya'll.ade2010-05-312-2/+2 * - Update KOffice to 2.1.2 releasefluffy2010-05-116-64/+6 * - The FreeBSD KDE team is pleased to announce KDE SC 4.4.3 for FreeBSDfluffy2010-05-114-219/+430 * - update to 1.4.1dinoex2010-03-285-4/+5 * Presenting KDE 4.3.5 for FreeBSD. The official release notes for thismiwi2010-02-073-4/+43 * - update to jpeg-8dinoex2010-02-055-2/+5 * The KDE FreeBSD team is proud to announce the release of KOffice2 suite for F...fluffy2009-12-227-76/+243 * The FreeBSD KDE is please to announce the release of KDE 4.3.4,miwi2009-12-022-16/+78 * The KDE FreeBSD team is proud to announce the release of KDE 4.3.3miwi2009-11-272-5/+27 * The FreeBSD KDE is please to announce the release of KDE 4.3.1,tabthorpe2009-09-022-4/+4 * - Switch SourceForge ports to the new File Release System: categories startin...amdmi32009-08-221-2/+1 * clean upmakc2009-08-081-3/+0 * The KDE FreeBSD team is proud to announce the release of KDE 4.3.0miwi2009-08-054-27/+137 * - bump all port that indirectly depends on libjpeg and have not yet been bump...dinoex2009-07-315-0/+5 * The KDE FreeBSD team is pleased to announce KDE 4.2.4, the last bugfixmiwi2009-06-032-4/+8 * Update KDE ports to 4.2.3makc2009-05-102-3/+4 * The KDE FreeBSD team is proud to announce the release of KDE 4.2.2miwi2009-04-022-15/+25 * Update KDE to 4.2.1.makc2009-03-092-3/+31 * - Add all manpages for kde4-l10n*miwi2009-02-091-0/+57 * The KDE FreeBSD team is proud to announce the release of KDE 4.2.0miwi2009-02-093-92/+289 * kde@freebsd team is pleased to announce KDE 4.1.4, the last bugfix release in...makc2009-01-143-10/+502 * The KDE FreeBSD team is proud to announce the release of KDE 4.1.1miwi2008-09-032-8/+185 * The KDE FreeBSD team is proud to announce the releasemiwi2008-08-291-3/+3 * The KDE FreeBSD team is proud to announce the releasemiwi2008-08-182-7/+61 * The KDE FreeBSD team is proud to announce the release of KDE 4.1.0miwi2008-08-105-294/+747 * - unbreak after update to webalizer 2.20-01dinoex2008-08-063-34/+0 * Mark BROKEN: does not patch after the upgrade of www/webalizererwin2008-08-051-0/+2 * - Update maintainer's email addresspav2008-07-241-1/+1 * Bump portrevision due to upgrade of devel/gettext.edwin2008-06-061-0/+1 * - Remove unneeded dependency from gtk12/gtk20 [1]miwi2008-04-203-9/+10 * Update to KDE 3.5.8lofi2007-10-304-8/+8 * Update to KDE 3.5.7 / KOffice 1.6.3lofi2007-07-0412-41/+20 * Upgrade to 1.4.0-0.thierry2007-06-132-4/+4 * - Welcome X.org 7.2 \o/.flz2007-05-206-0/+6 * 2007-04-06 sysutils/tct: this port is obsolete, please use sysutils/sleuthkit...miwi2007-04-116-86/+0 * Update to KDE 3.5.6 / KOffice 1.6.2lofi2007-03-1413-21/+32 * Really normalize Aspell dictionaries ports PKGVERSION...thierry2007-02-151-1/+1 * Upgrade to 1.3.1-0.thierry2007-02-132-4/+4 * Schedule these broken ports for removal on 2007-04-10 if they are stillkris2007-02-111-0/+2 * - Switch dependencies to modern XFree86/Xorg portspav2007-02-031-1/+1 * Normalize Aspell dictionaries PKGNAMEs.thierry2007-01-141-0/+1 * BROKEN: Leaves behind config file on deinstallkris2007-01-111-0/+2 * Update to KDE 3.5.5 / KOffice 1.6.1lofi2006-12-2011-18/+21 * KDE 3.5.4 / KOffice 1.5.2lofi2006-09-1310-30/+24 * All dictionaries can be installed separately:thierry2006-07-154-7/+18 * Update to KDE 3.5.3lofi2006-06-064-16/+16 * Update to KOffice 1.5.1lofi2006-05-276-12/+12 * Update to KOffice 1.5.0lofi2006-04-299-78/+51 * Update to KDE 3.5.2lofi2006-03-314-122/+16 * Update to KDE 3.5.1.lofi2006-02-014-6/+14 * SHA256ifyedwin2006-01-24