aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2015-12-21 23:41:30 +0800
committerfeld <feld@FreeBSD.org>2015-12-21 23:41:30 +0800
commit896223561630cd90cf0976af2dad2d1a43674ad9 (patch)
tree420866c5b568a648f6b008f96bade3035d511124 /irc
parent7eb13a5a4e955c30f8c4d1eb37d661245ad96660 (diff)
downloadfreebsd-ports-gnome-896223561630cd90cf0976af2dad2d1a43674ad9.tar.gz
freebsd-ports-gnome-896223561630cd90cf0976af2dad2d1a43674ad9.tar.zst
freebsd-ports-gnome-896223561630cd90cf0976af2dad2d1a43674ad9.zip
irc/quassel: Import patch to resolve DoS CVE
Approved by: ports-secteam (with hat) MFH: 2015Q4 Security: CVE-2015-8547
Diffstat (limited to 'irc')
-rw-r--r--irc/quassel/Makefile1
-rw-r--r--irc/quassel/files/patch-src_core_coreuserinputhandler.cpp12
2 files changed, 13 insertions, 0 deletions
diff --git a/irc/quassel/Makefile b/irc/quassel/Makefile
index c6975e6d91fb..921750302eaf 100644
--- a/irc/quassel/Makefile
+++ b/irc/quassel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= quassel
PORTVERSION= 0.12.2
+PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= http://www.quassel-irc.org/pub/
diff --git a/irc/quassel/files/patch-src_core_coreuserinputhandler.cpp b/irc/quassel/files/patch-src_core_coreuserinputhandler.cpp
new file mode 100644
index 000000000000..c3cff156f59c
--- /dev/null
+++ b/irc/quassel/files/patch-src_core_coreuserinputhandler.cpp
@@ -0,0 +1,12 @@
+Fix CVE-2015-8547
+--- src/core/coreuserinputhandler.cpp.orig 2015-04-23 20:47:17 UTC
++++ src/core/coreuserinputhandler.cpp
+@@ -228,7 +228,7 @@ void CoreUserInputHandler::doMode(const
+ if (!isNumber || maxModes == 0) maxModes = 1;
+
+ QStringList nickList;
+- if (nicks == "*") { // All users in channel
++ if (nicks == "*" && bufferInfo.type() == BufferInfo::ChannelBuffer) { // All users in channel
+ const QList<IrcUser*> users = network()->ircChannel(bufferInfo.bufferName())->ircUsers();
+ foreach(IrcUser *user, users) {
+ if ((addOrRemove == '+' && !network()->ircChannel(bufferInfo.bufferName())->userModes(user).contains(mode))