aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2002-11-04 09:27:07 +0800
committeredwin <edwin@FreeBSD.org>2002-11-04 09:27:07 +0800
commita6b2fb678bff4552c8629addef6e8f9ec1d023a9 (patch)
treea30b1208e86f2727af7dd93b2ca61d8eaaeeae53 /irc
parent3fc01c93a4c397aef77672cc0242e44185a448fb (diff)
downloadfreebsd-ports-gnome-a6b2fb678bff4552c8629addef6e8f9ec1d023a9.tar.gz
freebsd-ports-gnome-a6b2fb678bff4552c8629addef6e8f9ec1d023a9.tar.zst
freebsd-ports-gnome-a6b2fb678bff4552c8629addef6e8f9ec1d023a9.zip
PERL -> REINPLACE
Noticed on: bento
Diffstat (limited to 'irc')
-rw-r--r--irc/ninja/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/irc/ninja/Makefile b/irc/ninja/Makefile
index b5bdf1a38fdf..b12820c314eb 100644
--- a/irc/ninja/Makefile
+++ b/irc/ninja/Makefile
@@ -16,11 +16,13 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
GNU_CONFIGURE= yes
CONFIGURE_ENV= IRCLIB="${IRCLIB}"
+USE_REINPLACE= yes
IRCLIB= ${PREFIX}/share/ninja
post-patch:
- @${PERL} -e "s|%%IRCLIB%%|${IRCLIB}|g" ${WRKSRC}/include/config.h.dist
+ @${REINPLACE_CMD} -e "s|%%IRCLIB%%|${IRCLIB}|g" \
+ ${WRKSRC}/include/config.h.dist
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ninja ${PREFIX}/bin