aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-09-09 01:53:13 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-09-09 01:53:13 +0800
commit221fee9a39f1cfddd1f62cbd267aba07be58634d (patch)
tree914b141bd61b1d5d7ca3d55279784821424066e3 /irc
parentf51ca6ad364b345262ea975f9151da770729f9eb (diff)
downloadfreebsd-ports-gnome-221fee9a39f1cfddd1f62cbd267aba07be58634d.tar.gz
freebsd-ports-gnome-221fee9a39f1cfddd1f62cbd267aba07be58634d.tar.zst
freebsd-ports-gnome-221fee9a39f1cfddd1f62cbd267aba07be58634d.zip
- Fix build WITHOUT=EXAMPLES
- While here, fix LICENSE, add LICENSE_FILE, switch to USES=ssl, switch to options helpers, unsilence installation PR: 207283 Submitted by: samorders@gmail.com Approved by: maintainer timeout (swills, 6 months)
Diffstat (limited to 'irc')
-rw-r--r--irc/bip/Makefile24
-rw-r--r--irc/bip/pkg-plist4
2 files changed, 12 insertions, 16 deletions
diff --git a/irc/bip/Makefile b/irc/bip/Makefile
index 660f36a0431b..767dfab276d7 100644
--- a/irc/bip/Makefile
+++ b/irc/bip/Makefile
@@ -9,17 +9,16 @@ MASTER_SITES= https://projects.duckcorp.org/attachments/download/61/
MAINTAINER= swills@FreeBSD.org
COMMENT= Simple IRC proxy with SSL support
-LICENSE= GPLv2
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -Wno-sign-compare -Wno-error
-USES= cpe gmake
+USES= cpe gmake ssl
CPE_VENDOR= duckcorp
INSTALL_TARGET= SUBDIR=src install-exec
-USE_OPENSSL= yes
-
PATCH_STRIP= -p1
SUB_FILES= pkg-message
@@ -28,25 +27,22 @@ EXAMPLEFILES= bip.conf bip.vim
OPTIONS_DEFINE= DOCS EXAMPLES
-.include <bsd.port.options.mk>
-
post-install:
- @cd ${WRKSRC} && ${INSTALL} bip.1 ${STAGEDIR}${PREFIX}/man/man1
- @cd ${WRKSRC} && ${INSTALL} bipmkpw.1 ${STAGEDIR}${PREFIX}/man/man1
- @cd ${WRKSRC} && ${INSTALL} bip.conf.5 ${STAGEDIR}${PREFIX}/man/man5
+ ${INSTALL_MAN} ${WRKSRC}/bip.1 ${STAGEDIR}${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/bipmkpw.1 ${STAGEDIR}${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/bip.conf.5 ${STAGEDIR}${PREFIX}/man/man5
-.if ${PORT_OPTIONS:MDOCS}
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for docs in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${docs} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for i in ${EXAMPLEFILES}
${INSTALL_DATA} ${WRKSRC}/samples/${i} ${STAGEDIR}${EXAMPLESDIR}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/irc/bip/pkg-plist b/irc/bip/pkg-plist
index af5153841691..727dfebcc051 100644
--- a/irc/bip/pkg-plist
+++ b/irc/bip/pkg-plist
@@ -3,5 +3,5 @@ bin/bipmkpw
man/man1/bip.1.gz
man/man1/bipmkpw.1.gz
man/man5/bip.conf.5.gz
-%%EXAMPLESDIR%%/bip.conf
-%%EXAMPLESDIR%%/bip.vim
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bip.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bip.vim