aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
committertcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
commit2a8bcfc8ea71d4438b926a8adc477de360863145 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /irc
parent62341874a942de5989d54a3ba471cb8719d251ee (diff)
downloadfreebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.gz
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.zst
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Diffstat (limited to 'irc')
-rw-r--r--irc/dxirc/Makefile10
-rw-r--r--irc/konversation/Makefile4
-rw-r--r--irc/kvirc/Makefile10
-rw-r--r--irc/quassel/Makefile17
4 files changed, 23 insertions, 18 deletions
diff --git a/irc/dxirc/Makefile b/irc/dxirc/Makefile
index 414b7956dc32..c59e3f16f67a 100644
--- a/irc/dxirc/Makefile
+++ b/irc/dxirc/Makefile
@@ -40,12 +40,14 @@ NLS_CMAKE_BOOL= WITH_NLS
NOTIFY_RUN_DEPENDS= notify-send:devel/libnotify
-QT4_USE= QT4=corelib,gui,network \
- QT4=moc_build,rcc_build,uic_build,qmake_build
+QT4_USES= qt:4
+QT4_USE= QT=corelib,gui,network \
+ QT=moc_build,rcc_build,uic_build,qmake_build
QT4_CMAKE_ON= -DQT5:BOOL=OFF
-QT5_USE= QT5=core,gui,multimedia,network,widgets \
- QT5=buildtools_build,qmake_build
+QT5_USES= qt:5
+QT5_USE= QT=core,gui,multimedia,network,widgets \
+ QT=buildtools_build,qmake_build
QT5_CMAKE_ON= -DQT5:BOOL=ON
.include <bsd.port.mk>
diff --git a/irc/konversation/Makefile b/irc/konversation/Makefile
index 0183aadffa19..6ac71de925df 100644
--- a/irc/konversation/Makefile
+++ b/irc/konversation/Makefile
@@ -15,14 +15,14 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libqca-qt5.so:devel/qca@qt5
-USES= cmake:outsource desktop-file-utils gettext kde:5 python:run shebangfix tar:xz
+USES= cmake:outsource desktop-file-utils gettext kde:5 python:run qt:5 shebangfix tar:xz
USE_KDE= archive auth bookmarks codecs completion config \
configwidgets coreaddons crash dbusaddons doctools ecm \
emoticons globalaccel i18n iconthemes idletime itemviews \
jobwidgets kio notifications notifyconfig parts service solid \
sonnet textwidgets wallet widgetsaddons windowsystem xmlgui \
init_run
-USE_QT5= core dbus gui network phonon4 widgets xml \
+USE_QT= core dbus gui network phonon4 widgets xml \
buildtools_build qmake_build
SHEBANG_FILES= data/scripts/bug \
diff --git a/irc/kvirc/Makefile b/irc/kvirc/Makefile
index 2633dd74499f..1c631c00f14b 100644
--- a/irc/kvirc/Makefile
+++ b/irc/kvirc/Makefile
@@ -19,9 +19,9 @@ MAINTAINER= ports@FreeBSD.org
COMMENT?= IRC client for KDE 4
USE_PERL5= build
-USE_QT4= moc_build qmake_build rcc_build uic_build \
+USE_QT= moc_build qmake_build rcc_build uic_build \
dbus gui network sql xml
-USES= cmake cpe gettext perl5 ssl tar:bzip2
+USES= cmake cpe gettext perl5 qt:4 ssl tar:bzip2
CMAKE_ARGS= -DWANT_ESD=no -DWANT_DOXYGEN=no \
-DMANDIR=${MANPREFIX}
USE_LDCONFIG= yes
@@ -56,11 +56,13 @@ PLIST_SUB+= QT="" KDE="@comment "
OPTIONS_DEFINE+= PHONON WEBKIT
PHONON_DESC= Build with Phonon support
-PHONON_USE= QT4=phonon
+PHONON_USES= qt:4
+PHONON_USE= QT=phonon
PHONON_CMAKE_OFF= -DWITHOUT_PHONON=yes
WEBKIT_DESC= Build with QtWebkit support
-WEBKIT_USE= QT4=webkit
+WEBKIT_USES= qt:4
+WEBKIT_USE= QT=webkit
WEBKIT_CMAKE_OFF= -DWITHOUT_QTWEBKIT=yes
.else #defined(PKGNAMESUFFIX)
CONFLICTS_INSTALL= kvirc-qt4-4.*
diff --git a/irc/quassel/Makefile b/irc/quassel/Makefile
index 9fac71e734e9..2203124d4088 100644
--- a/irc/quassel/Makefile
+++ b/irc/quassel/Makefile
@@ -13,12 +13,12 @@ COMMENT?= Qt 5 based distributed IRC client (client and monolithic binary)
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake:outsource compiler:c++11-lib cpe pkgconfig tar:bzip2
+USES= cmake:outsource compiler:c++11-lib cpe pkgconfig qt:5 tar:bzip2
CPE_VENDOR= quassel-irc
CPE_PRODUCT= quassel_irc
-USE_QT5= buildtools_build core network qmake_build
+USE_QT= buildtools_build core network qmake_build
CMAKE_ARGS= -DWITH_KDE=off \
-DUSE_QT5=on
@@ -33,12 +33,12 @@ OPTIONS_SUB= yes
CLIENT_DESC= Quassel client (for use with core)
CLIENT_CMAKE_BOOL= WANT_QTCLIENT
-CLIENT_USE= qt5=dbus,gui,phonon4,webkit,widgets
+CLIENT_USE= qt=dbus,gui,phonon4,webkit,widgets
CLIENT_LIB_DEPENDS= libdbusmenu-qt5.so:devel/libdbusmenu-qt@qt5
CORE_DESC= Quassel core server (for use with client)
CORE_CMAKE_BOOL= WANT_CORE
-CORE_USE= qt5=script,sql
+CORE_USE= qt=script,sql
CORE_LIB_DEPENDS= libqca-qt5.so:devel/qca@qt5
CORE_SUB_FILES= pkg-message
CORE_VARS= use_rc_subr=quasselcore \
@@ -49,14 +49,15 @@ CORE_PLIST_FILES= bin/quasselcore
MONO_DESC= Quassel standalone (monolithic binary: core+client combined)
MONO_CMAKE_BOOL= WANT_MONO
-MONO_USE= qt5=script,sql
+MONO_USE= qt=script,sql
MONO_LIB_DEPENDS= libqca-qt5.so:devel/qca@qt5
-NLS_USE= QT5=linguisttools_build
+NLS_USES= qt:5
+NLS_USE= QT=linguisttools_build
-PGSQL_USE= qt5=sql-pgsql
+PGSQL_USE= qt=sql-pgsql
-SQLITE3_USE= qt5=sql-sqlite3_run
+SQLITE3_USE= qt=sql-sqlite3_run
post-patch-NLS-off:
${REINPLACE_CMD} -e '/add_subdirectory(po)/d' \