aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-11-30 23:50:30 +0800
committermat <mat@FreeBSD.org>2017-11-30 23:50:30 +0800
commit32512cab3e8dd90b7cd0525bb5dc98007db431e2 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /irc
parentb4ddc365e88ebdb48627086b02365b74119cf189 (diff)
downloadfreebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.tar.gz
freebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.tar.zst
freebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Diffstat (limited to 'irc')
-rw-r--r--irc/bitlbee/Makefile2
-rw-r--r--irc/py-fishcrypt/Makefile5
-rw-r--r--irc/py-irc/Makefile12
-rw-r--r--irc/py-limnoria/Makefile20
-rw-r--r--irc/py-supybot/Makefile2
-rw-r--r--irc/znc/Makefile2
6 files changed, 22 insertions, 21 deletions
diff --git a/irc/bitlbee/Makefile b/irc/bitlbee/Makefile
index 2f43a5f143ef..fc499a6bd023 100644
--- a/irc/bitlbee/Makefile
+++ b/irc/bitlbee/Makefile
@@ -83,7 +83,7 @@ OTR_LIB_DEPENDS= libotr.so.5:security/libotr \
libgpg-error.so:security/libgpg-error
SKYPE_CONFIGURE_ON= --skype=1
SKYPE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Skype4Py>0:net-im/py-skype4py
-SKYPE_USES= python
+SKYPE_USES= python:2.7
TWITTER_CONFIGURE_OFF= --twitter=0
YAHOO_CONFIGURE_OFF= --yahoo=0
diff --git a/irc/py-fishcrypt/Makefile b/irc/py-fishcrypt/Makefile
index 5fe24000b4aa..ac3f942affee 100644
--- a/irc/py-fishcrypt/Makefile
+++ b/irc/py-fishcrypt/Makefile
@@ -11,8 +11,8 @@ DIST_SUBDIR= python
MAINTAINER= nemysis@FreeBSD.org
COMMENT= FiSH/Mircryption-compatible encryption for XChat/HexChat
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycrypto>=0:security/py-pycrypto \
- ${PYTHON_PKGNAMEPREFIX}pysocks>=0:net/py-pysocks
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycrypto>=0:security/py-pycrypto@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pysocks>=0:net/py-pysocks@${FLAVOR}
USE_GITHUB= yes
GH_ACCOUNT= fladd
@@ -20,6 +20,7 @@ GH_PROJECT= py-${PORTNAME}
GH_TAGNAME= 43554b1a
USES= dos2unix python:run shebangfix
+USE_PYTHON= flavors
SHEBANG_FILES= fishcrypt.py
NO_BUILD= yes
diff --git a/irc/py-irc/Makefile b/irc/py-irc/Makefile
index 9fac59e2a8cc..a1e2c6931453 100644
--- a/irc/py-irc/Makefile
+++ b/irc/py-irc/Makefile
@@ -13,12 +13,12 @@ COMMENT= IRC protocol client library for Python
LICENSE= MIT
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hgtools>0:devel/py-hgtools \
- ${PYTHON_PKGNAMEPREFIX}pytest-runner>0:devel/py-pytest-runner \
- ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six \
- ${PYTHON_PKGNAMEPREFIX}jaraco.util>0:devel/py-jaraco.util \
- ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hgtools>0:devel/py-hgtools@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-runner>0:devel/py-pytest-runner@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jaraco.util>0:devel/py-jaraco.util@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${FLAVOR}
USES= python shebangfix
USE_PYTHON= distutils autoplist
diff --git a/irc/py-limnoria/Makefile b/irc/py-limnoria/Makefile
index fa99f4290829..99917bb961c1 100644
--- a/irc/py-limnoria/Makefile
+++ b/irc/py-limnoria/Makefile
@@ -12,7 +12,7 @@ COMMENT= Modified version of Supybot (IRC bot and framework)
LICENSE= BSD3CLAUSE
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}feedparser>=0:textproc/py-feedparser
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}feedparser>=0:textproc/py-feedparser@${FLAVOR}
OPTIONS_DEFINE= ECDSA PROXY
OPTIONS_DEFAULT= ECDSA ENCODING RSS TIME
@@ -34,17 +34,17 @@ TIME_DESC= Time Plugin: Extra time features (via dateutil/pytz)
SQLALCHEMY_DESC= SQLAlchemy database support
-ECDSA_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ecdsa>0:security/py-ecdsa
-PROXY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pysocks>=0:net/py-pysocks
+ECDSA_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ecdsa>0:security/py-ecdsa@${FLAVOR}
+PROXY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pysocks>=0:net/py-pysocks@${FLAVOR}
-ENCODING_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}chardet>=0:textproc/py-chardet
-GPG_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-gnupg>=0:security/py-python-gnupg
-RSS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}feedparser>=0:textproc/py-feedparser
-TIME_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil \
- ${PYTHON_PKGNAMEPREFIX}pytz>=0:devel/py-pytz
+ENCODING_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}chardet>=0:textproc/py-chardet@${FLAVOR}
+GPG_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-gnupg>=0:security/py-python-gnupg@${FLAVOR}
+RSS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}feedparser>=0:textproc/py-feedparser@${FLAVOR}
+TIME_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytz>=0:devel/py-pytz@${FLAVOR}
-SQLITE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3
-SQLALCHEMY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy10>0:databases/py-sqlalchemy10
+SQLITE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${FLAVOR}
+SQLALCHEMY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy10>0:databases/py-sqlalchemy10@${FLAVOR}
USES= python
USE_PYTHON= autoplist concurrent distutils
diff --git a/irc/py-supybot/Makefile b/irc/py-supybot/Makefile
index d326e69eb0e5..cbc13614ada9 100644
--- a/irc/py-supybot/Makefile
+++ b/irc/py-supybot/Makefile
@@ -15,7 +15,7 @@ COMMENT= Supybot - A Superb Python IRC bot
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python tar:bzip2
+USES= python:2.7 tar:bzip2
USE_PYTHON= distutils
PYDISTUTILS_PKGVERSION= 0.83.1+darcs
PYDISTUTILS_EGGINFO= supybot-${PORTVERSION}-py${PYTHON_VER}.egg-info
diff --git a/irc/znc/Makefile b/irc/znc/Makefile
index d2f08cb358ce..d13769ff7dce 100644
--- a/irc/znc/Makefile
+++ b/irc/znc/Makefile
@@ -54,7 +54,7 @@ PERL_USES= perl5
PYTHON_BUILD_DEPENDS= swig30>=3.0.0:devel/swig30
PYTHON_CONFIGURE_ON= --enable-python=python-${PYTHON_VER} --enable-swig
PYTHON_USE= perl5=build
-PYTHON_USES= perl5 python:3
+PYTHON_USES= perl5 python:3.4+
TCL_CONFIGURE_ENABLE= tcl
TCL_CONFIGURE_ON= --with-tcl=${TCL_LIBDIR}
TCL_USES= tcl