aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2018-12-31 23:13:43 +0800
committerdinoex <dinoex@FreeBSD.org>2018-12-31 23:13:43 +0800
commitb9f39b41f2030166ba4a33985e04c31b606dfb3f (patch)
tree66604aa24f28429cb44ea2c361b196266dc71690 /irc
parentaf20fc304e0e03809df9de442a189c5805cbc64d (diff)
downloadfreebsd-ports-gnome-b9f39b41f2030166ba4a33985e04c31b606dfb3f.tar.gz
freebsd-ports-gnome-b9f39b41f2030166ba4a33985e04c31b606dfb3f.tar.zst
freebsd-ports-gnome-b9f39b41f2030166ba4a33985e04c31b606dfb3f.zip
iroffer-dinoex
- update to 3.31 - update homepage
Diffstat (limited to 'irc')
-rw-r--r--irc/iroffer-dinoex/Makefile7
-rw-r--r--irc/iroffer-dinoex/distinfo5
-rw-r--r--irc/iroffer-dinoex/files/patch-Configure32
-rw-r--r--irc/iroffer-dinoex/files/patch-upnp.c34
-rw-r--r--irc/iroffer-dinoex/pkg-descr2
5 files changed, 8 insertions, 72 deletions
diff --git a/irc/iroffer-dinoex/Makefile b/irc/iroffer-dinoex/Makefile
index a0dd8e282e0c..84c89722eac4 100644
--- a/irc/iroffer-dinoex/Makefile
+++ b/irc/iroffer-dinoex/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= iroffer
-PORTVERSION= 3.30
-PORTREVISION= 3
+PORTVERSION= 3.31
CATEGORIES= irc
MASTER_SITES= http://iroffer.dinoex.net/
PKGNAMESUFFIX= -dinoex${PKGNAMESUFFIX2}
@@ -15,6 +14,7 @@ LICENSE= GPLv2
CONFLICTS= iroffer-1* iroffer-lamm-1.*
+USES= ssl
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Configure
CONFIGURE_ARGS= CC="${CC}" LDFLAGS="${LDFLAGS}" LOCALBASE="${LOCALBASE}"
@@ -45,7 +45,8 @@ OPTIONS_DEFAULT=CURL RUBY UPNP GEOIP
CURL_LIB_DEPENDS= libcurl.so:ftp/curl
CURL_CONFIGURE_ON= -curl
RUBY_USE= RUBY=yes
-RUBY_LIB_DEPENDS= lib${RUBY_NAME}.so:${RUBY_PORT}
+RUBY_LIB_DEPENDS= lib${RUBY_NAME}.so:${RUBY_PORT} \
+ libunwind.so:devel/libunwind
RUBY_CONFIGURE_ON= -ruby
UPNP_LIB_DEPENDS= libminiupnpc.so:net/miniupnpc
UPNP_CONFIGURE_ON= -upnp
diff --git a/irc/iroffer-dinoex/distinfo b/irc/iroffer-dinoex/distinfo
index 215ea3b630be..90ec64f38cab 100644
--- a/irc/iroffer-dinoex/distinfo
+++ b/irc/iroffer-dinoex/distinfo
@@ -1,2 +1,3 @@
-SHA256 (iroffer-dinoex-3.30.tar.gz) = c6ccc5d720e6d9cd797996b133d95a28f9e668f998d7c6c0b34098c2f805f072
-SIZE (iroffer-dinoex-3.30.tar.gz) = 541131
+TIMESTAMP = 1546269075
+SHA256 (iroffer-dinoex-3.31.tar.gz) = 910e7b523af63ebfefd074f96164e649767a9954ab9de2c13f4452a344f3a613
+SIZE (iroffer-dinoex-3.31.tar.gz) = 527712
diff --git a/irc/iroffer-dinoex/files/patch-Configure b/irc/iroffer-dinoex/files/patch-Configure
deleted file mode 100644
index 27f4e90ce23e..000000000000
--- a/irc/iroffer-dinoex/files/patch-Configure
+++ /dev/null
@@ -1,32 +0,0 @@
-Index: Configure
-===================================================================
-RCS file: /usr/home/public/iroffer/Configure,v
-retrieving revision 1.255
-retrieving revision 1.256
-diff -u -r1.255 -r1.256
---- Configure 3 Mar 2015 21:06:37 -0000 1.255
-+++ Configure 13 Oct 2015 18:28:17 -0000 1.256
-@@ -860,7 +860,7 @@
- fi
- else
- ${msg} "${irt_notfound}. ${irt_error} ${irt_nocc}"
-- maketype="gcc"
-+ cctype="gcc"
- waserror
- fi
- fi
-@@ -1654,10 +1654,14 @@
- #include <miniupnpc/miniupnpc.h>
- #include <miniupnpc/upnpcommands.h>
- ${main1}
-+#if MINIUPNPC_API_VERSION >= 14
-+ upnpDiscover(2000, NULL, NULL, 0, 0, 2U, NULL);
-+#else
- #ifdef UPNPDISCOVER_SUCCESS
- upnpDiscover(2000, NULL, NULL, 0, 0, NULL);
- #else
- upnpDiscover(2000, NULL, NULL, 0);
-+#endif /* UPNPDISCOVER_SUCCESS */
- #endif
- ${main2}" > config.temp.c
- if $cctype -o config.temp -DUSE_UPNP $WARNS $WERROR $CFLAGS "-I${LOCALBASE}/include" config.temp.c "-L${LOCALBASE}/lib" -lminiupnpc $LDFLAGS $libs $LIBS; then
diff --git a/irc/iroffer-dinoex/files/patch-upnp.c b/irc/iroffer-dinoex/files/patch-upnp.c
deleted file mode 100644
index 35e0e8f9a155..000000000000
--- a/irc/iroffer-dinoex/files/patch-upnp.c
+++ /dev/null
@@ -1,34 +0,0 @@
---- src/upnp.c.orig 2013-02-13 21:06:15.000000000 +0100
-+++ src/upnp.c 2016-12-25 23:05:37.702936000 +0100
-@@ -60,11 +60,15 @@
- tostdout_write();
- memset(&urls, 0, sizeof(struct UPNPUrls));
- memset(&data, 0, sizeof(struct IGDdatas));
-+#if MINIUPNPC_API_VERSION >= 14
-+ devlist = upnpDiscover(2000, NULL, NULL, 0, 0, 2U, NULL);
-+#else
- #ifdef UPNPDISCOVER_SUCCESS
- devlist = upnpDiscover(2000, NULL, NULL, 0, 0, NULL);
- #else
- devlist = upnpDiscover(2000, NULL, NULL, 0);
- #endif /* UPNPDISCOVER_SUCCESS */
-+#endif
- if (devlist)
- {
- dev = devlist;
-@@ -81,11 +85,15 @@
- "UPnP device : desc: %s\n st: %s",
- dev->descURL, dev->st);
-
-+#if MINIUPNPC_API_VERSION >= 16
-+ descXML = miniwget(dev->descURL, &descXMLsize, 0, 0);
-+#else
- #if MINIUPNPC_API_VERSION >= 9
- descXML = miniwget(dev->descURL, &descXMLsize, 0);
- #else
- descXML = miniwget(dev->descURL, &descXMLsize);
- #endif
-+#endif
- if (descXML)
- {
- parserootdesc (descXML, descXMLsize, &data);
diff --git a/irc/iroffer-dinoex/pkg-descr b/irc/iroffer-dinoex/pkg-descr
index c790c972a670..c7760aee2080 100644
--- a/irc/iroffer-dinoex/pkg-descr
+++ b/irc/iroffer-dinoex/pkg-descr
@@ -7,4 +7,4 @@ It does support mutiple IRC networks, SSL and IPv6.
LICENSE: GPL2
-WWW: http://iroffer.dinoex.net/
+WWW: https://iroffer.net/