aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-02-08 11:14:14 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-02-08 11:14:14 +0800
commitbd70d01d2a5c5440ea5d31b2d677d007032b59c0 (patch)
tree3f0fd58dcf43de0c14cc57e54afaa7665237a89d /irc
parenta8cf6a846bc0ee3fa0044636828989fbf0a6d63b (diff)
downloadfreebsd-ports-gnome-bd70d01d2a5c5440ea5d31b2d677d007032b59c0.tar.gz
freebsd-ports-gnome-bd70d01d2a5c5440ea5d31b2d677d007032b59c0.tar.zst
freebsd-ports-gnome-bd70d01d2a5c5440ea5d31b2d677d007032b59c0.zip
- devel/libslang2 has completely replaced devel/libslang which has not been
released in ~5yrs. - WITH_SLANG2 is now no longer a valid ports knob - WITH_SLANG implies devel/libslang2 now - devel/libslang -> devel/libslang2 is a SHARED LIB bump so bump PORTREVISION for affected ports - Take MAINTAINER for most unmaintained ports in this chain - some SF macro conversions - BROKEN with devel/libslang2 and DEPRECATE math/slsc (abandoned upstream) - BROKEN with devel/libslang2 japanese/slirc PR: ports/125255 Reviewed by: garga (libslang maintainer), portmgr (pav) Exp Run by: pav
Diffstat (limited to 'irc')
-rw-r--r--irc/slirc/Makefile6
-rw-r--r--irc/slirc/files/patch-slirc.c93
-rw-r--r--irc/slirc/files/patch-vfile-module.c183
3 files changed, 272 insertions, 10 deletions
diff --git a/irc/slirc/Makefile b/irc/slirc/Makefile
index 2a81c8fb4367..84ef82c18769 100644
--- a/irc/slirc/Makefile
+++ b/irc/slirc/Makefile
@@ -7,13 +7,13 @@
PORTNAME= slirc
PORTVERSION= 0.12
-PORTREVISION= 1
+PORTREVISION= 2
# Assign with += for slave ports
CATEGORIES+= irc
MASTER_SITES= http://members.core.com/~stabro/
EXTRACT_SUFX= .tgz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= pgollucci@FreeBSD.org
COMMENT= A SLang-based IRC client
LIB_DEPENDS= ${LIB_DEPENDS_LIBSLANG}
@@ -24,7 +24,7 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
SLANG_INCDIR?= ${PREFIX}/include
SLANG_LIBDIR?= ${PREFIX}/lib
-LIB_DEPENDS_LIBSLANG?= slang.1:${PORTSDIR}/devel/libslang
+LIB_DEPENDS_LIBSLANG?= slang.2:${PORTSDIR}/devel/libslang2
MAKE_ARGS= SLANG_INCDIR="${SLANG_INCDIR}" \
SLANG_LIBDIR="${SLANG_LIBDIR}" \
diff --git a/irc/slirc/files/patch-slirc.c b/irc/slirc/files/patch-slirc.c
index 6534fe35650a..c76a11c95c72 100644
--- a/irc/slirc/files/patch-slirc.c
+++ b/irc/slirc/files/patch-slirc.c
@@ -1,5 +1,14 @@
---- slirc.c.orig Tue Aug 24 00:15:11 1999
-+++ slirc.c Sun Jan 7 03:17:46 2001
+--- ./slirc.c.orig 1999-08-23 11:15:11.000000000 -0400
++++ ./slirc.c 2009-01-18 22:11:53.000000000 -0500
+@@ -81,7 +81,7 @@
+ char buf[130];
+
+ sprintf(buf, "Caught sig %d (%s)", signum, Top2);
+- SLang_doerror(buf);
++ SLang_verror(signum, buf);
+ if (VF_reset) SLexecute_function(VF_reset);
+ exit(1);
+ }
@@ -242,7 +242,7 @@
{
char secs[8];
@@ -28,3 +37,83 @@
strcat(SLirc_Load_Path,SCRIPTPATH); /* SCRIPTPATH defined in Makefile */
}
+@@ -758,7 +760,7 @@
+ SLsmg_reset_smg();
+ SLang_reset_tty();
+ if (VF_reset) SLexecute_function(VF_reset);
+- SLang_doerror(st);
++ SLang_verror(SL_INTRINSIC_ERROR, st);
+ puts(st);
+ exit(1);
+ }
+@@ -774,8 +776,8 @@
+
+ static void ClearSomeErrors(void)
+ {
+- if (SLang_Error && SLang_Error != USER_BREAK) {
+- SLang_Error = 0;
++ if (USER_BREAK != SLang_get_error()) {
++ SLang_set_error(0);
+ SLsmg_touch_lines(0, SLtt_Screen_Rows);
+ SLirc_UpdateDisplay();
+ SLang_input_pending(20);
+@@ -1016,7 +1018,7 @@
+ SLtt_get_terminfo(); /* Get the terminal info. */
+ SLtt_Use_Ansi_Colors = 1;
+ if (-1 == SLkp_init()) {
+- SLang_doerror("SLkp_init failed.");
++ SLang_verror(SL_INTRINSIC_ERROR, "SLkp_init failed.");
+ exit(1);
+ }
+
+@@ -1026,7 +1028,7 @@
+ * (actually, opost's ignored in slang-1.0.3 )
+ */
+ if (-1 == SLang_init_tty(abort_char, 0, 0)) {
+- SLang_doerror("Unable to initialize the terminal.");
++ SLang_verror(SL_INTRINSIC_ERROR, "Unable to initialize the terminal.");
+ exit(1);
+ }
+ SLsmg_init_smg(); /* this does get_screen_size inside. */
+@@ -1073,9 +1075,9 @@
+ SetStatus("Loading SLirc init script...");
+ SLirc_UpdateDisplay();
+ SLang_load_file(argv[1] ? argv[1] : "init.sl");
+- if (SLang_Error) {
+- SLang_doerror("Oh, shit. Who fucked up that file, then?");
+- SLang_Error = 0;
++ if (SLang_get_error()) {
++ SLang_verror(SL_INTRINSIC_ERROR, "Oh, shit. Who fucked up that file, then?");
++ SLang_set_error(0);
+ }
+ SLtt_Use_Ansi_Colors = UseColours;
+ SLirc_UpdateDisplay();
+@@ -1087,7 +1089,7 @@
+ check_timed = SLang_get_function("check_timed");
+ if (!check_timed) Fatal("check_timed is undefined");
+ expiry = time(NULL)+5;
+- while (SLang_Error != USER_BREAK) {
++ while (USER_BREAK != SLang_get_error()) {
+ int r,stkdep;
+ unsigned int tim;
+
+@@ -1106,7 +1108,7 @@
+ tim = time(NULL);
+ if (tim<expiry) continue;
+ expiry += 5;
+- stkdep = _SLstack_depth();
++ stkdep = SLstack_depth();
+ r = SLexecute_function(check_timed);
+ if (r==-1) Fatal("SLexecute_function(check_timed)?");
+ # if 0
+@@ -1114,8 +1116,8 @@
+ if (!r) Fatal("check_timed is undefined");
+ # endif
+ SLirc_UpdateDisplay();
+- stkdep = _SLstack_depth() - stkdep; /* % items left on stack. */
+- if (stkdep && SLang_Error != USER_BREAK) {
++ stkdep = SLstack_depth() - stkdep; /* % items left on stack. */
++ if (stkdep && USER_BREAK != SLang_get_error()) {
+ SLang_verror(SL_APPLICATION_ERROR,
+ "Eeek... check_timed() left %d units on stack",stkdep);
+ if (stkdep>0) SLdo_pop_n(stkdep);
diff --git a/irc/slirc/files/patch-vfile-module.c b/irc/slirc/files/patch-vfile-module.c
index d3e3041e6375..ec942ed2be66 100644
--- a/irc/slirc/files/patch-vfile-module.c
+++ b/irc/slirc/files/patch-vfile-module.c
@@ -1,5 +1,178 @@
---- vfile-module.c.orig Tue Aug 24 00:08:56 1999
-+++ vfile-module.c Sat Jan 6 20:25:43 2001
-@@ -2067 +2067 @@
-- MAKE_ICONSTANT("O_SYNC", O_SYNC),
-+ MAKE_ICONSTANT("O_FSYNC", O_FSYNC),
+--- ./vfile-module.c.orig 2008-08-11 21:49:04.000000000 +0000
++++ ./vfile-module.c 2008-08-11 22:25:20.246320000 +0000
+@@ -97,13 +97,13 @@
+ int ct;
+
+ if (at->data_type != SLANG_CHAR_TYPE) {
+- SLang_doerror("Operation requires character array");
++ SLang_verror(SL_INTRINSIC_ERROR, "Operation requires character array");
+ return -1;
+ }
+
+ if (len<0) ct = at->num_elements;
+ else if (len > at->num_elements) {
+- SLang_doerror("Too much data for array size");
++ SLang_verror(SL_INTRINSIC_ERROR, "Too much data for array size");
+ return -1;
+ }else ct = len;
+ *data = at->data;
+@@ -446,11 +446,11 @@
+
+ VFerrno = 0;
+ if (t->fd < 0) {
+- /* SLang_doerror("file already closed"); */
++ /* SLang_verror(SL_INTRINSIC_ERROR,"file already closed"); */
+ r = 0; goto return_r;
+ }
+ if (t->rdvf || t->wrvf) {
+- SLang_doerror("You must set_wrdep(*,*,0) before close");
++ SLang_verror(SL_INTRINSIC_ERROR, "You must set_wrdep(*,*,0) before close");
+ goto return_r;
+ }
+ r = close(t->fd);
+@@ -1171,7 +1171,7 @@
+
+ l = t->rbuft - t->rbufr;
+ if (l <= 0) { /* shouldn't happen */
+- SLang_doerror("read_into_buf() called with window=0");
++ SLang_verror(SL_INTRINSIC_ERROR,"read_into_buf() called with window=0");
+ return -1;
+ }
+ if (t->fd < 0 || t->flags & SJ_EOF) return 0; /* also shouldn't happen */
+@@ -1209,7 +1209,7 @@
+
+ if (!l || t->rtermn < 0 || !(m = t->rbufr - t->rbufq)) goto dflt_ret;
+ if (t->rbufq < t->rbufp) {
+- SLang_doerror("q<p");
++ SLang_verror(SL_INTRINSIC_ERROR, "q<p");
+ t->rbufq = t->rbufp;
+ }
+ if ( (cp = (char*)memchr(t->rbufq,t->rtermn,m))
+@@ -1259,7 +1259,7 @@
+
+ /*fprintf(stderr,"fd=%d, rthrsh=%d, bytes=%d\n",t->fd,t->rthrsh,t->rbufr-t->rbufp); */
+ if (t->fd < 0) {
+- SLang_doerror("Read on closed VFile");
++ SLang_verror(SL_INTRINSIC_ERROR, "Read on closed VFile");
+ goto return_r;
+ }
+
+@@ -1364,7 +1364,7 @@
+
+ if (!(mmt = pop_vfd(SJ_WRITE, &t))) goto free_fail; /* ct = -1 */
+ if (t->fd < 0) {
+- SLang_doerror("Write on closed VFile");
++ SLang_verror(SL_INTRINSIC_ERROR, "Write on closed VFile");
+ goto free_fail;
+ }
+
+@@ -1420,7 +1420,7 @@
+ if (!(wr_mmt = pop_vfd(SJ_WRITE, &wt))) goto free1;
+
+ if (wt != rt->wrvf || rt != wt->rdvf) {
+- SLang_doerror("copybytes filepair not linked by set_wrdep()");
++ SLang_verror(SL_INTRINSIC_ERROR, "copybytes filepair not linked by set_wrdep()");
+ goto free2;
+ }
+
+@@ -1469,7 +1469,7 @@
+ if (!(mmt = pop_vfd(SJ_READ, &t))) return -1; /* ct = -1 */
+
+ if (t->fd < 0) {
+- SLang_doerror("Read on closed VFile");
++ SLang_verror(SL_INTRINSIC_ERROR,"Read on closed VFile");
+ r = -1; goto return_r;
+ }
+ r = check_buf_data(t);
+@@ -1672,7 +1672,7 @@
+ fnt = SLang_get_function(func_name);
+ if (!fnt) {r = -2; goto return_r;}
+ if (t->fd < 0) {
+- SLang_doerror("Can't set_action() on closed VFile");
++ SLang_verror(SL_INTRINSIC_ERROR,"Can't set_action() on closed VFile");
+ r = -3; goto return_r;
+ }
+ }
+@@ -1720,7 +1720,7 @@
+ ) return -1;
+
+ if (t->flags & SJ_UDP) {
+- SLang_doerror("only default (unbuffered) rmode makes sense for UDP");
++ SLang_verror(SL_INTRINSIC_ERROR,"only default (unbuffered) rmode makes sense for UDP");
+ r = -1; goto return_r;
+ }
+
+@@ -1729,7 +1729,7 @@
+ if (!ct) {
+ if (t->rthrsh) { /* changing from buffered to unbuffered */
+ if (t->rbufr > t->rbufp) {
+- SLang_doerror("must read data before switching to unbuffered mode");
++ SLang_verror(SL_INTRINSIC_ERROR,"must read data before switching to unbuffered mode");
+ r = -1; goto return_r;
+ }
+ SLfree(t->rbuf0);
+@@ -1737,7 +1737,7 @@
+ vfile_list_dirty = 1; /* just t */
+ }
+ if (ch>=0) {
+- SLang_doerror("termination char ignored in unbuffered mode");
++ SLang_verror(SL_INTRINSIC_ERROR,"termination char ignored in unbuffered mode");
+ ch = -1;
+ }
+ }
+@@ -1802,12 +1802,12 @@
+ stkdep = _SLstack_depth() - stkdep; /* % items left on stack. */
+ /* for some reason, this next seems to cause segfault when */
+ /* used from ./vf and do_actions() is called in SLang ?! */
+- if (stkdep && SLang_Error != USER_BREAK) {
++ if (stkdep && USER_BREAK != SLang_get_error()) {
+ SLang_verror(SL_APPLICATION_ERROR,
+ "Eeek... %s() left %d units on stack",t->fns[i]->name,stkdep);
+ if (stkdep>0) {
+ SLdo_pop_n(stkdep);
+- SLang_Error = 0; /* probably safe to keep going */
++ SLang_set_error(0); /* probably safe to keep going */
+ }
+ }
+
+@@ -1840,7 +1840,7 @@
+ ct++;
+ do_action_i(t,0);
+ if (t->fd >= 0 && t->fns[0] && rbufp == t->rbufp && check_buf_data(t) >= 0) {
+- SLang_doerror("read-action did not handle data");
++ SLang_verror(SL_INTRINSIC_ERROR,"read-action did not handle data");
+ t->fns[0] = NULL; /* this to radically kill it */
+ }
+ }while (!vfile_list_dirty && t != tn);
+@@ -1868,7 +1868,7 @@
+ static fd_set fds[3]; /* a big one, we could malloc */
+
+ if (do_actions_dep++) { /* we are NOT recursive! */
+- SLang_doerror("Can't call do_actions() recursively");
++ SLang_verror(SL_INTRINSIC_ERROR,"Can't call do_actions() recursively");
+ goto return_ct;
+ }
+ /*tim = (int)time(NULL); */
+@@ -2133,8 +2133,8 @@
+ {
+ SLang_Class_Type *cl;
+
+- if (SLclass_add_typecast(SLANG_CHAR_TYPE, SLANG_INT_TYPE, char_to_int, 1)
+- || SLclass_add_typecast(SLANG_INT_TYPE, SLANG_CHAR_TYPE, int_to_char, 1))
++ if (SLclass_add_typecast(SLANG_CHAR_TYPE, SLANG_INT_TYPE, char_to_int, 1)
++ || SLclass_add_typecast(SLANG_INT_TYPE, SLANG_CHAR_TYPE, int_to_char, 1))
+ {
+ fprintf(stderr,"VFile: fail add_typecast(CHAR<->INT)\n");
+ return -1;
+@@ -2151,8 +2151,9 @@
+
+ if (NULL == (cl = SLclass_allocate_class("VFile_Type")))
+ return -1;
+- cl->cl_destroy = destroy_vfile_type;
+- cl->cl_string = vfile_string;
++ SLclass_set_destroy_function(cl, destroy_vfile_type);
++ SLclass_set_string_function(cl, vfile_string);
++
+ if (-1 == SLclass_register_class(cl, SJ_VFILE_TYPE, sizeof(VFILE), SLANG_CLASS_TYPE_MMT))
+ return -1;
+