aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2013-05-05 06:48:03 +0800
committerflo <flo@FreeBSD.org>2013-05-05 06:48:03 +0800
commit02ba370ac4348e20c88c9698d4e91f3fe34868c8 (patch)
treeab399d9912d8f00891d9d8508edf96aa3ef0bc0b /irc
parentab79042bad4c4010d43e6983f39a47e3575126a5 (diff)
downloadfreebsd-ports-gnome-02ba370ac4348e20c88c9698d4e91f3fe34868c8.tar.gz
freebsd-ports-gnome-02ba370ac4348e20c88c9698d4e91f3fe34868c8.tar.zst
freebsd-ports-gnome-02ba370ac4348e20c88c9698d4e91f3fe34868c8.zip
Fix installation of ports that rely on cp -n for installing files. r245960
changed cp to exit with a non-zero exit code if the file exists and is not overwritten thus causing ports to fail installing when e.g. trying to cp .default -> .conf files that already exist. We just ignore the error and continue, as we used to. Reported by: jaset Approved by: portmgr (bapt)
Diffstat (limited to 'irc')
-rw-r--r--irc/darkbot/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/irc/darkbot/Makefile b/irc/darkbot/Makefile
index 38b7253d7549..a253489c6620 100644
--- a/irc/darkbot/Makefile
+++ b/irc/darkbot/Makefile
@@ -35,12 +35,12 @@ post-install:
cd ${WRKSRC}/dat; \
for file in *; do \
${INSTALL_DATA} $$file ${ETCDIR}/dat/$${file}.dist; \
- ${CP} -np ${ETCDIR}/dat/$${file}.dist ${ETCDIR}/dat/$$file; \
+ ${CP} -np ${ETCDIR}/dat/$${file}.dist ${ETCDIR}/dat/$$file || ${TRUE} ; \
${ECHO_CMD} "@unexec cmp -s ${ETCDIR}/dat/$$file \
${ETCDIR}/dat/$${file}.dist && \
rm -f ${ETCDIR}/dat/$$file || true" >> ${TMPPLIST}; \
${ECHO_CMD} "${ETCDIR_REL}/dat/$${file}.dist" >> ${TMPPLIST}; \
- ${ECHO_CMD} "@exec cp -np %D/%F %B/$$file" >> ${TMPPLIST}; \
+ ${ECHO_CMD} "@exec cp -np %D/%F %B/$$file || true" >> ${TMPPLIST}; \
done
${ECHO_CMD} "@unexec rmdir ${ETCDIR}/logs 2>/dev/null || true" >> ${TMPPLIST}
${ECHO_CMD} "@unexec rmdir ${ETCDIR}/dat 2>/dev/null || true" >> ${TMPPLIST}