aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-09-01 22:11:52 +0800
committerkrion <krion@FreeBSD.org>2004-09-01 22:11:52 +0800
commit68c3cb71120554db2ce88f5e65d40a6703dbbbb4 (patch)
tree91a10a27f9f0ac8e2f8ee80a5eabf00a2884dfe8 /irc
parentcc27914c1b5bb8d8c018470d49315b2fe01a0a00 (diff)
downloadfreebsd-ports-gnome-68c3cb71120554db2ce88f5e65d40a6703dbbbb4.tar.gz
freebsd-ports-gnome-68c3cb71120554db2ce88f5e65d40a6703dbbbb4.tar.zst
freebsd-ports-gnome-68c3cb71120554db2ce88f5e65d40a6703dbbbb4.zip
Fix build with ident support.
Reported by: Martin Hasenbein <mh@bsd.net>
Diffstat (limited to 'irc')
-rw-r--r--irc/ngircd/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/irc/ngircd/Makefile b/irc/ngircd/Makefile
index f66b9aff0063..449276ccb108 100644
--- a/irc/ngircd/Makefile
+++ b/irc/ngircd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ngircd
PORTVERSION= 0.8.0
+PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= http://download.berlios.de/ngircd/ \
ftp://ftp.berlios.de/pub/ngircd/
@@ -16,6 +17,8 @@ COMMENT= Free open source daemon for Internet Relay Chat (IRC)
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
.if exists(/usr/include/tcpd.h)
WITH_TCP_WRAPPERS= yes
@@ -23,6 +26,7 @@ CONFIGURE_ARGS+= --with-tcp-wrappers
.endif
.if defined(WITH_IDENT)
+LIB_DEPENDS+= ident.0:${PORTSDIR}/security/libident
CONFIGURE_ARGS+= --with-ident
.endif