aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorwes <wes@FreeBSD.org>2002-04-23 06:18:03 +0800
committerwes <wes@FreeBSD.org>2002-04-23 06:18:03 +0800
commit06ead2ab93aac1aef798aff61e0b48042078325a (patch)
treee3796cfc0541e635fc307982a55e7c0af1ac22d8 /irc
parent77ae47d0e30c2e742a2bee309ffb1170e6857a9e (diff)
downloadfreebsd-ports-gnome-06ead2ab93aac1aef798aff61e0b48042078325a.tar.gz
freebsd-ports-gnome-06ead2ab93aac1aef798aff61e0b48042078325a.tar.zst
freebsd-ports-gnome-06ead2ab93aac1aef798aff61e0b48042078325a.zip
Muh released an update with a critical format string correction
that was remotely exploitable. This change updates the port to the corrected version. The patchfile in the previous port corrected some, but not all, of the vulnerability. Maintainer timeout: BillF was unresponsive after 9 days, Debolaz requested the port be fixed or marked broken via IRC. PR: ports/37048 Submitted by: Geir RĂ¥ness <pulz@pulz.no> Requested by: Debolaz <debolaz@debolaz.com>
Diffstat (limited to 'irc')
-rw-r--r--irc/muh/Makefile5
-rw-r--r--irc/muh/distinfo2
-rw-r--r--irc/muh/files/patch-aa29
3 files changed, 4 insertions, 32 deletions
diff --git a/irc/muh/Makefile b/irc/muh/Makefile
index bd1e364dbbd0..c2c8125fa748 100644
--- a/irc/muh/Makefile
+++ b/irc/muh/Makefile
@@ -7,9 +7,10 @@
PORTNAME= muh
PORTVERSION= 2.05d
+PORTREVISION= 1
+DISTNAME= muh-2.05d-fixed
CATEGORIES= irc
-MASTER_SITES= http://mind.riot.org/muh/download/
-DISTNAME= ${PORTNAME}${PORTVERSION}
+MASTER_SITES= http://prdownloads.sourceforge.net/muh/
MAINTAINER= billf@FreeBSD.org
diff --git a/irc/muh/distinfo b/irc/muh/distinfo
index 9851a0bee386..f26ddcaff6c9 100644
--- a/irc/muh/distinfo
+++ b/irc/muh/distinfo
@@ -1 +1 @@
-MD5 (muh2.05d.tar.gz) = c96cdb565e4fc2cca5b9db5a45d41190
+MD5 (muh-2.05d-fixed.tar.gz) = 0d3cd659d89983fb58dc89f531c1b3e8
diff --git a/irc/muh/files/patch-aa b/irc/muh/files/patch-aa
deleted file mode 100644
index 234ea1f41b32..000000000000
--- a/irc/muh/files/patch-aa
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/muh.c.orig Sun Mar 19 04:08:27 2000
-+++ src/muh.c Sat Sep 9 21:32:15 2000
-@@ -575,7 +575,7 @@
- if( strcmp( param2 + 2, "USERINFO\1" ) == 0 )
- irc_notice( &c_server, nick, USERINFOREPLY );
- if( strncmp( param2 + 2, "PING", 4 ) == 0 ) {
-- if( strlen( param2 + 1 ) > 6 ) irc_notice( &c_server, nick, param2 + 1 );
-+ if( strlen( param2 + 1 ) > 6 ) irc_notice( &c_server, nick, "%s", param2 + 1 );
- }
- if( strcmp( param2 + 2, "CLIENTINFO\1" ) == 0 )
- irc_notice( &c_server, nick, CLIENTINFOREPLY );
-@@ -591,7 +591,7 @@
- }
- else { /* normale message/notice */
- if( !is_ignore( hostname, IGNORE_MESSAGE ) && status.allowreply ) {
-- if( cfg.awaynotice ) irc_notice( &c_server, nick, cfg.awaynotice );
-+ if( cfg.awaynotice ) irc_notice( &c_server, nick, "%s", cfg.awaynotice );
- add_ignore( hostname, 120, IGNORE_MESSAGE );
- status.allowreply = 0;
- timers.reply = 0;
-@@ -841,7 +841,7 @@
- s = ( char * )malloc( 1024 );
- while( fgets( s, 1023, messagelog ) ) {
- if( s[ strlen( s ) - 1 ] == '\n' ) s[ strlen( s ) - 1 ] = 0;
-- irc_notice( &c_client, status.nickname, s );
-+ irc_notice( &c_client, status.nickname, "%s", s );
- }
- FREESTRING( s );
-