aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorjase <jase@FreeBSD.org>2013-09-01 06:47:13 +0800
committerjase <jase@FreeBSD.org>2013-09-01 06:47:13 +0800
commit09a4219e0300522aac4452dab27e5b9e325e66e2 (patch)
tree9e0089de721098c2e9492db6b1561c8182057550 /irc
parentfb38ccfb5e3158697fb1b1b6e87b98be2d4a5a79 (diff)
downloadfreebsd-ports-gnome-09a4219e0300522aac4452dab27e5b9e325e66e2.tar.gz
freebsd-ports-gnome-09a4219e0300522aac4452dab27e5b9e325e66e2.tar.zst
freebsd-ports-gnome-09a4219e0300522aac4452dab27e5b9e325e66e2.zip
- Update to 20130831
- Pet portlint(1) - whitespace nits in Makefile and pkg-descr - Fix a typo and grammar in pkg-descr - Add pkg-install which creates a symlink for renamed Weechat binary
Diffstat (limited to 'irc')
-rw-r--r--irc/weechat-devel/Makefile28
-rw-r--r--irc/weechat-devel/distinfo4
-rw-r--r--irc/weechat-devel/pkg-descr6
-rw-r--r--irc/weechat-devel/pkg-install6
4 files changed, 32 insertions, 12 deletions
diff --git a/irc/weechat-devel/Makefile b/irc/weechat-devel/Makefile
index 2b3754430db9..602ce6b929ee 100644
--- a/irc/weechat-devel/Makefile
+++ b/irc/weechat-devel/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= weechat
-PORTVERSION= 20130812
+PORTVERSION= 20130831
CATEGORIES= irc
MASTER_SITES= http://perturb.me.uk/distfiles/ \
${MASTER_SITE_LOCAL}
@@ -18,14 +18,14 @@ CONFLICTS= weechat-0.3*
USE_LDCONFIG= yes
USES= cmake iconv
-CMAKE_ARGS+= -DENABLE_GUILE=no -DENABLE_MAN=no
+CMAKE_ARGS+= -DENABLE_GUILE=no
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
WANT_PERL= yes
LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl \
gcrypt:${PORTSDIR}/security/libgcrypt
-GITDESC= v0.4.1-164-g7dea560
+GITDESC= v0.4.1-191-g410caef
GITREV!= echo "${GITDESC}" | sed -E 's/^.*-g(.{7})$$/\1/'
#GITREV= 01a1316
WRKSRC= ${WRKDIR}/${PORTNAME}-${GITREV}
@@ -132,10 +132,6 @@ PLIST_SUB+= LUA="@comment "
.endif
.if ${PORT_OPTIONS:MDOCUMENTATION}
-.if defined(MAINTAINER_BUILD)
-BUILD_DEPENDS+= xsltproc:${PORTSDIR}/textproc/libxslt \
- docbook-xsl>=0:${PORTSDIR}/textproc/docbook-xsl
-.endif
BUILD_DEPENDS+= asciidoc:${PORTSDIR}/textproc/asciidoc \
source-highlight>=3.1.5:${PORTSDIR}/textproc/source-highlight
CMAKE_ARGS+= -DENABLE_DOC=yes
@@ -162,6 +158,18 @@ PLIST_SUB+= ICON=""
PLIST_SUB+= ICON="@comment "
.endif
+.if defined(MAINTAINER_MODE)
+BUILD_DEPENDS+= xsltproc:${PORTSDIR}/textproc/libxslt \
+ docbook-xsl>=0:${PORTSDIR}/textproc/docbook-xsl
+.if empty(PORT_OPTIONS:MDOCUMENTATION)
+BUILD_DEPENDS+= asciidoc:${PORTSDIR}/textproc/asciidoc \
+ source-highlight>=3.1.5:${PORTSDIR}/textproc/source-highlight
+.endif
+CMAKE_ARGS+= -DENABLE_MAN=yes
+.else
+CMAKE_ARGS+= -DENABLE_MAN=no
+.endif
+
MAN1= weechat.1
post-patch:
@@ -189,7 +197,13 @@ pre-configure:
@sleep 5
.endif
+post-build:
+.if defined(MAINTAINER_MODE)
+ ${CP} ${WRKSRC}/doc/en/weechat.1 ${FILESDIR}/weechat.1.new
+.endif
+
post-install:
+ @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
${INSTALL_MAN} ${FILESDIR}/weechat.1.in ${MAN1PREFIX}/man/man1/weechat.1
.include <bsd.port.mk>
diff --git a/irc/weechat-devel/distinfo b/irc/weechat-devel/distinfo
index b56fffda9953..4fade311f31b 100644
--- a/irc/weechat-devel/distinfo
+++ b/irc/weechat-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (weechat-devel-7dea560.tar.gz) = 0b35acaa1b59f29db359d730c066ed0327719ddb3705fcceef16c168802727cb
-SIZE (weechat-devel-7dea560.tar.gz) = 2699990
+SHA256 (weechat-devel-410caef.tar.gz) = 83b0b7025196332af78b636b16d64ed5fa785b053556da04a7fa1fae5b78bc22
+SIZE (weechat-devel-410caef.tar.gz) = 2719277
diff --git a/irc/weechat-devel/pkg-descr b/irc/weechat-devel/pkg-descr
index b88631f34bb3..9ad96095ab02 100644
--- a/irc/weechat-devel/pkg-descr
+++ b/irc/weechat-devel/pkg-descr
@@ -1,9 +1,9 @@
WeeChat (Wee Enhanced Environment for Chat) is a fast and light IRC
client. Everything can be done with a keyboard, and it is customizable
-and extensible with scripts. For the moment, only ncurse GUI is
+and extensible with scripts. For the moment, only ncurses GUI is
supported by this port.
-Note: this is not the official release version, this is a git snapshot, which
+Note: This is not the official release version. This is a git snapshot, which
may in some cases be unstable.
-WWW: http://weechat.org
+WWW: http://weechat.org
diff --git a/irc/weechat-devel/pkg-install b/irc/weechat-devel/pkg-install
new file mode 100644
index 000000000000..b27a71d1c653
--- /dev/null
+++ b/irc/weechat-devel/pkg-install
@@ -0,0 +1,6 @@
+#!/bin/sh
+# $FreeBSD$
+
+if [ "${2}" = "POST-INSTALL" ]; then
+ ln -sf ${PKG_PREFIX}/bin/weechat ${PKG_PREFIX}/bin/weechat-curses
+fi