aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2009-04-13 15:51:30 +0800
committerdinoex <dinoex@FreeBSD.org>2009-04-13 15:51:30 +0800
commit9fef91cf56baa612b295b737d8d3ebc41d02b445 (patch)
treee7028c3dead0734a0d9fe78c31250af48a9f9b17 /irc
parent74d2586f07ab133ea40d616f62dd410169d48a16 (diff)
downloadfreebsd-ports-gnome-9fef91cf56baa612b295b737d8d3ebc41d02b445.tar.gz
freebsd-ports-gnome-9fef91cf56baa612b295b737d8d3ebc41d02b445.tar.zst
freebsd-ports-gnome-9fef91cf56baa612b295b737d8d3ebc41d02b445.zip
iroffer is a fileserver for irc (commonly referred to as a DCC bot). It
uses the DCC feature of irc to send files to other users. iroffer will connect to an irc server and let people request files from it. This is a major rewrite of Iroffer with extended features. It does support mutiple IRC networks, SSL and IPv6. LICENSE: GPL2 WWW: http://iroffer.dinoex.net/
Diffstat (limited to 'irc')
-rw-r--r--irc/Makefile1
-rw-r--r--irc/iroffer-dinoex/Makefile78
-rw-r--r--irc/iroffer-dinoex/distinfo3
-rw-r--r--irc/iroffer-dinoex/pkg-descr10
-rw-r--r--irc/iroffer-dinoex/pkg-message21
-rw-r--r--irc/iroffer-dinoex/pkg-plist21
6 files changed, 134 insertions, 0 deletions
diff --git a/irc/Makefile b/irc/Makefile
index 03aa50de51aa..e9fb2c30a1a6 100644
--- a/irc/Makefile
+++ b/irc/Makefile
@@ -52,6 +52,7 @@
SUBDIR += ircproxy
SUBDIR += ircservices
SUBDIR += iroffer
+ SUBDIR += iroffer-dinoex
SUBDIR += iroffer-lamm
SUBDIR += irssi
SUBDIR += irssi-dcc_send_limiter
diff --git a/irc/iroffer-dinoex/Makefile b/irc/iroffer-dinoex/Makefile
new file mode 100644
index 000000000000..4d3bbef5f350
--- /dev/null
+++ b/irc/iroffer-dinoex/Makefile
@@ -0,0 +1,78 @@
+# New ports collection makefile for: iroffer-dinoex
+# Date created: 10 Apr 2007
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= iroffer
+PORTVERSION= 3.13
+CATEGORIES= irc
+MASTER_SITES= http://iroffer.dinoex.net/
+PKGNAMESUFFIX= -dinoex${PKGNAMESUFFIX2}
+DISTNAME= iroffer-dinoex-${PORTVERSION}
+
+MAINTAINER= dinoex@FreeBSD.ORG
+COMMENT= An IRC "bot" that makes sharing files via DCC extremely easy
+
+HAS_CONFIGURE= yes
+CONFIGURE_SCRIPT= Configure
+MAN1= iroffer.1
+
+CONFLICTS= iroffer-1* iroffer-lamm-1.*
+
+OPTIONS= CURL "build ftp/http support" on \
+ RUBY "build RUBY script support" on \
+ UPNP "build UPNP support" on \
+ GEOIP "build GEOIP support" on \
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_CURL)
+LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+CONFIGURE_ARGS+= -curl
+.endif
+.if defined(WITH_GEOIP)
+LIB_DEPENDS+= GeoIP:${PORTSDIR}/net/GeoIP
+CONFIGURE_ARGS+= -geoip
+.endif
+.if defined(WITH_UPNP)
+LIB_DEPENDS+= miniupnpc.3:${PORTSDIR}/net/miniupnpc
+CONFIGURE_ARGS+= -upnp
+.endif
+.if defined(WITH_RUBY)
+USE_RUBY= yes
+CONFIGURE_ARGS+= -ruby
+.include "${PORTSDIR}/Mk/bsd.ruby.mk"
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/iroffer ${PREFIX}/bin/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README-iroffer.txt ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/README.modDinoex ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/LIESMICH.modDinoex ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/LICENSE ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/THANKS ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/TODO ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/help-admin-en.txt ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/help-admin-de.txt ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/help-admin-it.txt ${DOCSDIR}/
+.endif
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}/htdocs
+ ${INSTALL_DATA} ${WRKSRC}/iroffer.cron ${EXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/sample.config ${EXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/beispiel.config ${EXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/header.html ${EXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/footer.html ${EXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/ruby-sample.rb ${EXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/htdocs/iroffer-state.css \
+ ${WRKSRC}/htdocs/robots.txt \
+ ${EXAMPLESDIR}/htdocs/
+.endif
+ ${INSTALL_MAN} ${WRKSRC}/iroffer.1 ${PREFIX}/man/man1/
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/irc/iroffer-dinoex/distinfo b/irc/iroffer-dinoex/distinfo
new file mode 100644
index 000000000000..691e9423390f
--- /dev/null
+++ b/irc/iroffer-dinoex/distinfo
@@ -0,0 +1,3 @@
+MD5 (iroffer-dinoex-3.13.tar.gz) = 863ddccec089e95b550325cc46e72792
+SHA256 (iroffer-dinoex-3.13.tar.gz) = c242ab9dd802e5940194101c504b9dd9d8c994eb80695b4264106f40dccced34
+SIZE (iroffer-dinoex-3.13.tar.gz) = 411602
diff --git a/irc/iroffer-dinoex/pkg-descr b/irc/iroffer-dinoex/pkg-descr
new file mode 100644
index 000000000000..c790c972a670
--- /dev/null
+++ b/irc/iroffer-dinoex/pkg-descr
@@ -0,0 +1,10 @@
+iroffer is a fileserver for irc (commonly referred to as a DCC bot). It
+uses the DCC feature of irc to send files to other users. iroffer will
+connect to an irc server and let people request files from it.
+
+This is a major rewrite of Iroffer with extended features.
+It does support mutiple IRC networks, SSL and IPv6.
+
+LICENSE: GPL2
+
+WWW: http://iroffer.dinoex.net/
diff --git a/irc/iroffer-dinoex/pkg-message b/irc/iroffer-dinoex/pkg-message
new file mode 100644
index 000000000000..827c9c101b63
--- /dev/null
+++ b/irc/iroffer-dinoex/pkg-message
@@ -0,0 +1,21 @@
+=========================================================================
+
+Sample configuration and crontab files have been placed in
+${PREFIX}/share/examples/iroffer.
+
+These should be copied to a location of your own choosing, and edited to
+suit your needs.
+
+To run iroffer, just run:
+
+iroffer <name of config file>
+
+You may also set up iroffer to be run automatically from crontab.
+See the file ${PREFIX}/share/examples/iroffer/iroffer.cron for a sample.
+
+For more details on how to use the program see the comments in
+${PREFIX}/share/examples/iroffer/sample.config, as well as the README
+files ${PREFIX}/share/doc/iroffer/README and
+${PREFIX}/share/doc/iroffer/WHATSNEW.
+
+=========================================================================
diff --git a/irc/iroffer-dinoex/pkg-plist b/irc/iroffer-dinoex/pkg-plist
new file mode 100644
index 000000000000..81f92cfc77cb
--- /dev/null
+++ b/irc/iroffer-dinoex/pkg-plist
@@ -0,0 +1,21 @@
+bin/iroffer
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/LIESMICH.modDinoex
+%%PORTDOCS%%%%DOCSDIR%%/README-iroffer.txt
+%%PORTDOCS%%%%DOCSDIR%%/README.modDinoex
+%%PORTDOCS%%%%DOCSDIR%%/THANKS
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/help-admin-de.txt
+%%PORTDOCS%%%%DOCSDIR%%/help-admin-en.txt
+%%PORTDOCS%%%%DOCSDIR%%/help-admin-it.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/beispiel.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/footer.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/header.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/iroffer.cron
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ruby-sample.rb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sample.config
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/htdocs/iroffer-state.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/htdocs/robots.txt
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/htdocs
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%