aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2009-08-30 18:41:41 +0800
committerlinimon <linimon@FreeBSD.org>2009-08-30 18:41:41 +0800
commitb29a905355a12ad9d7cc4d3b52b5c949c3744962 (patch)
treec6bd5e39c5914eb1586c2e95acbf29bb49035930 /irc
parentae97ead1208f8d6b115cae52437bf00efcb5685f (diff)
downloadfreebsd-ports-gnome-b29a905355a12ad9d7cc4d3b52b5c949c3744962.tar.gz
freebsd-ports-gnome-b29a905355a12ad9d7cc4d3b52b5c949c3744962.tar.zst
freebsd-ports-gnome-b29a905355a12ad9d7cc4d3b52b5c949c3744962.zip
Conditionally uses Perl, so needs WANT_PERL before inclusion of
bsd.port.pre.mk. Hat: portmgr
Diffstat (limited to 'irc')
-rw-r--r--irc/epic4/Makefile1
-rw-r--r--irc/epic5/Makefile1
-rw-r--r--irc/znc/Makefile1
3 files changed, 3 insertions, 0 deletions
diff --git a/irc/epic4/Makefile b/irc/epic4/Makefile
index cf9d8c8011ac..1d3efbc89de4 100644
--- a/irc/epic4/Makefile
+++ b/irc/epic4/Makefile
@@ -29,6 +29,7 @@ USE_OPENSSL= yes
SUB_FILES= pkg-message
PLIST_SUB+= PORTVERSION=${PORTVERSION}
USE_BZIP2= yes
+WANT_PERL= yes
CFLAGS:= ${CFLAGS:C/-O2/-g -O/g}
OPTIONS= IPV6 "IPv6 support" on \
diff --git a/irc/epic5/Makefile b/irc/epic5/Makefile
index 44ae93496e16..03c1423b879a 100644
--- a/irc/epic5/Makefile
+++ b/irc/epic5/Makefile
@@ -24,6 +24,7 @@ MAN1= epic5.1
USE_OPENSSL= yes
PLIST_SUB+= PORTVERSION=${PORTVERSION}
USE_BZIP2= yes
+WANT_PERL= yes
CFLAGS:= ${CFLAGS:C/-O2/-g -O/g}
OPTIONS= IPV6 "IPv6 support" on \
diff --git a/irc/znc/Makefile b/irc/znc/Makefile
index 6c4d0a1325ee..b09a4ac05e43 100644
--- a/irc/znc/Makefile
+++ b/irc/znc/Makefile
@@ -16,6 +16,7 @@ COMMENT= An advanced IRC bouncer
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= gnomehack
+WANT_PERL= yes
CONFIGURE_ARGS= --disable-c-ares
OPTIONS= DEBUG "Enable debugging" off \