aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2014-10-29 17:41:47 +0800
committerjohans <johans@FreeBSD.org>2014-10-29 17:41:47 +0800
commit891c7308122762b163a12c4ea5fc95496463f2e2 (patch)
tree58d25bcfc83952d11f99893a2757a73ebe627668 /irc
parentf615bb3eb3dc327aba9d5922a7465c6d2ddea9a4 (diff)
downloadfreebsd-ports-gnome-891c7308122762b163a12c4ea5fc95496463f2e2.tar.gz
freebsd-ports-gnome-891c7308122762b163a12c4ea5fc95496463f2e2.tar.zst
freebsd-ports-gnome-891c7308122762b163a12c4ea5fc95496463f2e2.zip
The IRC configure script has curious logic, is being overly complex,
and actually breaks badly if the port is being built in a chroot where the host triplet won't match the jail triplet. The solution I've provided here is clean. Using the pre-configure target, the build directory (with a fixed name) is created and the needed configure script and header are copied over, just like the top configure script does. Then the port makefile just configures with that. It's much better, more robust, and fixes the triplet mismatch. PR: 194679 Submitted by: marino
Diffstat (limited to 'irc')
-rw-r--r--irc/irc/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/irc/irc/Makefile b/irc/irc/Makefile
index 017300ed3ddb..cb7e93ac83a3 100644
--- a/irc/irc/Makefile
+++ b/irc/irc/Makefile
@@ -19,11 +19,17 @@ CONFLICTS_INSTALL= charybdis-[0-9]* ircd-hybrid-[0-9]* Nefarious-[0-9]* \
USE_RC_SUBR= ircd
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/ircd
-BUILD_WRKSRC= ${WRKSRC}/${MACHINE_ARCH}-unknown-${OPSYS:tl}${OSREL}
-INSTALL_WRKSRC= ${BUILD_WRKSRC}
+BUILD_WRKSRC= ${WRKSRC}/build
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+CONFIGURE_WRKSRC= ${BUILD_WRKSRC}
OPTIONS_DEFINE= IPV6
OPTIONS_DEFAULT=IPV6
IPV6_CONFIGURE_ENABLE= ipv6
+pre-configure:
+ @${MKDIR} ${BUILD_WRKSRC}
+ ${CP} -p ${WRKSRC}/support/configure ${BUILD_WRKSRC}
+ ${CP} -p ${WRKSRC}/support/config.h.dist ${BUILD_WRKSRC}/config.h
+
.include <bsd.port.mk>