aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorbrnrd <brnrd@FreeBSD.org>2016-10-05 15:30:53 +0800
committerbrnrd <brnrd@FreeBSD.org>2016-10-05 15:30:53 +0800
commitefc91a0123ddca7c57bd167cc5d018c2c08cde31 (patch)
tree39a2430a9b86ef038fa5d45db13c82927bba197e /irc
parentfa383b0ba747767b8c41d282ef68477e2ee4bd49 (diff)
downloadfreebsd-ports-gnome-efc91a0123ddca7c57bd167cc5d018c2c08cde31.tar.gz
freebsd-ports-gnome-efc91a0123ddca7c57bd167cc5d018c2c08cde31.tar.zst
freebsd-ports-gnome-efc91a0123ddca7c57bd167cc5d018c2c08cde31.zip
irc/weechat: Fix build when PYTHON not set
- Check PYTHON option before checking version
Diffstat (limited to 'irc')
-rw-r--r--irc/weechat/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
index 619e72da50c8..fdb943ba2cd1 100644
--- a/irc/weechat/Makefile
+++ b/irc/weechat/Makefile
@@ -90,7 +90,7 @@ TCL_USES= tcl:85+
.include <bsd.port.pre.mk>
-.if ${PYTHON_MAJOR_VER} >= 3
+.if defined(PORT_OPTIONS:MPYTHON) && ${PYTHON_MAJOR_VER} >= 3
WARNING= "Using Python 3.x is NOT recommended because many \"official\" scripts won\'t work"
CMAKE_ARGS+= -DENABLE_PYTHON3:BOOL=true \
-DPYTHON_LIBRARY:FILEPATH=${LOCALBASE}/lib/libpython${PYTHON_VER}m.so