aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-09-10 21:14:50 +0800
committermat <mat@FreeBSD.org>2018-09-10 21:14:50 +0800
commit6baece3b7ae06d93445a0e0ecf02e59541a92a95 (patch)
treeeaf052562fa1ad9b232918eb5e617ac1df0dd725 /irc
parentc6f82ca14271d2d9433ac4938a2188b9b6d092c1 (diff)
downloadfreebsd-ports-gnome-6baece3b7ae06d93445a0e0ecf02e59541a92a95.tar.gz
freebsd-ports-gnome-6baece3b7ae06d93445a0e0ecf02e59541a92a95.tar.zst
freebsd-ports-gnome-6baece3b7ae06d93445a0e0ecf02e59541a92a95.zip
Add DOCS options to ports that should have one.
Also various fixes related to said option. PR: 230864 Submitted by: mat exp-runs by: antoine
Diffstat (limited to 'irc')
-rw-r--r--irc/ircd-ratbox/Makefile2
-rw-r--r--irc/irssi-fish/Makefile2
-rw-r--r--irc/ratbox-respond/Makefile2
-rw-r--r--irc/roxirc/Makefile2
4 files changed, 7 insertions, 1 deletions
diff --git a/irc/ircd-ratbox/Makefile b/irc/ircd-ratbox/Makefile
index 2569e62463d4..1833634f6dfb 100644
--- a/irc/ircd-ratbox/Makefile
+++ b/irc/ircd-ratbox/Makefile
@@ -50,7 +50,7 @@ PORTDOCS= [^i]*.txt README.* technical/[^i]*.txt Tao-of-IRC.*
#-- Options ------------------------------------------------------------
OPTIONS_DEFINE= OPENSSL IPV6 ZIPLINKS SHARED_MODS ASSERT SMALL_NET \
- SERVICES SHORTCUTS
+ SERVICES SHORTCUTS DOCS
ZIPLINKS_DESC= Support compressed server links
SHARED_MODS_DESC= Support shared modules
ASSERT_DESC= Enable debugging code
diff --git a/irc/irssi-fish/Makefile b/irc/irssi-fish/Makefile
index bbe1b3a4b1f1..704b98b39e41 100644
--- a/irc/irssi-fish/Makefile
+++ b/irc/irssi-fish/Makefile
@@ -27,6 +27,8 @@ USE_LDCONFIG= yes
PLIST_FILES= lib/irssi/modules/libfish.so
PORTDOCS= README.md FiSH-irssi.txt
+OPTIONS_DEFINE= DOCS
+
post-patch:
${REINPLACE_CMD} -e "s,/usr/local,${LOCALBASE},g" \
-e "s,share/doc/FiSH-irssi,${DOCSDIR_REL},g" ${WRKSRC}/CMakeLists.txt
diff --git a/irc/ratbox-respond/Makefile b/irc/ratbox-respond/Makefile
index 0e4957aa4f34..72535af6c68e 100644
--- a/irc/ratbox-respond/Makefile
+++ b/irc/ratbox-respond/Makefile
@@ -22,6 +22,8 @@ PORTDOCS= challenge.txt
PORTEXAMPLES= *
PLIST_FILES= bin/ratbox-respond bin/makekeypair
+OPTIONS_DEFINE= DOCS
+
do-install:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/makekeypair ${STAGEDIR}${PREFIX}/bin
diff --git a/irc/roxirc/Makefile b/irc/roxirc/Makefile
index 50f23720dbf3..093b122ad745 100644
--- a/irc/roxirc/Makefile
+++ b/irc/roxirc/Makefile
@@ -16,6 +16,8 @@ NO_BUILD= yes
PLIST_FILES= bin/roxirc
PORTDOCS= *
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} 's|if \[ -x .*|${WISH} "$$0" "$$@"|' ${WRKSRC}/roxirc