aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-04-09 13:53:14 +0800
committerwill <will@FreeBSD.org>2001-04-09 13:53:14 +0800
commita57b005c856442e2c5e6fa3d0125003dc138582b (patch)
tree4530b0faa149dd774c69b7c3228db1e8dcac9fc2 /irc
parent57624e2147e160844d94d004010ec2ce3f2c9076 (diff)
downloadfreebsd-ports-gnome-a57b005c856442e2c5e6fa3d0125003dc138582b.tar.gz
freebsd-ports-gnome-a57b005c856442e2c5e6fa3d0125003dc138582b.tar.zst
freebsd-ports-gnome-a57b005c856442e2c5e6fa3d0125003dc138582b.zip
Apparently I broke this package with the bsd.kde.mk introduction. Fix that
by using QT_NONSTANDARD and adding --disable-static. Discussed with: trevor
Diffstat (limited to 'irc')
-rw-r--r--irc/kvirc-devel/Makefile4
-rw-r--r--irc/kvirc/Makefile4
2 files changed, 6 insertions, 2 deletions
diff --git a/irc/kvirc-devel/Makefile b/irc/kvirc-devel/Makefile
index 006fe6b8693d..8658f7adf2e6 100644
--- a/irc/kvirc-devel/Makefile
+++ b/irc/kvirc-devel/Makefile
@@ -25,6 +25,7 @@ USE_AUTOCONF= yes
USE_QT_VER= 2
USE_X_PREFIX= yes
USE_GMAKE= yes
+QT_NONSTANDARD= yes
CONFIGURE_ARGS= --x-includes=$(X11BASE)/include \
--x-libraries=$(X11BASE)/lib \
--datadir=$(PREFIX)/share \
@@ -33,7 +34,8 @@ CONFIGURE_ARGS= --x-includes=$(X11BASE)/include \
--with-qt-library-dir=${X11BASE}/lib \
--without-kde-check \
--with-freebsd-pthread \
- --with-qt-name=qt2
+ --with-qt-name=qt2 \
+ --disable-static
CONFIGURE_ENV+= SS_X_EXTRA_LIBS=-lxpg4
diff --git a/irc/kvirc/Makefile b/irc/kvirc/Makefile
index 006fe6b8693d..8658f7adf2e6 100644
--- a/irc/kvirc/Makefile
+++ b/irc/kvirc/Makefile
@@ -25,6 +25,7 @@ USE_AUTOCONF= yes
USE_QT_VER= 2
USE_X_PREFIX= yes
USE_GMAKE= yes
+QT_NONSTANDARD= yes
CONFIGURE_ARGS= --x-includes=$(X11BASE)/include \
--x-libraries=$(X11BASE)/lib \
--datadir=$(PREFIX)/share \
@@ -33,7 +34,8 @@ CONFIGURE_ARGS= --x-includes=$(X11BASE)/include \
--with-qt-library-dir=${X11BASE}/lib \
--without-kde-check \
--with-freebsd-pthread \
- --with-qt-name=qt2
+ --with-qt-name=qt2 \
+ --disable-static
CONFIGURE_ENV+= SS_X_EXTRA_LIBS=-lxpg4