aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2019-03-04 15:21:57 +0800
committerjbeich <jbeich@FreeBSD.org>2019-03-04 15:21:57 +0800
commitaf8afa61a5a706ebf2bd4e051c06085a02692b48 (patch)
tree534f12b6a28a8e8e7cf9cf9eb5e7bfed0c783337 /irc
parentba91bc4b0bfbe97b8ba06704c8f386cf0d2cd51e (diff)
downloadfreebsd-ports-gnome-af8afa61a5a706ebf2bd4e051c06085a02692b48.tar.gz
freebsd-ports-gnome-af8afa61a5a706ebf2bd4e051c06085a02692b48.tar.zst
freebsd-ports-gnome-af8afa61a5a706ebf2bd4e051c06085a02692b48.zip
irc/anope: unbreak with libc++ 8
In file included from src/access.cpp:12: In file included from include/service.h:15: In file included from include/services.h:22: In file included from /usr/include/c++/v1/stdexcept:46: In file included from /usr/include/c++/v1/exception:81: In file included from /usr/include/c++/v1/cstddef:38: include/version:1:1: error: expected unqualified-id <U+007F>ELF<U+0002><U+0001><U+0001> <U+0000><U+0000><U+0000><U+0000><U+0000><U+0000><U+0000><U+0000><U+0002><U+0000>><U+0000><U+0001><U+0000><U+0000><U+0000><U+0000>P <U+0000><U+0000><U+0000><U+0000><U+0000>@<U+0000><U+0000><U+0000><U+0000><U+0000><U+0000><U+0000><F0>"<U+0001><U+0000><U+0000><U+0000><U+0000><U+0000><U+0000><U+0000><U+0000><U+0000>@<U+0000>8 ^ PR: 236192 Approved by: portmgr blanket
Diffstat (limited to 'irc')
-rw-r--r--irc/anope/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/irc/anope/Makefile b/irc/anope/Makefile
index f524e0f78fd9..d97994341f49 100644
--- a/irc/anope/Makefile
+++ b/irc/anope/Makefile
@@ -47,6 +47,11 @@ SQLITE_USES= sqlite
TRE_LIB_DEPENDS= libtre.so:textproc/libtre
+post-patch:
+# Avoid conflict with C++20 <version> by adding -bin suffix
+ @${REINPLACE_CMD} -i .c++20 's/version /version-bin /' \
+ ${WRKSRC}/include/CMakeLists.txt
+
post-patch-GNUTLS-on:
${LN} -s ${WRKSRC}/modules/extra/m_ssl_gnutls.cpp ${WRKSRC}/modules/