aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/Canna/Makefile
diff options
context:
space:
mode:
authormax <max@FreeBSD.org>2001-11-21 08:42:18 +0800
committermax <max@FreeBSD.org>2001-11-21 08:42:18 +0800
commit2911a809b69250782af88050bfb57d914e627548 (patch)
treeadd1159d13a75c16086933e94265ea5948c2168d /japanese/Canna/Makefile
parentff1841fd96d0975a85b26cae1ec6ffb652dcf51b (diff)
downloadfreebsd-ports-gnome-2911a809b69250782af88050bfb57d914e627548.tar.gz
freebsd-ports-gnome-2911a809b69250782af88050bfb57d914e627548.tar.zst
freebsd-ports-gnome-2911a809b69250782af88050bfb57d914e627548.zip
Adjust post-install and pkg-plist so that all necessary directories
are created with proper mode/ownership at installation time, and thus, possible to pkg_delete cleanly.
Diffstat (limited to 'japanese/Canna/Makefile')
-rw-r--r--japanese/Canna/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/japanese/Canna/Makefile b/japanese/Canna/Makefile
index 15212209c8a4..638e71989ab0 100644
--- a/japanese/Canna/Makefile
+++ b/japanese/Canna/Makefile
@@ -48,13 +48,16 @@ MLINKS= uilibs.3 XKanjiControl.3 uilibs.3 XLookupKanjiString.3 \
STARTUP_SCRIPT= ${PREFIX}/etc/rc.d/canna.sh
-pre-install:
+post-install:
${MKDIR} /var/run/canna
${CHOWN} bin:bin /var/run/canna
+.for f in user user/user group
+ ${MKDIR} ${PREFIX}/lib/canna/dic/$f
+ ${CHOWN} bin:bin ${PREFIX}/lib/canna/dic/$f
+ ${CHMOD} 775 ${PREFIX}/lib/canna/dic/$f
+.endfor
@${SED} -e "s;@PREFIX@;${PREFIX};g" ${FILESDIR}/canna.sh.in \
>${WRKDIR}/canna.sh
-
-post-install:
if [ ! -f ${STARTUP_SCRIPT} ]; then \
${ECHO} "Installing ${STARTUP_SCRIPT} startup file."; \
${INSTALL_SCRIPT} ${WRKDIR}/canna.sh ${STARTUP_SCRIPT}; \