aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/celrw/Makefile
diff options
context:
space:
mode:
authorsada <sada@FreeBSD.org>2002-06-03 05:46:53 +0800
committersada <sada@FreeBSD.org>2002-06-03 05:46:53 +0800
commit5e084febc127a159c7d19df61d9bae448a69d260 (patch)
tree5899b269378dbaf4c7959a6d7f2e9407456ef882 /japanese/celrw/Makefile
parent9e1d2e77bea4a82cfb0ce3271e4347fcd1a0bc16 (diff)
downloadfreebsd-ports-gnome-5e084febc127a159c7d19df61d9bae448a69d260.tar.gz
freebsd-ports-gnome-5e084febc127a159c7d19df61d9bae448a69d260.tar.zst
freebsd-ports-gnome-5e084febc127a159c7d19df61d9bae448a69d260.zip
PR: ports/31950
Submitted by: IWASHITA Yoji <shuna@pop16.odn.ne.jp> Add new port: japanese/celrw . Celrw is cellular phone-number read/write tool. Celrw's target is PDC only (in Japan).
Diffstat (limited to 'japanese/celrw/Makefile')
-rw-r--r--japanese/celrw/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/japanese/celrw/Makefile b/japanese/celrw/Makefile
new file mode 100644
index 000000000000..8133a1953712
--- /dev/null
+++ b/japanese/celrw/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: ja-celrw
+# Date created: 13 Nov 2001
+# Whom: IWASHITA Yoji <shuna@pop16.odn.ne.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= celrw
+PORTVERSION= 0.12
+CATEGORIES= japanese misc
+MASTER_SITES= http://www.nurs.or.jp/~kurati/celrw/
+
+MAINTAINER= shuna@pop16.odn.ne.jp
+
+BUILD_DEPENDS= automake:${PORTSDIR}/devel/automake
+
+USE_BZIP2= yes
+HAS_CONFIGURE= yes
+ALL_TARGET=
+
+pre-configure:
+ ${RM} -f ${WRKSRC}/install.sh
+ ${LN} -sf ${PREFIX}/share/automake/install-sh ${WRKSRC}/install-sh
+ ${LN} -sf ${PREFIX}/share/automake/config.guess ${WRKSRC}/config.guess
+ ${LN} -sf ${PREFIX}/share/automake/config.sub ${WRKSRC}/config.sub
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/celrw ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>