aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/eb/Makefile
diff options
context:
space:
mode:
authorsumikawa <sumikawa@FreeBSD.org>2003-03-03 04:35:38 +0800
committersumikawa <sumikawa@FreeBSD.org>2003-03-03 04:35:38 +0800
commite0f03c345970d9da388f25a58610b8d0d18914fb (patch)
treee318311d38e7a047a0e1fcfa3c19667d70a11119 /japanese/eb/Makefile
parent687be098795c72d2d541ee5d73a98e7a73614ed1 (diff)
downloadfreebsd-ports-gnome-e0f03c345970d9da388f25a58610b8d0d18914fb.tar.gz
freebsd-ports-gnome-e0f03c345970d9da388f25a58610b8d0d18914fb.tar.zst
freebsd-ports-gnome-e0f03c345970d9da388f25a58610b8d0d18914fb.zip
[0] Updates for the latest version 3.3.1
[1] Fix MASTER_SITES [2] Don't use configure option '--enable-pthread' (backout last commit) because it breaks japanese/ndtpd and the pthread support of EB library itself is still incomplete and experimental. [3] Remove imported patch; files/patch-eb::match.c [4] Add patch to use USE_LIBTOOL=yes; files/patch-configure [5] Use configure option '--build=...' [6] Use LOCALBASE instead of PREFIX for other installed packages [7] Use DATADIR [8] Don't be quiet at post-extract section (backout last commit) [9] Sort @dirrm section of pkg-plist; generated by (cd /usr/local; find -ds share/eb -type d) | sed 's,^,@dirrm ,' [4]-[7] were submitted by KATO Tsuguru <tkato@prontomail.com>. Thanks, Kato-san. PR: ports/48840 Submitted by: Kazu TAKAMUNE <takamune@avrl.mei.co.jp>
Diffstat (limited to 'japanese/eb/Makefile')
-rw-r--r--japanese/eb/Makefile29
1 files changed, 13 insertions, 16 deletions
diff --git a/japanese/eb/Makefile b/japanese/eb/Makefile
index 5339465109d3..d1206750932a 100644
--- a/japanese/eb/Makefile
+++ b/japanese/eb/Makefile
@@ -6,18 +6,17 @@
#
PORTNAME= eb
-PORTVERSION= 3.3
-PORTREVISION= 2
+PORTVERSION= 3.3.1
CATEGORIES= japanese
MASTER_SITES= ftp://ftp.sra.co.jp/pub/misc/eb/ \
- ftp://ftp.eos.hokudai.ac.jp/pub/network/ndtp/eb/
+ ftp://ftp.eos.hokudai.ac.jp/pub/net/ndtp/eb/
DISTFILES= ${EBFILES} \
${LISTFILES} \
${APPENDIXFILES}
EXTRACT_ONLY= ${EBFILES}
PATCH_SITES= ${MASTER_SITES}
-PATCHFILES= ${DISTNAME}+.diff ${DISTNAME}+2.diff
+#PATCHFILES= ${DISTNAME}+.diff ${DISTNAME}+2.diff
MAINTAINER= takamune@avrl.mei.co.jp
COMMENT= C library for accessing EB, EBG, EBXA and EPWING CD-ROM dictionaries
@@ -60,24 +59,22 @@ APPENDIXFILES= appendix/cencro-1.0.tar.gz \
DIST_SUBDIR= eb
USE_PERL5= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-nls \
- --enable-pthread \
- --with-pthread-cflags="${PTHREAD_CFLAGS}" \
- --with-pthread-ldflags="${PTHREAD_LIBS}" \
- --with-gettext-includes=${PREFIX}/include \
- --with-gettext-libraries=${PREFIX}/lib \
- --with-iconv-includes=${PREFIX}/include \
- --with-iconv-libraries=${PREFIX}/lib
+ --with-gettext-includes=${LOCALBASE}/include \
+ --with-gettext-libraries=${LOCALBASE}/lib \
+ --with-iconv-includes=${LOCALBASE}/include \
+ --with-iconv-libraries=${LOCALBASE}/lib
-APPENDIXDIR= ${PREFIX}/share/eb/appendix
+APPENDIXDIR= ${DATADIR}/appendix
post-extract:
- @${RM} -fr ${WRKSRC}/zlib
- @${MKDIR} ${WRKDIR}/appendix
+ ${RM} -fr ${WRKSRC}/zlib
+ ${MKDIR} ${WRKDIR}/appendix
.for file in ${APPENDIXFILES}
- @${TAR} --exclude CVS -C ${WRKDIR}/appendix -zxmf \
+ ${TAR} --exclude CVS -C ${WRKDIR}/appendix -zxmf \
${DISTDIR}/${DIST_SUBDIR}/${file}
.endfor