aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/ebview-gtk2/Makefile
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-02-02 22:29:18 +0800
committernork <nork@FreeBSD.org>2003-02-02 22:29:18 +0800
commitdf8eb4fa7e2d89173ebeb1d99930dc4ec9fbf61a (patch)
treee00def4ca9015235508e73df39799b0785cc9893 /japanese/ebview-gtk2/Makefile
parentb1f92be3f27080a1fcc9fedc419f45ff823d53b8 (diff)
downloadfreebsd-ports-gnome-df8eb4fa7e2d89173ebeb1d99930dc4ec9fbf61a.tar.gz
freebsd-ports-gnome-df8eb4fa7e2d89173ebeb1d99930dc4ec9fbf61a.tar.zst
freebsd-ports-gnome-df8eb4fa7e2d89173ebeb1d99930dc4ec9fbf61a.zip
Conditionalize libgnugetopt dependencies.
PR: ports/47747 Submitted by: Ports Fury
Diffstat (limited to 'japanese/ebview-gtk2/Makefile')
-rw-r--r--japanese/ebview-gtk2/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/japanese/ebview-gtk2/Makefile b/japanese/ebview-gtk2/Makefile
index f04ec5dcc8b8..4ccfec10337d 100644
--- a/japanese/ebview-gtk2/Makefile
+++ b/japanese/ebview-gtk2/Makefile
@@ -13,8 +13,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
- eb.6:${PORTSDIR}/japanese/eb
+LIB_DEPENDS= eb.6:${PORTSDIR}/japanese/eb
USE_GNOMENG= yes
USE_GNOME= imlib
@@ -22,11 +21,18 @@ USE_REINPLACE= yes
USE_GMAKE= yes
USE_AUTOMAKE_VER= 14
USE_AUTOCONF_VER= 253
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+.if !exists(/usr/include/getopt.h)
+LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+LDFLAGS+= -lgnugetopt
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}