aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/edict-fpw/Makefile
diff options
context:
space:
mode:
authortaoka <taoka@FreeBSD.org>2001-08-23 09:57:35 +0800
committertaoka <taoka@FreeBSD.org>2001-08-23 09:57:35 +0800
commit7c166880008394af922f67a4ff13c74c758cacac (patch)
tree151a64edf71390fdc1f956e832d9d4c04f772b12 /japanese/edict-fpw/Makefile
parent1a9a885ebd7be299fb764496a17f0edbc190742a (diff)
downloadfreebsd-ports-gnome-7c166880008394af922f67a4ff13c74c758cacac.tar.gz
freebsd-ports-gnome-7c166880008394af922f67a4ff13c74c758cacac.tar.zst
freebsd-ports-gnome-7c166880008394af922f67a4ff13c74c758cacac.zip
Use the converted file on the master site
instead of converting the original file by its converting script in this port.
Diffstat (limited to 'japanese/edict-fpw/Makefile')
-rw-r--r--japanese/edict-fpw/Makefile38
1 files changed, 10 insertions, 28 deletions
diff --git a/japanese/edict-fpw/Makefile b/japanese/edict-fpw/Makefile
index 73aa74b9734b..5487bfc6a8e8 100644
--- a/japanese/edict-fpw/Makefile
+++ b/japanese/edict-fpw/Makefile
@@ -8,43 +8,25 @@
PORTNAME= edict-fpw
PORTVERSION= 1.2.1
CATEGORIES= japanese
-MASTER_SITES= http://openlab.ring.gr.jp/edict/fpw/dist/edict/ \
- ftp://ftp.cc.monash.edu.au/pub/nihongo/ \
- ftp://ftp.cdrom.com/pub/japanese/monash/ \
- ftp://ftp.sedl.org/pub/mirrors/nihongo/ \
- ftp://ftp.u-aizu.ac.jp/pub/SciEng/nihongo/ftp.cc.monash.edu.au/
-DISTNAME= ${PORTNAME}${PORTVERSION}-src
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- edict.gz \
- edict_doc.txt
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+MASTER_SITES= http://openlab.ring.gr.jp/edict/fpw/dist/edict/
+DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= taoka@FreeBSD.org
-BUILD_DEPENDS= fpwmake:${PORTSDIR}/japanese/freepwing \
- catdump:${PORTSDIR}/japanese/epwutil \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
-
-WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
-
-post-extract:
- ${MKDIR} ${WRKSRC}/source
- ${CP} -f ${DISTDIR}/edict.gz ${WRKSRC}/source
- ${CP} -f ${DISTDIR}/edict_doc.txt ${WRKSRC}/source
- ${GZIP_CMD} -d ${WRKSRC}/source/edict.gz
-
-do-build:
- cd ${WRKSRC}; fpwmake > /dev/null; \
- fpwmake catalogs
+USE_ZIP= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/edict
+EXTRACT_BEFORE_ARGS= -qL
do-install:
${MKDIR} ${PREFIX}/share/dict/edict-fpw/edict/data
- ${INSTALL_DATA} ${WRKSRC}/honmon ${PREFIX}/share/dict/edict-fpw/edict/data
+ ${INSTALL_DATA} ${WRKSRC}/edict/data/honmon ${PREFIX}/share/dict/edict-fpw/edict/data
${INSTALL_DATA} ${WRKSRC}/catalogs ${PREFIX}/share/dict/edict-fpw
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/edict-fpw
- ${INSTALL_DATA} ${WRKSRC}/source/edict_doc.txt ${PREFIX}/share/doc/edict-fpw
- ${INSTALL_DATA} ${WRKSRC}/README.PKG ${PREFIX}/share/doc/edict-fpw
+.for i in readme.pkg edict.txt
+ ${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/share/doc/edict-fpw
+.endfor
.endif
.include <bsd.port.mk>