aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/edict-fpw/Makefile
diff options
context:
space:
mode:
authortaoka <taoka@FreeBSD.org>2000-08-24 21:42:10 +0800
committertaoka <taoka@FreeBSD.org>2000-08-24 21:42:10 +0800
commitbbc5dbccde6baf652008ed74ce79903c6e40dc15 (patch)
tree486d01966cb3af48bae205fda12005b71a93fa86 /japanese/edict-fpw/Makefile
parent7510356977feb1c6cdd2d4c55b4a9d2cbcabf8e1 (diff)
downloadfreebsd-ports-gnome-bbc5dbccde6baf652008ed74ce79903c6e40dc15.tar.gz
freebsd-ports-gnome-bbc5dbccde6baf652008ed74ce79903c6e40dc15.tar.zst
freebsd-ports-gnome-bbc5dbccde6baf652008ed74ce79903c6e40dc15.zip
Updated to version 1.2.1
- Names of distfiles (the original dictonary) were changed. - Previous dictonary is only Japanese-English one. This version's dictonary includes English-Japanese one, too.
Diffstat (limited to 'japanese/edict-fpw/Makefile')
-rw-r--r--japanese/edict-fpw/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/japanese/edict-fpw/Makefile b/japanese/edict-fpw/Makefile
index 85abaf011cfd..4046e850c22b 100644
--- a/japanese/edict-fpw/Makefile
+++ b/japanese/edict-fpw/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= edict-fpw
-PORTVERSION= 1.1
+PORTVERSION= 1.2.1
CATEGORIES= japanese
MASTER_SITES= ftp://ftp.sra.co.jp/pub/misc/freepwing/fpwbooks/edict/ \
ftp://ftp.cc.monash.edu.au/pub/nihongo/ \
@@ -16,20 +16,22 @@ MASTER_SITES= ftp://ftp.sra.co.jp/pub/misc/freepwing/fpwbooks/edict/ \
DISTNAME= ${PORTNAME}${PORTVERSION}-src
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
edict.gz \
- edict.doc
+ edict_doc.txt
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= taoka@FreeBSD.org
BUILD_DEPENDS= fpwmake:${PORTSDIR}/japanese/freepwing \
- catdump:${PORTSDIR}/japanese/epwutil
+ catdump:${PORTSDIR}/japanese/epwutil \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
post-extract:
${MKDIR} ${WRKSRC}/source
${CP} -f ${DISTDIR}/edict.gz ${WRKSRC}/source
- ${CP} -f ${DISTDIR}/edict.doc ${WRKSRC}/source
+ ${CP} -f ${DISTDIR}/edict_doc.txt ${WRKSRC}/source
${GZIP_CMD} -d ${WRKSRC}/source/edict.gz
do-build:
@@ -42,8 +44,8 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/catalogs ${PREFIX}/share/dict/edict-fpw
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/edict-fpw
- ${INSTALL_DATA} ${WRKSRC}/source/edict.doc ${PREFIX}/share/doc/edict-fpw
- ${INSTALL_DATA} ${WRKSRC}/README.pkg ${PREFIX}/share/doc/edict-fpw
+ ${INSTALL_DATA} ${WRKSRC}/source/edict_doc.txt ${PREFIX}/share/doc/edict-fpw
+ ${INSTALL_DATA} ${WRKSRC}/README.PKG ${PREFIX}/share/doc/edict-fpw
.endif
.include <bsd.port.mk>