aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/edyvalue
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2007-01-21 22:36:17 +0800
committernork <nork@FreeBSD.org>2007-01-21 22:36:17 +0800
commit7366e425f808e1bf1d8d1b807c97f5daa6673e7e (patch)
treed396156a35712c4189ff01742b2077b429586e29 /japanese/edyvalue
parenta06904ad30520f62e2ada583d1f6479ae47fe70d (diff)
downloadfreebsd-ports-gnome-7366e425f808e1bf1d8d1b807c97f5daa6673e7e.tar.gz
freebsd-ports-gnome-7366e425f808e1bf1d8d1b807c97f5daa6673e7e.tar.zst
freebsd-ports-gnome-7366e425f808e1bf1d8d1b807c97f5daa6673e7e.zip
Add edyvalue 2007.01.06, utility to print a statement of Edy card.
PR: ports/108177 Submitted by: Yoshihiko Sarumaru <mistral at imasy.or.jp>
Diffstat (limited to 'japanese/edyvalue')
-rw-r--r--japanese/edyvalue/Makefile31
-rw-r--r--japanese/edyvalue/distinfo3
-rw-r--r--japanese/edyvalue/files/Makefile13
-rw-r--r--japanese/edyvalue/files/patch-EdyValue.c49
-rw-r--r--japanese/edyvalue/pkg-descr4
-rw-r--r--japanese/edyvalue/pkg-message3
6 files changed, 103 insertions, 0 deletions
diff --git a/japanese/edyvalue/Makefile b/japanese/edyvalue/Makefile
new file mode 100644
index 000000000000..f57d6115115c
--- /dev/null
+++ b/japanese/edyvalue/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: edyvalue
+# Date created: 18 January 2007
+# Whom: Yoshihiko Sarumaru <mistral@imasy.or.jp>
+#
+# $FreeBSD$
+
+PORTNAME= edyvalue
+PORTVERSION= 2007.01.06
+CATEGORIES= japanese
+MASTER_SITES= http://www.imfj.net/people/nomura/soft/PaSoRi/
+DISTNAME= EdyValue
+DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
+EXTRACT_SUFX= .c
+EXTRACT_ONLY=
+
+MAINTAINER= mistral@imasy.or.jp
+COMMENT= Utility to print a statement of Edy card
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libpasori.a:${PORTSDIR}/devel/libpasori
+
+PLIST_FILES= bin/EdyValue
+
+post-extract:
+ @${MKDIR} ${WRKSRC}
+ @${CP} -f ${DISTDIR}/${DISTFILES} ${WRKSRC}
+ @${CP} -f ${FILESDIR}/Makefile ${WRKSRC}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/japanese/edyvalue/distinfo b/japanese/edyvalue/distinfo
new file mode 100644
index 000000000000..0a5e1cb35d02
--- /dev/null
+++ b/japanese/edyvalue/distinfo
@@ -0,0 +1,3 @@
+MD5 (edyvalue/2007.01.06/EdyValue.c) = 1b6cb4f287d9a225913dd4077973211a
+SHA256 (edyvalue/2007.01.06/EdyValue.c) = 71005c7bc3f0378f8b76da4f6f908cf61b1791fb04b1a82ef8b3d66019156688
+SIZE (edyvalue/2007.01.06/EdyValue.c) = 1675
diff --git a/japanese/edyvalue/files/Makefile b/japanese/edyvalue/files/Makefile
new file mode 100644
index 000000000000..f4fee370af0d
--- /dev/null
+++ b/japanese/edyvalue/files/Makefile
@@ -0,0 +1,13 @@
+# $FreeBSD$
+
+PROG= EdyValue
+DPADD= ${LOCALBASE}/lib/libpasori.a
+LDADD= -L${LOCALBASE}/lib -lpasori
+
+BINDIR= ${LOCALBASE}/bin
+NO_MAN=
+
+CFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -Wall -W
+
+.include <bsd.prog.mk>
diff --git a/japanese/edyvalue/files/patch-EdyValue.c b/japanese/edyvalue/files/patch-EdyValue.c
new file mode 100644
index 000000000000..c1568b3e915f
--- /dev/null
+++ b/japanese/edyvalue/files/patch-EdyValue.c
@@ -0,0 +1,49 @@
+--- EdyValue.c.orig Sat Jan 6 16:36:29 2007
++++ EdyValue.c Sun Jan 21 02:36:09 2007
+@@ -1,6 +1,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include "libpasori.h"
++#include "libpasori_command.h"
+ #define TRUE 1
+ #define FALSE 0
+
+@@ -19,21 +20,25 @@
+ return (FALSE);
+ }
+
+-int main(void){
++int main(int argc, char **argv){
+ pasori* p;
+ felica* f;
+ int i;
+- int m;
+- int year, month, day;
++ unsigned int month, day;
+ uint8 b[16];
+
+- p = pasori_open(NULL);
++ char* devpath = NULL;
++ if (argc == 2) {
++ devpath = argv[1];
++ }
++ p = pasori_open(devpath);
+ if(!p){
+ printf("error\n");
+ exit(-1);
+ }
+ pasori_init(p);
+ f = felica_polling(p,0xFE00,0,0);
++ if (f) {
+ printf("*** Edy Value ***\n");
+ i=0;
+ while(!felica_read_without_encryption02(f,0x170F,0,i,b)){
+@@ -79,6 +84,8 @@
+ printf(" --> % 5d Yen (rest) ",b[14]*256+b[15]);
+ printf("%02X%02X%02X\n",b[1],b[2],b[3]);
+ i++;
++ }
++ free(f);
+ }
+ pasori_close(p);
+ return 0;
diff --git a/japanese/edyvalue/pkg-descr b/japanese/edyvalue/pkg-descr
new file mode 100644
index 000000000000..4ba3a504256d
--- /dev/null
+++ b/japanese/edyvalue/pkg-descr
@@ -0,0 +1,4 @@
+EdyValue prints statements from an Edy card.
+You need a Sony RC-S320 or VAIO with FeliCa port to use this program.
+
+WWW: http://www.imfj.net/people/nomura/soft/PaSoRi/EdyValue.html
diff --git a/japanese/edyvalue/pkg-message b/japanese/edyvalue/pkg-message
new file mode 100644
index 000000000000..a0c31c3baa54
--- /dev/null
+++ b/japanese/edyvalue/pkg-message
@@ -0,0 +1,3 @@
+******************************************************************************
+Place your Edy card on PaSoRi before executing EdyValue.
+******************************************************************************