aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/emacs-manual
diff options
context:
space:
mode:
authorshige <shige@FreeBSD.org>2000-07-19 16:03:55 +0800
committershige <shige@FreeBSD.org>2000-07-19 16:03:55 +0800
commitee6ad8b7d368ebc7f7b04db6b2ff12b00f2a0824 (patch)
tree79c7a56df32c4ab445a3a593e31f220269038a3d /japanese/emacs-manual
parent09a3443d2c60bac05824ef25d83e4a5cf1d1ac46 (diff)
downloadfreebsd-ports-gnome-ee6ad8b7d368ebc7f7b04db6b2ff12b00f2a0824.tar.gz
freebsd-ports-gnome-ee6ad8b7d368ebc7f7b04db6b2ff12b00f2a0824.tar.zst
freebsd-ports-gnome-ee6ad8b7d368ebc7f7b04db6b2ff12b00f2a0824.zip
Synchronize with emacs-20.7 update.
And apply EMACS_PORT_NAME style.
Diffstat (limited to 'japanese/emacs-manual')
-rw-r--r--japanese/emacs-manual/Makefile16
-rw-r--r--japanese/emacs-manual/distinfo2
-rw-r--r--japanese/emacs-manual/files/extra-patch-texinfmt.el.patch41
3 files changed, 51 insertions, 8 deletions
diff --git a/japanese/emacs-manual/Makefile b/japanese/emacs-manual/Makefile
index 6e0f9fd5cb0d..66ab8518caa8 100644
--- a/japanese/emacs-manual/Makefile
+++ b/japanese/emacs-manual/Makefile
@@ -16,12 +16,13 @@ DISTFILES= ${DISTNAME}.tgz ${EMACS_ARC}
MAINTAINER= okazaki@be.to
-BUILD_DEPENDS= ${EMACS}:${PORTSDIR}/editors/emacs20
+EMACS_PORT_NAME= emacs20
+EMACS_NO_RUN_DEPENDS= YES
ERRATA_FILE=
EXTRACT_ONLY= ${DISTNAME}.tgz
-EMACS_DISTNAME= emacs-20.6
+EMACS_DISTNAME= emacs-${EMACS_VER}
EMACS_ARC= ${EMACS_DISTNAME}.tar.gz
EMACS_SRCDIR= ${WRKDIR}/${EMACS_DISTNAME}
EXTRACT_FILES= ${EMACS_DISTNAME}/man/ack.texi \
@@ -36,11 +37,6 @@ EXTRACT_ONLY+= ${ERRATA_FILE}.tgz
EXTRA_PATCHES+= ${WRKDIR}/${ERRATA_FILE}
.endif
-# We use emacs20 to format texinfo files.
-EMACS= emacs-20.6
-
-MAKE_ENV= EMACS="${EMACS}"
-
post-extract:
${CP} ${FILESDIR}/Makefile.in ${WRKSRC}/Makefile
${CP} ${FILESDIR}/PORT_TEXIFMT.MK ${WRKSRC}
@@ -49,6 +45,12 @@ post-extract:
${CP} ${EXTRACT_FILES} ${WRKSRC})
${MKDIR} ${WRKDIR}/info
+# workaround target (please delete after emacs-20.7-man-jp is released).
+pre-patch:
+ @(cd ${WRKSRC} && \
+ ${PATCH} ${PATCH_ARGS} < ${FILESDIR}/patch-texinfmt.el.patch ; \
+ )
+
post-patch:
cd ${WRKSRC} && \
${PERL} -pi -e 's/(@[^@]*ref{.*,.*,.*, *elisp),/$$1-ja,/;' *.texi
diff --git a/japanese/emacs-manual/distinfo b/japanese/emacs-manual/distinfo
index d97cbb2e838b..2a02325a67cb 100644
--- a/japanese/emacs-manual/distinfo
+++ b/japanese/emacs-manual/distinfo
@@ -1,2 +1,2 @@
MD5 (emacs-20.6-man-jp.tgz) = 4cd74247ebb493f385e41901ef33081f
-MD5 (emacs-20.6.tar.gz) = cfcaa33b5fc7d64210d3428f13570f8d
+MD5 (emacs-20.7.tar.gz) = c732cf5e668d4ac67d9418ecb103ecf5
diff --git a/japanese/emacs-manual/files/extra-patch-texinfmt.el.patch b/japanese/emacs-manual/files/extra-patch-texinfmt.el.patch
new file mode 100644
index 000000000000..ccf025269b6b
--- /dev/null
+++ b/japanese/emacs-manual/files/extra-patch-texinfmt.el.patch
@@ -0,0 +1,41 @@
+--- patch-texinfmt.el.orig Fri Mar 3 21:26:16 2000
++++ patch-texinfmt.el Thu Jul 13 18:17:38 2000
+@@ -1,5 +1,5 @@
+---- texinfmt.el-ORIG Sun May 30 04:21:06 1999
+-+++ texinfmt.el Thu Jan 13 10:52:58 2000
++--- texinfmt.el.orig Thu Jul 13 18:12:19 2000
+++++ texinfmt.el Thu Jul 13 18:17:28 2000
+ @@ -1111,6 +1111,78 @@
+
+ ;;; @node, @menu, @detailmenu
+@@ -112,17 +112,18 @@
+ (texinfo-discard-command)
+ (setq texinfo-last-node name)
+ (let ((tem (if texinfo-fold-nodename-case (downcase name) name)))
+-@@ -1212,7 +1308,8 @@
++@@ -1212,7 +1308,9 @@
+ (insert (or fname (car args)) ": ")
+ (if (nth 3 args)
+ (insert "(" (nth 3 args) ")"))
+-- (insert (car args))))))
++- (and (car args) (insert (car args)))))))
+ + (insert (or (car args) ""))
+ + (or (save-excursion (looking-at "[.,]")) (insert "."))))))
+++
+
+ (put 'pxref 'texinfo-format 'texinfo-format-pxref)
+ (defun texinfo-format-pxref ()
+-@@ -1220,6 +1317,7 @@
++@@ -1220,6 +1318,7 @@
+ (or (save-excursion
+ (forward-char -2)
+ (looking-at "::"))
+@@ -130,7 +131,7 @@
+ (insert ".")))
+
+ ;; @inforef{NODE, FNAME, FILE}
+-@@ -1230,7 +1328,8 @@
++@@ -1230,7 +1329,8 @@
+ (let ((args (texinfo-format-parse-args)))
+ (texinfo-discard-command)
+ (if (nth 1 args)
6eee4a1931998a4e8988fe0'>BROKEN on 5.x: Configure failskris2004-02-091-1/+7 * BROKEN on 5.x: configure failskris2004-02-091-1/+7 * BROKEN on 5.x: Does not compilekris2004-02-091-1/+7 * BROKEN on 5.x: Does not compilekris2004-02-091-0/+4 * - Update to version 3.1.1krion2004-02-084-16/+5 * Update to 0.11.2edwin2004-02-083-9/+2 * Reset bouncing maintainer addresskris2004-02-081-1/+1 * - Update to version 1.2krion2004-02-083-3/+6 * * Upgrade to 2.5.6.obraun2004-02-072-6/+5 * Use PLIST_FILES (bento-tested, marcus-reviewed).trevor2004-02-0680-43/+44 * - Update to 1.1.0krion2004-02-064-122/+208 * Use PLIST_FILES.trevor2004-02-0678-40/+40 * Fix and remove BROKEN.flathill2004-02-062-4/+111 * Fix build/install on stable.nork2004-02-051-3/+3 * Update to KDE 3.2.0lofi2004-02-056-168/+618 * Bump PORTREVISION on all ports that depend on gettext to aid with upgrading.marcus2004-02-04235-43/+235 * Add USE_GETTEXT and bump PORTREVISION.marcus2004-02-0411-27/+26 * New game for port collection: clone of BlockOut gamelev2004-02-045-0/+89 * Fix port commentlev2004-02-041-1/+1 * Add pykawari 8.1.0, pykawari is a real kawari8 module for ninix-aya.nork2004-02-046-0/+126 * Changed MASTER_SITE as the old one is permanently down.mich2004-02-031-1/+1 * Update to 2.6.nork2004-02-033-3/+7 * Remove BROKEN since the port has now been fixed for gcc33. Also,hoek2004-02-021-8/+3 * Remove some old stale comment about requiring Tk80.hoek2004-02-021-5/+0 * 1) Fix multi-line strings to sate gcc33hoek2004-02-024-0/+78 * - Fix installation of mapconvert.pypav2004-02-029-9/+39 * Upgrade to 0.11.1edwin2004-02-025-124/+131 * - Fix build on AMD64krion2004-02-021-2/+2 * Add xwelltris, Tetris-like game for X11.lev2004-02-025-0/+62 * - Add new architectures, hopefully unbreaking build on amd64/ia64pav2004-02-011-0/+13 * - Update to 0.12krion2004-02-012-2/+2 * - Fix plist forgotten by my last commitkrion2004-02-012-3/+20 * - Update to 0.11krion2004-01-313-25/+5 * - SIZEifykrion2004-01-314-0/+4 * Add intlhack to fix the build on -STABLE.marcus2004-01-312-2/+2 * - Fix and sort plist and bump PORTREVISIONkrion2004-01-312-0/+9 * - Fix plist and bump PORTREVISIONkrion2004-01-312-0/+2 * Fix plist and bump PORTREVISIONkris2004-01-312-0/+2 * - SIZEifykrion2004-01-3010-0/+10 * - Set NO_PACKAGEpav2004-01-301-0/+1 * Add SIZE.ceri2004-01-301-0/+1 * Fix plist and bump PORTREVISIONkris2004-01-306-0/+15 * Tarball was rerolled, the author incorporated my suggestions, but forgot toarved2004-01-302-9/+1 * - Fix build on alphakrion2004-01-302-0/+26 * Add NO_PACKAGE, port is very weird regarding distfiles and legal issues.edwin2004-01-302-0/+2 * Update to 2.4.2.adamw2004-01-304-6/+6 * - Respect CPPFLAGSkrion2004-01-302-2/+23 * - Add also pkg-message, forgotten by me in last commitkrion2004-01-301-0/+6 * - Update to version 0.6krion2004-01-303-3/+14 * - Fix WITH_PERSISTENTpav2004-01-291-1/+1 * - Update to 5.5.9pav2004-01-293-3/+8 * Dunno yet what happened, but the monkeybubble website has disappearedadamw2004-01-291-1/+3 * - Update MASTER_SITESpav2004-01-291-1/+1 * SIZEify.trevor2004-01-29