aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/emacs20-emcws/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-09-23 19:28:55 +0800
committerknu <knu@FreeBSD.org>2002-09-23 19:28:55 +0800
commit494737356dcc983805faa7b8796be456d44508a2 (patch)
tree799151e594d7eb9d4b168345b083f53fcb054ab9 /japanese/emacs20-emcws/Makefile
parent1333ac0a261b7e1bf98b793072900d1b23979a4e (diff)
downloadfreebsd-ports-gnome-494737356dcc983805faa7b8796be456d44508a2.tar.gz
freebsd-ports-gnome-494737356dcc983805faa7b8796be456d44508a2.tar.zst
freebsd-ports-gnome-494737356dcc983805faa7b8796be456d44508a2.zip
Since WITH_{CANNA,FREEWNN,WNN6,SJ3} are always defined, there is no
need to check if they are defined. Remove the checks and correct conditional PLIST_SUB+= assignment. Submitted by: bento
Diffstat (limited to 'japanese/emacs20-emcws/Makefile')
-rw-r--r--japanese/emacs20-emcws/Makefile21
1 files changed, 7 insertions, 14 deletions
diff --git a/japanese/emacs20-emcws/Makefile b/japanese/emacs20-emcws/Makefile
index fce51ec939ae..fe9b6ea667a6 100644
--- a/japanese/emacs20-emcws/Makefile
+++ b/japanese/emacs20-emcws/Makefile
@@ -38,40 +38,37 @@ WITH_CANNA?= YES
WITH_SJ3?= NO
CONFIGURE_TARGET= ${MACHINE_ARCH}--freebsd
+
.if !defined(NO_X11)
CONFIGURE_ARGS= --with-x-toolkit --with-pop
USE_XLIB= YES
.else
CONFIGURE_ARGS= --with-x=no --with-pop
.endif
-.if defined(WITH_WNN6)
+
.if (${WITH_WNN6} == "yes" || ${WITH_WNN6} == "YES")
CONFIGURE_ARGS+=--with-wnn --with-wnn-includes=${LOCALBASE}/include/wnn6/wnn \
--with-wnn-libraries=${LOCALBASE}/lib/libwnn6.so
LIB_DEPENDS+= wnn6.1:${PORTSDIR}/japanese/Wnn6-lib
.endif
-.endif
-.if defined(WITH_FREEWNN)
+
.if (${WITH_FREEWNN} == "yes" || ${WITH_FREEWNN} == "YES")
CONFIGURE_ARGS+=--with-wnn --with-wnn-includes=${LOCALBASE}/include/wnn \
--with-wnn-libraries=${LOCALBASE}/lib/libwnn.so
LIB_DEPENDS+= wnn.0:${PORTSDIR}/japanese/FreeWnn-lib
.endif
-.endif
-.if defined(WITH_CANNA)
+
.if (${WITH_CANNA} == "yes" || ${WITH_CANNA} == "YES")
CONFIGURE_ARGS+= --with-canna \
--with-canna-includes=${LOCALBASE}/include \
--with-canna-libraries=${LOCALBASE}/lib
LIB_DEPENDS+= canna.1:${PORTSDIR}/japanese/Canna
.endif
-.endif
-.if defined(WITH_SJ3)
+
.if (${WITH_SJ3} == "yes" || ${WITH_SJ3} == "YES")
CONFIGURE_ARGS+= --with-sj3
BUILD_DEPENDS+= sj3serv:${PORTSDIR}/japanese/sj3
.endif
-.endif
DOC_FILE= DOC-EMCWS-${EMACS_VER}.1
EMCWS_ELCS= busyu.el \
@@ -97,7 +94,6 @@ EMCWS_ELCS= busyu.el \
wnn-client.el \
wnn-egg.el
-.if defined(WITH_WNN6) || defined(WITH_FREEWNN)
.if (${WITH_WNN6} == "yes" || ${WITH_WNN6} == "YES") || (${WITH_FREEWNN} == "yes" || ${WITH_FREEWNN} == "YES")
EMCWS_ELCS+= egg.elc \
wnn-egg.elc
@@ -105,16 +101,14 @@ PLIST_SUB+= WITH_WNN=""
.else
PLIST_SUB+= WITH_WNN="@comment "
.endif
-.endif
-.if defined(WITH_CANNA)
+
.if (${WITH_CANNA} == "yes" || ${WITH_CANNA} == "YES")
EMCWS_ELCS+= canna.elc
PLIST_SUB+= WITH_CANNA=""
.else
PLIST_SUB+= WITH_CANNA="@comment "
.endif
-.endif
-.if defined(WITH_SJ3)
+
.if (${WITH_SJ3} == "yes" || ${WITH_SJ3} == "YES")
EMCWS_ELCS+= sj3-client.elc \
sj3-egg.elc
@@ -122,7 +116,6 @@ PLIST_SUB+= WITH_SJ3=""
.else
PLIST_SUB+= WITH_SJ3="@comment "
.endif
-.endif
MULE_PATCHED_ELS= ange-ftp.el ange-ftp.elc \
help.el help.elc \