aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/font-motoya-al
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-03-22 07:05:19 +0800
committerbapt <bapt@FreeBSD.org>2015-03-22 07:05:19 +0800
commitfe5a7e4bee2fc7a40343278a44de77847b5c91c5 (patch)
treeb9556c9042a9d20d7c71f49869f39f95afc00052 /japanese/font-motoya-al
parent9167139629893ea7664f3b1cf93141ff1eeb82b4 (diff)
downloadfreebsd-ports-gnome-fe5a7e4bee2fc7a40343278a44de77847b5c91c5.tar.gz
freebsd-ports-gnome-fe5a7e4bee2fc7a40343278a44de77847b5c91c5.tar.zst
freebsd-ports-gnome-fe5a7e4bee2fc7a40343278a44de77847b5c91c5.zip
Make fonts repecting XDG
Xorg is now looking in ${LOCALBASE}/share/fonts by default Xorg now accepts symlinks in etc/X11/fontpath.d (as decribed in Xserver(1)) Large cleanup on lots of font ports All fonts are now properly dynamically generating fonts.dir and fonts.scale instead of sometime overwriting existing ones) All fonts are generating fontconfig's cache Improve consistency in fonts ports
Diffstat (limited to 'japanese/font-motoya-al')
-rw-r--r--japanese/font-motoya-al/Makefile28
-rw-r--r--japanese/font-motoya-al/files/pkg-install.in7
-rw-r--r--japanese/font-motoya-al/pkg-plist7
3 files changed, 11 insertions, 31 deletions
diff --git a/japanese/font-motoya-al/Makefile b/japanese/font-motoya-al/Makefile
index 15872467b975..3b4e73cc8cdb 100644
--- a/japanese/font-motoya-al/Makefile
+++ b/japanese/font-motoya-al/Makefile
@@ -2,7 +2,7 @@
PORTNAME= font-motoya-al
PORTVERSION= 0.0.20100921
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= japanese x11-fonts
MASTER_SITES= LOCAL
MASTER_SITE_SUBDIR= hrs
@@ -11,34 +11,22 @@ DISTNAME= motoya-al-fonts-${PORTVERSION:S,^0.0.,,}
MAINTAINER= hrs@FreeBSD.org
COMMENT= Free Japanese fonts by MOTOYA
-RUN_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig
-
-USES= tar:bzip2
+USES= fonts tar:bzip2
NO_BUILD= yes
PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-install
SUB_FILES= pkg-install
-SUB_LIST= X_FONTSDIR=${PREFIX}/${X_FONTSDIR}
-PLIST_SUB= X_FONTSDIR=${X_FONTSDIR} \
- LOCAL_FONTSDIR=${LOCAL_FONTSDIR}
PORTDOCS= newsrelease20100921.pdf
-LOCAL_FONTSDIR= share/fonts
-X_FONTSDIR= lib/X11/fonts
-
+FONTNAME= TTF
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/*.ttf ${STAGEDIR}${DATADIR}
- ${MKDIR} ${STAGEDIR}${PREFIX}/${LOCAL_FONTSDIR}/TTF
- cd ${STAGEDIR}${PREFIX}/${LOCAL_FONTSDIR}/TTF && ${LN} -s -f \
- ../${LOCAL_FONTSDIR:C,[^/]+,..,g}/${DATADIR_REL}/MTL*.ttf .
- ${MKDIR} ${STAGEDIR}${PREFIX}/${X_FONTSDIR}/TTF
- cd ${STAGEDIR}${PREFIX}/${X_FONTSDIR}/TTF && ${LN} -s -f \
- ../${X_FONTSDIR:C,[^/]+,..,g}/${DATADIR_REL}/MTL*.ttf .
+ ${MKDIR} ${STAGEDIR}${FONTSDIR}
+ cd ${STAGEDIR}${FONTSDIR} && ${LN} -s -f \
+ ../../../${DATADIR_REL}/MTL*.ttf .
${MKDIR} ${STAGEDIR}${PREFIX}/etc/fonts/conf.avail \
${STAGEDIR}${PREFIX}/etc/fonts/conf.d
${INSTALL_DATA} ${FILESDIR}/20-unhint-motoya-al.conf \
@@ -48,11 +36,7 @@ do-install:
${STAGEDIR}${PREFIX}/etc/fonts/conf.d/20-unhint-motoya-al.conf
${LN} -s -f ../conf.avail/62-fonts-motoya-al.conf \
${STAGEDIR}${PREFIX}/etc/fonts/conf.d/62-fonts-motoya-al.conf
-
-.if ${PORT_OPTIONS:MDOCS}
-post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/japanese/font-motoya-al/files/pkg-install.in b/japanese/font-motoya-al/files/pkg-install.in
index a680897e2e58..a4e47a941d82 100644
--- a/japanese/font-motoya-al/files/pkg-install.in
+++ b/japanese/font-motoya-al/files/pkg-install.in
@@ -1,7 +1,7 @@
#!/bin/sh
# $FreeBSD$
-X_FONTSDIR=%%X_FONTSDIR%%/TTF
+FONTSDIR=%%FONTSDIR%%
catfontsdir ()
{
@@ -76,7 +76,7 @@ nfonts ()
case "$2" in
POST-INSTALL)
- cd ${X_FONTSDIR}
+ cd ${FONTSDIR}
touch fonts.dir
(catfontsdir < fonts.dir; addentries) > fonts.dir.tmp
nfonts < fonts.dir.tmp > fonts.dir
@@ -84,7 +84,7 @@ POST-INSTALL)
rm -f fonts.dir.tmp
;;
POST-DEINSTALL)
- cd ${X_FONTSDIR}
+ cd ${FONTSDIR}
catfontsdir < fonts.dir > fonts.dir.tmp
nfonts < fonts.dir.tmp > fonts.dir
cat fonts.dir.tmp >> fonts.dir
@@ -92,6 +92,5 @@ POST-DEINSTALL)
if [ -r fonts.dir -a `wc -l < fonts.dir` = 1 ]; then
rm -f fonts.dir
fi
- rmdir ${X_FONTSDIR} > /dev/null 2>&1 || true
;;
esac
diff --git a/japanese/font-motoya-al/pkg-plist b/japanese/font-motoya-al/pkg-plist
index b8c4bc4098d2..aa9ba6e8acdf 100644
--- a/japanese/font-motoya-al/pkg-plist
+++ b/japanese/font-motoya-al/pkg-plist
@@ -1,11 +1,8 @@
%%DATADIR%%/MTLc3m.ttf
%%DATADIR%%/MTLmr3m.ttf
-%%LOCAL_FONTSDIR%%/TTF/MTLc3m.ttf
-%%LOCAL_FONTSDIR%%/TTF/MTLmr3m.ttf
etc/fonts/conf.avail/20-unhint-motoya-al.conf
etc/fonts/conf.avail/62-fonts-motoya-al.conf
etc/fonts/conf.d/20-unhint-motoya-al.conf
etc/fonts/conf.d/62-fonts-motoya-al.conf
-%%X_FONTSDIR%%/TTF/MTLc3m.ttf
-%%X_FONTSDIR%%/TTF/MTLmr3m.ttf
-@fc %%X_FONTSDIR%%/TTF
+%%FONTSDIR%%/MTLc3m.ttf
+%%FONTSDIR%%/MTLmr3m.ttf