aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/font-vlgothic/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-03-30 07:38:32 +0800
committermiwi <miwi@FreeBSD.org>2008-03-30 07:38:32 +0800
commitd9bfff58533a3d18570ee7e943b76434dbd0d4b7 (patch)
treee274a73dcf364912b674bee7395700cb4a6fa1ac /japanese/font-vlgothic/Makefile
parent88885c43e3a44c5531d1e26e62b9fb63e3c3923e (diff)
downloadfreebsd-ports-gnome-d9bfff58533a3d18570ee7e943b76434dbd0d4b7.tar.gz
freebsd-ports-gnome-d9bfff58533a3d18570ee7e943b76434dbd0d4b7.tar.zst
freebsd-ports-gnome-d9bfff58533a3d18570ee7e943b76434dbd0d4b7.zip
- Update to 20080327
PR: 122076 Submitted by: Ports Fury
Diffstat (limited to 'japanese/font-vlgothic/Makefile')
-rw-r--r--japanese/font-vlgothic/Makefile27
1 files changed, 16 insertions, 11 deletions
diff --git a/japanese/font-vlgothic/Makefile b/japanese/font-vlgothic/Makefile
index 0b9ebd300387..3bad2c361356 100644
--- a/japanese/font-vlgothic/Makefile
+++ b/japanese/font-vlgothic/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= vlgothic
-PORTVERSION= 20071015
+PORTVERSION= 20080327
CATEGORIES= japanese x11-fonts
MASTER_SITES= http://vinelinux.org/~daisuke/vlgothic/
DISTNAME= VLGothic-${PORTVERSION}
@@ -17,31 +17,36 @@ COMMENT= Free Japanese TrueType fonts named 'VLGothic'
BUILD_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig
RUN_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig
+WRKSRC= ${WRKDIR}/VLGothic
+
USE_BZIP2= yes
NO_BUILD= yes
-FONTSDIR= lib/X11/fonts/vlgothic
-PLIST_SUB= FONTSDIR=${FONTSDIR}
+PLIST_SUB= FONTSDIR="${FONTSDIR_REL}"
-WRKSRC= ${WRKDIR}/VLGothic
+FONTSDIR= ${PREFIX}/lib/X11/fonts/vlgothic
+FONTSDIR_REL= ${FONTSDIR:S,${PREFIX}/,,}
+TTF_FILES= VL-PGothic-Regular.ttf VL-Gothic-Regular.ttf
DOC_FILES= Changelog LICENSE LICENSE.en LICENSE_E.mplus LICENSE_J.mplus \
README README.sazanami README_J.mplus
do-install:
- ${MKDIR} ${PREFIX}/${FONTSDIR}
- ${INSTALL_DATA} ${WRKSRC}/VL-PGothic-Regular.ttf \
- ${WRKSRC}/VL-Gothic-Regular.ttf \
- ${PREFIX}/${FONTSDIR}
- ${MKDIR} ${PREFIX}/etc/fonts/conf.d
+ @${MKDIR} ${FONTSDIR}
+.for file in ${TTF_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${FONTSDIR}
+.endfor
+ @${MKDIR} ${PREFIX}/etc/fonts/conf.d
${INSTALL_DATA} ${FILESDIR}/63-vlgothic.conf \
${PREFIX}/etc/fonts/conf.d
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${DOC_FILES:S,^,${WRKSRC}/,} ${DOCSDIR}
+.for file in ${DOC_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
.endif
post-install:
- ${X11BASE}/bin/fc-cache -f -v ${PREFIX}/${FONTSDIR}
+ ${LOCALBASE}/bin/fc-cache -f -v ${FONTSDIR}
.include <bsd.port.mk>