aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/gicq/Makefile
diff options
context:
space:
mode:
authorflathill <flathill@FreeBSD.org>1998-11-19 15:39:16 +0800
committerflathill <flathill@FreeBSD.org>1998-11-19 15:39:16 +0800
commitd3d62c3a94036dd4e2c506ecce77961f7dc04595 (patch)
tree80fbbfc061522185f0ed8152afac6d7ae1fe0314 /japanese/gicq/Makefile
parent50a6690956a71c86d70402da1c5f03a3ec3694d6 (diff)
downloadfreebsd-ports-gnome-d3d62c3a94036dd4e2c506ecce77961f7dc04595.tar.gz
freebsd-ports-gnome-d3d62c3a94036dd4e2c506ecce77961f7dc04595.tar.zst
freebsd-ports-gnome-d3d62c3a94036dd4e2c506ecce77961f7dc04595.zip
Initial Import ja-gicq.(gicq for japanese)
Diffstat (limited to 'japanese/gicq/Makefile')
-rw-r--r--japanese/gicq/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/japanese/gicq/Makefile b/japanese/gicq/Makefile
new file mode 100644
index 000000000000..f2f923c12d11
--- /dev/null
+++ b/japanese/gicq/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: gicq
+# Version required: 0.22
+# Date Created: 31 Oct 1998
+# Whom: Seiichirou Hiraoka
+#
+# $Id$
+#
+
+DISTNAME= gicq-0.22
+PKGNAME= ja-gicq-0.22
+CATEGORIES= japanese net
+MASTER_SITES= http://www.montana.com/gabriel/gicq/files/
+
+PATCH_SITES= http://flos.kuee.kyoto-u.ac.jp/soft/
+PATCHFILES= gicq-0.22ja.patch
+PATCH_DIST_STRIP= -p1
+
+MAINTAINER= flathill@FreeBSD.ORG
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-gnome --disable-nls
+CONFIGURE_ENV= LIBS=-lxpg4
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libicq.a:${PORTSDIR}/japanese/libicq \
+ ${X11BASE}/lib/libgtk.a:${PORTSDIR}/japanese/gtk
+
+post-configure:
+ @${SED} -e "s;@PREFIX@;${PREFIX};g" ${FILESDIR}/wrapper \
+ > ${WRKDIR}/wrapper
+
+post-install:
+ @${MV} ${PREFIX}/bin/gicq ${PREFIX}/bin/gicq.bin
+ @${INSTALL_SCRIPT} ${WRKDIR}/wrapper ${PREFIX}/bin/gicq
+ @${INSTALL_DATA} \
+ ${FILESDIR}/menu.gicq ${PREFIX}/share/ja-gtk/menu/menu.gicq.bin
+
+.include <bsd.port.mk>