aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/gxditview/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1995-05-02 18:36:33 +0800
committerasami <asami@FreeBSD.org>1995-05-02 18:36:33 +0800
commit3794d6ca5d2122f2a24a86cf95e262dd2406240f (patch)
tree218cd7709c0020d493a9eac3404fb079403016a9 /japanese/gxditview/Makefile
parent3e45c5b944f779f97f2b8f2f8f0fbfc3917729b5 (diff)
downloadfreebsd-ports-gnome-3794d6ca5d2122f2a24a86cf95e262dd2406240f.tar.gz
freebsd-ports-gnome-3794d6ca5d2122f2a24a86cf95e262dd2406240f.tar.zst
freebsd-ports-gnome-3794d6ca5d2122f2a24a86cf95e262dd2406240f.zip
Oops, deleted too much (says)
Submitted by: Nobuhiro Yasutomi <nobu@psrc.isac.co.jp>
Diffstat (limited to 'japanese/gxditview/Makefile')
-rw-r--r--japanese/gxditview/Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/japanese/gxditview/Makefile b/japanese/gxditview/Makefile
index 74149812ca71..2d682e76d76c 100644
--- a/japanese/gxditview/Makefile
+++ b/japanese/gxditview/Makefile
@@ -3,7 +3,7 @@
# Date created: 14 April 1995
# Whom: Nobuhiro Yasutomi <nobu@psrc.isac.co.jp>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1995/05/02 10:07:43 asami Exp $
#
DISTNAME= groff-1.09
@@ -20,4 +20,20 @@ PATCH_DIST_ARGS?= -d ${WRKSRC}/.. --forward --quiet -E -p1
USE_IMAKE= yes
WRKSRC=${.CURDIR}/work/${DISTNAME}/xditview
+pre-fetch:
+ @(cd ${DISTDIR}; \
+ if [ ! -f ${PATCHFILES} ]; then \
+ ${ECHO_MSG} ">> ${PATCHFILES} doesn't seem to exist on this system."; \
+ for file in ${DISTPATCHES} ; do \
+ for site in ${PATCH_SITES} ; do \
+ if ${NCFTP} ${NCFTPFLAGS} $${site}$${file}; then \
+ break; \
+ fi \
+ done; \
+ done; \
+ for file in ${DISTPATCHES} ; do zcat $${file}; done | \
+ sed '/^END -----/,/^BEGIN ----/d' | uudecode; \
+ rm -f ${DISTPATCHES};\
+ fi)
+
.include <bsd.port.mk>