aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/ibus-anthy
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2012-01-14 11:35:54 +0800
committerdaichi <daichi@FreeBSD.org>2012-01-14 11:35:54 +0800
commit25f02b54f75ad6b6f28eabb8d9d341dedfdc3bb5 (patch)
tree97efb60add9b47cbf2fb62912110e2046ff441c6 /japanese/ibus-anthy
parentd9cfe75cae14415497768bdc94a3064f93447e53 (diff)
downloadfreebsd-ports-gnome-25f02b54f75ad6b6f28eabb8d9d341dedfdc3bb5.tar.gz
freebsd-ports-gnome-25f02b54f75ad6b6f28eabb8d9d341dedfdc3bb5.tar.zst
freebsd-ports-gnome-25f02b54f75ad6b6f28eabb8d9d341dedfdc3bb5.zip
- updated to 1.2.6
- changed for ibus 1.4.0 - clean-up Makefile
Diffstat (limited to 'japanese/ibus-anthy')
-rw-r--r--japanese/ibus-anthy/Makefile58
-rw-r--r--japanese/ibus-anthy/distinfo4
-rw-r--r--japanese/ibus-anthy/files/patch-configure28
-rw-r--r--japanese/ibus-anthy/files/patch-engine_Makefile.am6
-rw-r--r--japanese/ibus-anthy/files/patch-engine_Makefile.in8
-rw-r--r--japanese/ibus-anthy/files/patch-po_Makefile.in.in4
-rw-r--r--japanese/ibus-anthy/files/patch-setup_main.py4
-rw-r--r--japanese/ibus-anthy/pkg-plist7
8 files changed, 52 insertions, 67 deletions
diff --git a/japanese/ibus-anthy/Makefile b/japanese/ibus-anthy/Makefile
index 39d5a477338c..e01c4b4f652a 100644
--- a/japanese/ibus-anthy/Makefile
+++ b/japanese/ibus-anthy/Makefile
@@ -6,59 +6,43 @@
#
PORTNAME= ibus-anthy
-PORTVERSION= 1.2.4
+PORTVERSION= 1.2.6
CATEGORIES= japanese
+PROJECTHOST= ibus
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
MAINTAINER= daichi@FreeBSD.org
COMMENT= Anthy engine for IBus
BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13
-LIB_DEPENDS+= anthy.1:${PORTSDIR}/japanese/anthy \
- ibus.2:${PORTSDIR}/textproc/ibus
+LIB_DEPENDS= anthy.1:${PORTSDIR}/japanese/anthy \
+ ibus-1.0.400:${PORTSDIR}/textproc/ibus
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-2.0/pynotify/_pynotify.so:${PORTSDIR}/devel/py-notify
-USE_GNOME= pygtk2
-USE_PYTHON= yes
-
-USE_GMAKE= yes
GNU_CONFIGURE= yes
-
-PROJECTHOST= ibus
-
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+USE_GMAKE= yes
USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
-.endif
+USE_PYTHON= yes
+USE_GNOME= pygtk2
-REPLACE_FILES= engine/engine.py setup/anthyprefs.py setup/main.py
+LOCALBASE_REPLACE_FILES= \
+ engine/engine.py \
+ setup/anthyprefs.py \
+ setup/main.py
-post-patch:
- @for FILE in ${REPLACE_FILES}; do \
- ${SED} -i .bak -e "s/@@LOCALBASE@@/${LOCALBASE:S/\//\\\//g}/g" \
- ${WRKSRC}/$${FILE}; \
- done;
+INCLUDEDIR_REPLACE_FILES= \
+ engine/Makefile.am \
+ engine/Makefile.in
-port-build:
-.if !defined(WITHOUT_NLS)
- @cd ${WRKSRC}/po; \
- ${GMAKE} all-yes
-.endif
+post-patch:
+ cd ${WRKSRC} && \
+ ${REINPLACE_CMD} "s/@@LOCALBASE@@/${LOCALBASE:S/\//\\\//g}/g" \
+ ${LOCALBASE_REPLACE_FILES} && \
+ ${REINPLACE_CMD} "s/@@INCLUDEDIR@@/${INCLUDEDIR:S/\//\\\//g}/g" \
+ ${INCLUDEDIR_REPLACE_FILES}
post-install:
-.if !defined(WITHOUT_NLS)
- @cd ${WRKSRC}/po; \
- ${GMAKE} install-data-yes
- @${CHMOD} 444 \
- ${LOCALBASE}/share/locale/fr/LC_MESSAGES/ibus-anthy.mo \
- ${LOCALBASE}/share/locale/ja/LC_MESSAGES/ibus-anthy.mo \
- ${LOCALBASE}/share/locale/zh_CN/LC_MESSAGES/ibus-anthy.mo
-
-.endif
@${CAT} ${PKGMESSAGE}
- @${ECHO} To display this message again, type ${PKG_INFO} -D ${PKGNAME}
+ @${ECHO_CMD} To display this message again, type ${PKG_INFO} -D ${PKGNAME}
.include <bsd.port.mk>
diff --git a/japanese/ibus-anthy/distinfo b/japanese/ibus-anthy/distinfo
index 5f22dc429e42..ef17e08f3987 100644
--- a/japanese/ibus-anthy/distinfo
+++ b/japanese/ibus-anthy/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ibus-anthy-1.2.4.tar.gz) = 6fb22a28445b8c6d4e42ebc163968709faab1a903a2699aa1ce30b4c11e06736
-SIZE (ibus-anthy-1.2.4.tar.gz) = 496158
+SHA256 (ibus-anthy-1.2.6.tar.gz) = e4d5eb27c35295a69c0baa308a6589c8aea19f72317d08b692437af5512dd6f6
+SIZE (ibus-anthy-1.2.6.tar.gz) = 519488
diff --git a/japanese/ibus-anthy/files/patch-configure b/japanese/ibus-anthy/files/patch-configure
index 310092d36d5a..89d1bca71027 100644
--- a/japanese/ibus-anthy/files/patch-configure
+++ b/japanese/ibus-anthy/files/patch-configure
@@ -1,38 +1,38 @@
---- configure.org 2010-10-26 21:43:56.110339260 +0900
-+++ configure 2010-10-26 21:45:26.167340080 +0900
-@@ -16347,7 +16347,7 @@
+--- configure.orig 2012-01-14 12:14:14.987155483 +0900
++++ configure 2012-01-14 12:24:25.699154843 +0900
+@@ -17010,7 +17010,7 @@
if test $ac_have_decl = 1; then :
else
-- as_fn_error "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
-+# as_fn_error "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
+- as_fn_error $? "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
++# as_fn_error $? "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
fi
ac_fn_c_check_decl "$LINENO" "NTH_KATAKANA_CANDIDATE" "ac_cv_have_decl_NTH_KATAKANA_CANDIDATE" "#include <anthy/anthy.h>
"
-@@ -16363,7 +16363,7 @@
+@@ -17026,7 +17026,7 @@
if test $ac_have_decl = 1; then :
else
-- as_fn_error "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
-+# as_fn_error "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
+- as_fn_error $? "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
++# as_fn_error $? "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
fi
ac_fn_c_check_decl "$LINENO" "NTH_HIRAGANA_CANDIDATE" "ac_cv_have_decl_NTH_HIRAGANA_CANDIDATE" "#include <anthy/anthy.h>
"
-@@ -16379,7 +16379,7 @@
+@@ -17042,7 +17042,7 @@
if test $ac_have_decl = 1; then :
else
-- as_fn_error "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
-+# as_fn_error "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
+- as_fn_error $? "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
++# as_fn_error $? "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
fi
ac_fn_c_check_decl "$LINENO" "NTH_HALFKANA_CANDIDATE" "ac_cv_have_decl_NTH_HALFKANA_CANDIDATE" "#include <anthy/anthy.h>
"
-@@ -16395,7 +16395,7 @@
+@@ -17058,7 +17058,7 @@
if test $ac_have_decl = 1; then :
else
-- as_fn_error "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
-+# as_fn_error "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
+- as_fn_error $? "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
++# as_fn_error $? "Could not find NTH_*_CANDIDATE values in anthy.h" "$LINENO" 5
fi
diff --git a/japanese/ibus-anthy/files/patch-engine_Makefile.am b/japanese/ibus-anthy/files/patch-engine_Makefile.am
index 9b4153dce742..c9dd4de9e8e8 100644
--- a/japanese/ibus-anthy/files/patch-engine_Makefile.am
+++ b/japanese/ibus-anthy/files/patch-engine_Makefile.am
@@ -1,11 +1,11 @@
---- engine/Makefile.am.org 2010-10-26 21:45:32.256341895 +0900
-+++ engine/Makefile.am 2010-10-26 21:46:30.290338394 +0900
+--- engine/Makefile.am.orig 2012-01-14 12:14:14.982155825 +0900
++++ engine/Makefile.am 2012-01-14 12:24:26.006155593 +0900
@@ -62,7 +62,7 @@
enginedir = $(datadir)/ibus/component
anthy.py anthy_wrap.c: anthy.i
- $(SWIG) -python $(ANTHY_CFLAGS) -I/usr/include -o anthy_wrap.c $(srcdir)/anthy.i
-+ $(SWIG) -python -I/usr/include ${ANTHY_CFLAGS} -o anthy_wrap.c $(srcdir)/anthy.i
++ $(SWIG) -python -I@@INCLUDEDIR@@ ${ANTHY_CFLAGS} -o anthy_wrap.c $(srcdir)/anthy.i
anthy.xml: anthy.xml.in
( \
diff --git a/japanese/ibus-anthy/files/patch-engine_Makefile.in b/japanese/ibus-anthy/files/patch-engine_Makefile.in
index d5a6176e319f..a312172846dc 100644
--- a/japanese/ibus-anthy/files/patch-engine_Makefile.in
+++ b/japanese/ibus-anthy/files/patch-engine_Makefile.in
@@ -1,11 +1,11 @@
---- engine/Makefile.in.org 2010-10-26 21:46:34.816343795 +0900
-+++ engine/Makefile.in 2010-10-26 21:46:56.693338776 +0900
-@@ -791,7 +791,7 @@
+--- engine/Makefile.in.orig 2012-01-14 12:14:14.982155825 +0900
++++ engine/Makefile.in 2012-01-14 12:24:25.982156733 +0900
+@@ -795,7 +795,7 @@
anthy.py anthy_wrap.c: anthy.i
- $(SWIG) -python $(ANTHY_CFLAGS) -I/usr/include -o anthy_wrap.c $(srcdir)/anthy.i
-+ $(SWIG) -python -I/usr/include ${ANTHY_CFLAGS} -o anthy_wrap.c $(srcdir)/anthy.i
++ $(SWIG) -python -I@@INCLUDEDIR@@ ${ANTHY_CFLAGS} -o anthy_wrap.c $(srcdir)/anthy.i
anthy.xml: anthy.xml.in
( \
diff --git a/japanese/ibus-anthy/files/patch-po_Makefile.in.in b/japanese/ibus-anthy/files/patch-po_Makefile.in.in
index 1f9a7f9f6966..d7dcbbadd7b7 100644
--- a/japanese/ibus-anthy/files/patch-po_Makefile.in.in
+++ b/japanese/ibus-anthy/files/patch-po_Makefile.in.in
@@ -1,5 +1,5 @@
---- po/Makefile.in.in.org 2010-10-26 21:47:03.832342476 +0900
-+++ po/Makefile.in.in 2010-10-26 21:47:19.182337797 +0900
+--- po/Makefile.in.in.orig 2012-01-14 12:14:14.985154041 +0900
++++ po/Makefile.in.in 2012-01-13 11:29:00.154154365 +0900
@@ -34,7 +34,7 @@
datarootdir = @datarootdir@
libdir = @libdir@
diff --git a/japanese/ibus-anthy/files/patch-setup_main.py b/japanese/ibus-anthy/files/patch-setup_main.py
index 4c48e15334df..762e9d9c914f 100644
--- a/japanese/ibus-anthy/files/patch-setup_main.py
+++ b/japanese/ibus-anthy/files/patch-setup_main.py
@@ -1,5 +1,5 @@
---- setup/main.py.org 2010-10-26 21:47:23.526339618 +0900
-+++ setup/main.py 2010-10-26 21:47:47.987340388 +0900
+--- setup/main.py.orig 2012-01-14 12:14:14.986154797 +0900
++++ setup/main.py 2012-01-14 12:24:25.953154304 +0900
@@ -58,7 +58,7 @@
# glade "icon_name" property has a custom scaling and it seems
# to be difficult to show the complicated small icon in metacity.
diff --git a/japanese/ibus-anthy/pkg-plist b/japanese/ibus-anthy/pkg-plist
index 6b1857b7e280..d324e85c86d0 100644
--- a/japanese/ibus-anthy/pkg-plist
+++ b/japanese/ibus-anthy/pkg-plist
@@ -3,6 +3,7 @@
%%PYTHON_SITELIBDIR%%/anthy.py
libexec/ibus-engine-anthy
libexec/ibus-setup-anthy
+%%DATADIR%%/dicts/oldchar.t
%%DATADIR%%/dicts/symbol.t
%%DATADIR%%/engine/engine.py
%%DATADIR%%/engine/engine.pyc
@@ -43,9 +44,9 @@ libexec/ibus-setup-anthy
%%DATADIR%%/setup/prefs.pyo
%%DATADIR%%/setup/setup.glade
share/ibus/component/anthy.xml
-%%NLS%%share/locale/fr/LC_MESSAGES/ibus-anthy.mo
-%%NLS%%share/locale/ja/LC_MESSAGES/ibus-anthy.mo
-%%NLS%%share/locale/zh_CN/LC_MESSAGES/ibus-anthy.mo
+share/locale/fr/LC_MESSAGES/ibus-anthy.mo
+share/locale/ja/LC_MESSAGES/ibus-anthy.mo
+share/locale/zh_CN/LC_MESSAGES/ibus-anthy.mo
@dirrm %%DATADIR%%/setup
@dirrm %%DATADIR%%/icons
@dirrm %%DATADIR%%/engine