aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/iiimf-le-freewnn/files
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2005-03-04 19:38:18 +0800
committerdaichi <daichi@FreeBSD.org>2005-03-04 19:38:18 +0800
commite7badae326222207e55c2db855589599e59da059 (patch)
tree20e62c3824b66b0d794469cf89706ea411f3ca3b /japanese/iiimf-le-freewnn/files
parentfd9019ca0a57f34d2c9dffc06a547161e38f6df0 (diff)
downloadfreebsd-ports-gnome-e7badae326222207e55c2db855589599e59da059.tar.gz
freebsd-ports-gnome-e7badae326222207e55c2db855589599e59da059.tar.zst
freebsd-ports-gnome-e7badae326222207e55c2db855589599e59da059.zip
IIIMF-related ports some changes:
- support CFLAGS of /etc/make.conf - replace absolute path with ${LOCALBASE}, ${PREFIX} and others - replace -pthread flags with ${THREAD*} - m17n fixed of gnome-im-swither - fixed vid krisbot Submitted by: Masanori OZAWA <ozawa@ongs.co.jp>
Diffstat (limited to 'japanese/iiimf-le-freewnn/files')
-rw-r--r--japanese/iiimf-le-freewnn/files/patch-Makefile2
-rw-r--r--japanese/iiimf-le-freewnn/files/patch-acfiles_check_sys.m438
-rw-r--r--japanese/iiimf-le-freewnn/files/patch-leif_autogen.sh93
-rw-r--r--japanese/iiimf-le-freewnn/files/patch-leif_configure.ac6
-rw-r--r--japanese/iiimf-le-freewnn/files/patch-leif_freewnn_Makefile.am13
-rw-r--r--japanese/iiimf-le-freewnn/files/patch-leif_freewnn_freewnn.c4
6 files changed, 50 insertions, 106 deletions
diff --git a/japanese/iiimf-le-freewnn/files/patch-Makefile b/japanese/iiimf-le-freewnn/files/patch-Makefile
index 85df0e345035..bcc2cb24a1c8 100644
--- a/japanese/iiimf-le-freewnn/files/patch-Makefile
+++ b/japanese/iiimf-le-freewnn/files/patch-Makefile
@@ -13,7 +13,7 @@
update-acfiles:
cd acfiles && \
- $(ACLOCAL) && $(AUTOMAKE) --add-missing --copy && libtoolize --force --copy && \
-+ $(ACLOCAL) && $(AUTOMAKE) --add-missing --copy && $(LIBTOOLIZE) --force --copy && \
++ $(ACLOCAL) $(ACLOCAL_DIR) && $(AUTOMAKE) --add-missing --copy && $(LIBTOOLIZE) --force --copy && \
rm -f Makefile.in aclocal.m4
config:
diff --git a/japanese/iiimf-le-freewnn/files/patch-acfiles_check_sys.m4 b/japanese/iiimf-le-freewnn/files/patch-acfiles_check_sys.m4
new file mode 100644
index 000000000000..8626eeae1fd1
--- /dev/null
+++ b/japanese/iiimf-le-freewnn/files/patch-acfiles_check_sys.m4
@@ -0,0 +1,38 @@
+--- acfiles/check_sys.m4.orig Tue Sep 14 13:31:27 2004
++++ acfiles/check_sys.m4 Wed Mar 2 08:39:25 2005
+@@ -203,6 +203,11 @@
+ CXX=${CC}
+ fi
+ ;;
++ cc*:*)
++ COMMON_CFLAGS="${COMMON_CFLAGS} -Wall"
++ SHLIBCFLAGS='-fpic'
++ SHLIBLDFLAGS='-shared'
++ ;;
+ *)
+ DEBUG_CXX_CFLAGS="${DEBUG_CXX_CFLAGS} -g"
+ ;;
+@@ -249,8 +254,8 @@
+ COMMON_CXX_CFLAGS="${COMMON_CXX_CFLAGS} -DLinux"
+ ;;
+ *freebsd*)
+- THREAD_LDFLAGS="-pthread"
+- PTHREAD_LIBS=""
++ THREAD_LDFLAGS=""
++ PTHREAD_LIBS="${PTHREAD_LIBS}"
+ ;;
+ esac
+
+@@ -288,9 +293,9 @@
+ THREAD_CXX_CFLAGS="-mt"
+ HAVE_THREAD="uithread"
+ ;;
+- *freebsd*@gcc:*)
+- THREAD_LDFLAGS="-pthread"
+- THREAD_LIBS=""
++ *freebsd*@cc:*|*freebsd*@gcc:*)
++ THREAD_LDFLAGS=""
++ THREAD_LIBS="${PTHREAD_LIBS}"
+ HAVE_THREAD="freebsd-pthread"
+ ;;
+ *linux*)
diff --git a/japanese/iiimf-le-freewnn/files/patch-leif_autogen.sh b/japanese/iiimf-le-freewnn/files/patch-leif_autogen.sh
deleted file mode 100644
index d38d31e628c7..000000000000
--- a/japanese/iiimf-le-freewnn/files/patch-leif_autogen.sh
+++ /dev/null
@@ -1,93 +0,0 @@
---- leif/autogen.sh Thu Dec 11 15:29:55 2003
-+++ leif/autogen.sh Wed Feb 16 16:53:53 2005
-@@ -6,6 +6,14 @@
-
- DIE=0
-
-+LIBTOOL=libtool15
-+INTLTOOLIZE=intltoolize
-+LIBTOOLIZE=libtoolize15
-+ACLOCAL=aclocal15
-+AUTOHEADER=autoheader253
-+AUTOMAKE=automake15
-+AUTOCONF=autoconf253
-+
- ACLOCAL_FLAGS="-I ../acfiles $ACLOCAL_FLAGS"
-
- if [ -n "$GNOME2_DIR" ]; then
-@@ -22,7 +30,7 @@
- exit 1
- }
-
--(autoconf --version) < /dev/null > /dev/null 2>&1 || {
-+(${AUTOCONF} --version) < /dev/null > /dev/null 2>&1 || {
- echo
- echo "**Error**: You must have \`autoconf' installed."
- echo "Download the appropriate package for your distribution,"
-@@ -31,7 +39,7 @@
- }
-
- (grep "^AC_PROG_INTLTOOL" $srcdir/configure.ac >/dev/null) && {
-- (intltoolize --version) < /dev/null > /dev/null 2>&1 || {
-+ (${INTLTOOLIZE} --version) < /dev/null > /dev/null 2>&1 || {
- echo
- echo "**Error**: You must have \`intltool' installed."
- echo "You can get it from:"
-@@ -41,7 +49,7 @@
- }
-
- (grep "^AM_PROG_LIBTOOL" $srcdir/configure.ac >/dev/null) && {
-- (libtool --version) < /dev/null > /dev/null 2>&1 || {
-+ (${LIBTOOL} --version) < /dev/null > /dev/null 2>&1 || {
- echo
- echo "**Error**: You must have \`libtool' installed."
- echo "You can get it from: ftp://ftp.gnu.org/pub/gnu/"
-@@ -59,7 +67,7 @@
- }
- }
-
--(automake --version) < /dev/null > /dev/null 2>&1 || {
-+(${AUTOMAKE} --version) < /dev/null > /dev/null 2>&1 || {
- echo
- echo "**Error**: You must have \`automake' installed."
- echo "You can get it from: ftp://ftp.gnu.org/pub/gnu/"
-@@ -69,7 +77,7 @@
-
-
- # if no automake, don't bother testing for aclocal
--test -n "$NO_AUTOMAKE" || (aclocal --version) < /dev/null > /dev/null 2>&1 || {
-+test -n "$NO_AUTOMAKE" || (${ACLOCAL} --version) < /dev/null > /dev/null 2>&1 || {
- echo
- echo "**Error**: Missing \`aclocal'. The version of \`automake'"
- echo "installed doesn't appear recent enough."
-@@ -114,24 +122,24 @@
- fi
- if grep "^AC_PROG_INTLTOOL" configure.ac >/dev/null; then
- echo "Running intltoolize..."
-- intltoolize --copy --force --automake
-+ ${INTLTOOLIZE} --copy --force --automake
- fi
- if grep "^AM_PROG_LIBTOOL" configure.ac >/dev/null; then
- if test -z "$NO_LIBTOOLIZE" ; then
- echo "Running libtoolize..."
-- libtoolize --force --copy
-+ ${LIBTOOLIZE} --force --copy
- fi
- fi
- echo "Running aclocal $aclocalinclude ..."
-- aclocal $aclocalinclude
-+ ${ACLOCAL} $aclocalinclude
- if grep "^AM_CONFIG_HEADER" configure.ac >/dev/null; then
- echo "Running autoheader..."
-- autoheader
-+ ${AUTOHEADER}
- fi
- echo "Running automake --gnu $am_opt ..."
-- automake --add-missing --copy --gnu $am_opt
-+ ${AUTOMAKE} --add-missing --copy --gnu $am_opt
- echo "Running autoconf ..."
-- autoconf
-+ ${AUTOCONF}
- )
- fi
- done
diff --git a/japanese/iiimf-le-freewnn/files/patch-leif_configure.ac b/japanese/iiimf-le-freewnn/files/patch-leif_configure.ac
index b99e2e345198..5ffdb17a57bc 100644
--- a/japanese/iiimf-le-freewnn/files/patch-leif_configure.ac
+++ b/japanese/iiimf-le-freewnn/files/patch-leif_configure.ac
@@ -7,15 +7,15 @@
CFLAGS="${COMMON_CXX_CFLAGS} ${COMMON_CFLAGS} \
${DEBUG_CXX_CFLAGS} ${DEBUG_CFLAGS} \
- ${THREAD_COMMON_CXX_CFLAGS}"
-+ ${THREAD_COMMON_CXX_CFLAGS} -I/usr/local/include -I/usr/X11R6/include"
++ ${THREAD_COMMON_CXX_CFLAGS} ${CFLAGS}"
CXXFLAGS="${COMMON_CXX_CFLAGS} ${COMMON_CXXFLAGS} \
${DEBUG_CXX_CFLAGS} ${DEBUG_CXXFLAGS} \
- ${THREAD_COMMON_CXX_CFLAGS}"
-+ ${THREAD_COMMON_CXX_CFLAGS} -I/usr/local/include"
++ ${THREAD_COMMON_CXX_CFLAGS} ${CXXFLAGS}"
-LDFLAGS="${COMMON_LDFLAGS} ${THREAD_LDFLAGS}"
-+LDFLAGS="${COMMON_LDFLAGS} ${THREAD_LDFLAGS} -L/usr/local/lib"
++LDFLAGS="${COMMON_LDFLAGS} ${THREAD_LDFLAGS} ${LDFLAGS}"
-LE_TARGETS="default template sampleja sampleja2 sampleja3 newpy testEIMIL unit hangul chewing"
+LE_TARGETS="freewnn"
diff --git a/japanese/iiimf-le-freewnn/files/patch-leif_freewnn_Makefile.am b/japanese/iiimf-le-freewnn/files/patch-leif_freewnn_Makefile.am
index 8f6397344fe4..88801a97abe2 100644
--- a/japanese/iiimf-le-freewnn/files/patch-leif_freewnn_Makefile.am
+++ b/japanese/iiimf-le-freewnn/files/patch-leif_freewnn_Makefile.am
@@ -1,13 +1,12 @@
---- leif/freewnn/Makefile.am.orig Sun Feb 20 14:47:50 2005
-+++ leif/freewnn/Makefile.am Sun Feb 20 14:48:49 2005
-@@ -3,8 +3,8 @@
+--- leif/freewnn/Makefile.am.orig Wed Mar 2 23:48:30 2005
++++ leif/freewnn/Makefile.am Wed Mar 2 23:49:21 2005
+@@ -3,7 +3,8 @@
-DNO_COLOR_FEEDBACK -DNO_CARET_NEGO \
-I$(IM_INCLUDEDIR)/iml \
-I$(CSCONV_DIR) \
- -I/usr/include/wnn
--FreeWnnLE_la_LDFLAGS = -module -rpath $(IM_LEIFDIR) $(SHLIBLDFLAGS) $(THREAD_LDFLAGS)
-+ -I/usr/local/include/wnn
-+FreeWnnLE_la_LDFLAGS = -module -rpath $(IM_LEIFDIR) $(SHLIBLDFLAGS) $(THREAD_LDFLAGS) -L/usr/local/lib
++ -DLOCALBASE="\"${LOCALBASE}\"" \
++ -DIMDIR="\"${IMDIR}\""
+ FreeWnnLE_la_LDFLAGS = -module -rpath $(IM_LEIFDIR) $(SHLIBLDFLAGS) $(THREAD_LDFLAGS)
FreeWnnLE_la_LIBADD = -lwnn $(THREAD_LIBS)
FreeWnnLE_la_SOURCES = freewnn.c
- noinst_LTLIBRARIES = FreeWnnLE.la
diff --git a/japanese/iiimf-le-freewnn/files/patch-leif_freewnn_freewnn.c b/japanese/iiimf-le-freewnn/files/patch-leif_freewnn_freewnn.c
index 84532ed858d6..255f856ea558 100644
--- a/japanese/iiimf-le-freewnn/files/patch-leif_freewnn_freewnn.c
+++ b/japanese/iiimf-le-freewnn/files/patch-leif_freewnn_freewnn.c
@@ -5,10 +5,10 @@
#endif
-#define WNNRCFILE "/etc/FreeWnn/ja/wnnenvrc"
-+#define WNNRCFILE "/usr/local/lib/wnn/ja_JP/wnnenvrc"
++#define WNNRCFILE (LOCALBASE "/lib/wnn/ja_JP/wnnenvrc")
-#define CSC_PATH "/usr/lib/im/csconv/csconv.so"
-+#define CSC_PATH "/usr/local/lib/im/csconv/csconv.so"
++#define CSC_PATH (IMDIR "/csconv/csconv.so")
#define CSC_OPEN_LOCALE "csconv_open_locale"
#define CSC_OPEN "csconv_open"
#define CSC_CONV "csconv"