aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/jcode.pl
diff options
context:
space:
mode:
authorsada <sada@FreeBSD.org>2002-07-10 15:38:49 +0800
committersada <sada@FreeBSD.org>2002-07-10 15:38:49 +0800
commitf5a99abb18d4e8cc5f3d41673fc06053bbfb3f68 (patch)
tree153432c179ac5358f0d8ca3abc169d6ebe638c91 /japanese/jcode.pl
parentc2018e60a4bf233e363568e9e0017590dffc64a2 (diff)
downloadfreebsd-ports-gnome-f5a99abb18d4e8cc5f3d41673fc06053bbfb3f68.tar.gz
freebsd-ports-gnome-f5a99abb18d4e8cc5f3d41673fc06053bbfb3f68.tar.zst
freebsd-ports-gnome-f5a99abb18d4e8cc5f3d41673fc06053bbfb3f68.zip
- upgrade to version 2.13
- note proper MASTER_SITE and WWW - use perl5 base install location
Diffstat (limited to 'japanese/jcode.pl')
-rw-r--r--japanese/jcode.pl/Makefile13
-rw-r--r--japanese/jcode.pl/distinfo2
-rw-r--r--japanese/jcode.pl/pkg-descr16
-rw-r--r--japanese/jcode.pl/pkg-plist3
4 files changed, 14 insertions, 20 deletions
diff --git a/japanese/jcode.pl/Makefile b/japanese/jcode.pl/Makefile
index 14d6c7a2b6b1..369facf02469 100644
--- a/japanese/jcode.pl/Makefile
+++ b/japanese/jcode.pl/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= jcode.pl
-PORTVERSION= 2.10
+PORTVERSION= 2.13
CATEGORIES= japanese
-MASTER_SITES= ftp://ftp.iij.ad.jp/pub/IIJ/dist/utashiro/perl/ \
- ftp://ftp.sra.co.jp/pub/lang/perl/sra-scripts/
+MASTER_SITES= http://srekcah.org/jcode/
EXTRACT_SUFX= # none
MAINTAINER= sada@FreeBSD.org
@@ -19,11 +18,13 @@ NO_BUILD= yes
EXTRACT_CMD= ${CP}
EXTRACT_BEFORE_ARGS=
EXTRACT_AFTER_ARGS= .
+PLIST_SUB= INSTALL_BASE=${INSTALL_BASE}
-INSTALLDIR= ${PREFIX}/lib/perl
+INSTALL_BASE= lib/perl5/site_perl/${PERL_VER}
+INSTALL_DIR= ${PREFIX}/${INSTALL_BASE}
do-install:
- @${MKDIR} ${INSTALLDIR}
- ${INSTALL_DATA} ${WRKDIR}/${DISTNAME} ${INSTALLDIR}/jcode.pl
+ ${MKDIR} ${INSTALL_DIR}
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME} ${INSTALL_DIR}/${PORTNAME}
.include <bsd.port.mk>
diff --git a/japanese/jcode.pl/distinfo b/japanese/jcode.pl/distinfo
index dcae05a6c832..67939167e19e 100644
--- a/japanese/jcode.pl/distinfo
+++ b/japanese/jcode.pl/distinfo
@@ -1 +1 @@
-MD5 (jcode.pl-2.10) = d4f33ca814bef7461cbbd4173b60bfb1
+MD5 (jcode.pl-2.13) = 7d688306677b99ec34cf68ef93562381
diff --git a/japanese/jcode.pl/pkg-descr b/japanese/jcode.pl/pkg-descr
index ebb8db4137cc..66652d1c74ce 100644
--- a/japanese/jcode.pl/pkg-descr
+++ b/japanese/jcode.pl/pkg-descr
@@ -1,19 +1,13 @@
-``jcode.pl-2.x'' is a perl library for japanese character code conversion.
-It supports translation of each JIS, EUC, Shift JIS texts, and automatically
-recognizes the encode-method of the target text files.
+jcode.pl is a perl library for japanese character code conversion.
+It supports translation of each JIS, EUC, Shift JIS texts,
+and automatically recognizes the encode-method of the target text files.
To use this, your script should load this library as
-
+ require "jcode.pl";
or
+ require('jcode.pl');
-# ``unshift(@INC, '/usr/local/lib/perl');'' could be needed before.
-
-# See also:
-# http://www.bekkoame.or.jp/~syunji/perl/perl_j.html
-# http://www.bekkoame.or.jp/~syunji/perl/jcode20.txt
-# (both pages are written in Japanese)
+WWW: http://srekcah.org/jcode/
- SADA Kenji
-sada@e-mail.ne.jp
+sada@FreeBSD.org
diff --git a/japanese/jcode.pl/pkg-plist b/japanese/jcode.pl/pkg-plist
index c36545e8e916..17537ad7bf1b 100644
--- a/japanese/jcode.pl/pkg-plist
+++ b/japanese/jcode.pl/pkg-plist
@@ -1,2 +1 @@
-lib/perl/jcode.pl
-@unexec rmdir %B 2>/dev/null || true
+%%INSTALL_BASE%%/jcode.pl