aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/jvim/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-01-29 19:08:52 +0800
committerknu <knu@FreeBSD.org>2002-01-29 19:08:52 +0800
commit2a436f8061602989d2bc9da2badeb810b25743fe (patch)
treecbe88b8f8fbad0137e21885684157d7bc8fb5240 /japanese/jvim/Makefile
parent4945631e5af11d192570f6bcb9c89591bfbe9e1a (diff)
downloadfreebsd-ports-gnome-2a436f8061602989d2bc9da2badeb810b25743fe.tar.gz
freebsd-ports-gnome-2a436f8061602989d2bc9da2badeb810b25743fe.tar.zst
freebsd-ports-gnome-2a436f8061602989d2bc9da2badeb810b25743fe.zip
Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;
the ECHO macro is set to "echo" by default, but it is set to "true" if make(1) is invoked with the -s option while ECHO_CMD is always set to the echo command. Use command macros where appropriate.
Diffstat (limited to 'japanese/jvim/Makefile')
-rw-r--r--japanese/jvim/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/japanese/jvim/Makefile b/japanese/jvim/Makefile
index 7c9e522314c3..5e845d5827f5 100644
--- a/japanese/jvim/Makefile
+++ b/japanese/jvim/Makefile
@@ -51,7 +51,7 @@ JPLIB+= -ljd -lcrypt
#
# Make a value of INPUT_METHOD
.if defined(INPUT_METHOD)
-INPUT_METHOD!= ${ECHO} ${INPUT_METHOD} | sed -e 's/^/-/' -e 's/ /+/g'
+INPUT_METHOD!= ${ECHO_CMD} ${INPUT_METHOD} | sed -e 's/^/-/' -e 's/ /+/g'
.endif
#
# For ONEW library
@@ -60,7 +60,7 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/libonew${INPUT_METHOD}.a:${PORTSDIR}/japanese/o
JPDEF+= -DONEW
# If we use ONEW libray, then -lonew*.a should appear
# before the other libraries.
-JPLIB!= echo ${JPLIB} | sed 's%^%-lonew${INPUT_METHOD} %'
+JPLIB!= ${ECHO_CMD} ${JPLIB} | sed 's%^%-lonew${INPUT_METHOD} %'
.endif
pre-build: