aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/kon2-16dot/Makefile
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>1998-09-26 23:41:21 +0800
committerkuriyama <kuriyama@FreeBSD.org>1998-09-26 23:41:21 +0800
commit85d591347e0326a6787bf966348003d230c3da78 (patch)
treedb8e8b04136507fd18b3c0527580b9be7b24c1ac /japanese/kon2-16dot/Makefile
parent1398b75b36a21c4f6d9be599d992015bbdebcf82 (diff)
downloadfreebsd-ports-gnome-85d591347e0326a6787bf966348003d230c3da78.tar.gz
freebsd-ports-gnome-85d591347e0326a6787bf966348003d230c3da78.tar.zst
freebsd-ports-gnome-85d591347e0326a6787bf966348003d230c3da78.zip
This update has these changes:
o Maintainer (with the previous maintainer's approval) o beep patch (Thanks to nabe@mobile.icc.titech.ac.jp!) o selectable Kon font size at make time. o modification for non-default PREFIX PR: ports/7878 Submitted by: Taguchi Takeshi <taguchi@tohoku.iij.ad.jp>
Diffstat (limited to 'japanese/kon2-16dot/Makefile')
-rw-r--r--japanese/kon2-16dot/Makefile32
1 files changed, 28 insertions, 4 deletions
diff --git a/japanese/kon2-16dot/Makefile b/japanese/kon2-16dot/Makefile
index 1d3b365e8cd9..9ffe29fec18f 100644
--- a/japanese/kon2-16dot/Makefile
+++ b/japanese/kon2-16dot/Makefile
@@ -3,7 +3,7 @@
# Date created: 11 Apr 1997
# Whom: Makoto Matsushita <matusita@jp.freebsd.org>
#
-# $Id: Makefile,v 1.13 1997/09/19 19:27:45 max Exp $
+# $Id: Makefile,v 1.14 1998/05/24 03:09:02 steve Exp $
#
DISTNAME= kon2-0.3
@@ -11,10 +11,13 @@ PKGNAME= ja-kon2-0.3
CATEGORIES= japanese
# note kon is only in first directory and fonts are only in second directory
MASTER_SITES= ftp://ftp.tut.ac.jp/Linux/Packages/Utils/ \
- ftp://ftp.iij.ad.jp/pub/X/XFree86/XFree86/3.3.1/untarred/xc/fonts/bdf/misc/
-DISTFILES= kon2-0.3.tar.gz k14.bdf 7x14rk.bdf
+ ftp://ftp.xfree86.org/pub/X/XFree86/XFree86/3.3.2/untarred/xc/fonts/bdf/misc/ \
+ ftp://ftp.iij.ad.jp/pub/X/XFree86/XFree86/3.3.2/untarred/xc/fonts/bdf/misc/
+DISTFILES= kon2-0.3.tar.gz \
+ k14.bdf 7x14rk.bdf \
+ jiskan16.bdf 8x16rk.bdf
-MAINTAINER= hideyuki@sat.t.u-tokyo.ac.jp
+MAINTAINER= shige@kuis.kyoto-u.ac.jp
MAN1= kon.1
MANLANG= ja
@@ -22,11 +25,32 @@ EXTRACT_ONLY= kon2-0.3.tar.gz
DOCDIR= ${PREFIX}/share/doc/kon2
+.if defined(KONFONT)
+.if (${KONFONT} == "16dot")
+KON16FONT=Startup
+.else if (${KONFONT} == "14dot")
+KON14FONT=Startup
+.endif
+.endif
+
+pre-fetch:
+.if !defined(KONFONT)
+ @${ECHO_MSG} "NOTE: You can select default kon font size."
+ @${ECHO_MSG} "by adding \"KONFONT=<Font Size>\" to argument of make."
+ @${ECHO_MSG} "<Font Size> must be \"16dot\" or \"14dot\"."
+ @${ECHO_MSG} "KONFONT defalut value is \"16dot\"."
+KON16FONT=Startup
+.endif
+
pre-build:
${SED} -e 's,%%PREFIX%%,${PREFIX},' \
-e 's,%%DISTDIR%%,${DISTDIR},' \
${FILESDIR}/dotconfig > ${WRKSRC}/.config
@(cd ${WRKSRC}; ${MAKE} -f Makefile.FreeBSD config)
+ @for i in kon.cfg.FreeBSD doc/kon.1; do\
+ ${MV} -f ${WRKSRC}/$${i} ${WRKSRC}/$${i}.in ;\
+ ${SED} -e "s;@@PREFIX@@;${PREFIX};g" -e "s;@@KON16FONT@@;${KON16FONT};g" -e "s;@@KON14FONT@@;${KON14FONT};g" ${WRKSRC}/$${i}.in > ${WRKSRC}/$${i} ;\
+ done
post-install:
@${INSTALL_MAN} ${WRKSRC}/doc/kon.1 ${PREFIX}/man/ja/man1