aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/kon2-16dot
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-02-02 22:09:50 +0800
committerpawel <pawel@FreeBSD.org>2014-02-02 22:09:50 +0800
commit1da43da8305043d8aa3eb5cff3a7cd37afb35b82 (patch)
tree4500666b46b6c0a36c66bc66bd7e78f1b8dec88d /japanese/kon2-16dot
parent5dff6334792c901d585cb8f84dfa04acc2a8c8ed (diff)
downloadfreebsd-ports-gnome-1da43da8305043d8aa3eb5cff3a7cd37afb35b82.tar.gz
freebsd-ports-gnome-1da43da8305043d8aa3eb5cff3a7cd37afb35b82.tar.zst
freebsd-ports-gnome-1da43da8305043d8aa3eb5cff3a7cd37afb35b82.zip
Stage support for japanese/kon2-16dot and it's slaves
PR: port/186321 (based on) Submitted by: maintainer
Diffstat (limited to 'japanese/kon2-16dot')
-rw-r--r--japanese/kon2-16dot/Makefile16
-rw-r--r--japanese/kon2-16dot/files/dotconfig10
-rw-r--r--japanese/kon2-16dot/files/patch-Makefile.FreeBSD4
-rw-r--r--japanese/kon2-16dot/files/patch-font_Makefile.FreeBSD10
-rw-r--r--japanese/kon2-16dot/files/patch-src_Makefile.FreeBSD18
-rw-r--r--japanese/kon2-16dot/pkg-descr2
-rw-r--r--japanese/kon2-16dot/pkg-plist7
7 files changed, 42 insertions, 25 deletions
diff --git a/japanese/kon2-16dot/Makefile b/japanese/kon2-16dot/Makefile
index 42c1e950bfcf..4b08e789b8ee 100644
--- a/japanese/kon2-16dot/Makefile
+++ b/japanese/kon2-16dot/Makefile
@@ -14,19 +14,14 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
# '+=' is for slave ports
-MAINTAINER?= turutani@scphys.kyoto-u.ac.jp
+MAINTAINER= turutani@scphys.kyoto-u.ac.jp
COMMENT= Kanji On Console -- Display kanji characters on your own console
ONLY_FOR_ARCHS= i386 amd64
-MAN1= kon.1
-MANLANG= ja
-
PORTDOCS= README README.FreeBSD
SUB_LIST= KON16FONT=${KON16FONT} \
KON14FONT=${KON14FONT}
-
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if !defined(KONFONT)
@@ -48,6 +43,7 @@ post-patch:
${WRKSRC}/.config::
(${ECHO_CMD} "DISTDIR = ${DISTDIR}"; \
${ECHO_CMD} "TOPDIR = ${PREFIX}"; \
+ ${ECHO_CMD} "S_TOPDIR = ${STAGEDIR}${PREFIX}"; \
${CAT} ${FILESDIR}/dotconfig; \
) > ${WRKSRC}/.config
@@ -64,10 +60,8 @@ post-configure:
done
post-install:
- ${INSTALL_MAN} ${WRKSRC}/src/kon.1 ${MANPREFIX}/man/ja/man1
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC}/doc && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
-.endif
+ ${INSTALL_MAN} ${WRKSRC}/src/kon.1 ${STAGEDIR}${MANPREFIX}/man/ja/man1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/doc && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.post.mk>
diff --git a/japanese/kon2-16dot/files/dotconfig b/japanese/kon2-16dot/files/dotconfig
index 66d12df50408..80be57ece42e 100644
--- a/japanese/kon2-16dot/files/dotconfig
+++ b/japanese/kon2-16dot/files/dotconfig
@@ -1,10 +1,10 @@
# $FreeBSD$
-BINDIR = $(TOPDIR)/bin
-LIBDIR = $(TOPDIR)/etc
-MANDIR = $(TOPDIR)/man/ja/man
-FONTDIR = $(TOPDIR)/share/fonts/bdf
+BINDIR = $(S_TOPDIR)/bin
+LIBDIR = $(S_TOPDIR)/etc
+MANDIR = $(S_TOPDIR)/man/ja/man
+FONTDIR = $(S_TOPDIR)/share/fonts/bdf
CONFIG_NAME = kon.cfg
-CFLAGS += -DCONFIG_NAME=\"$(LIBDIR)/$(CONFIG_NAME)\"
+CFLAGS += -DCONFIG_NAME=\"$(TOPDIR)/etc/$(CONFIG_NAME)\"
HAS_VGA = HAS_VGA
FLD_MINIX = FLD_MINIX
diff --git a/japanese/kon2-16dot/files/patch-Makefile.FreeBSD b/japanese/kon2-16dot/files/patch-Makefile.FreeBSD
index 9566aace84c3..93f6ae9eb2e8 100644
--- a/japanese/kon2-16dot/files/patch-Makefile.FreeBSD
+++ b/japanese/kon2-16dot/files/patch-Makefile.FreeBSD
@@ -13,10 +13,10 @@
(cd ${.CURDIR}/src ; make install)
(cd ${.CURDIR}/font ; make install)
- install -g wheel -o root -m 0644 -c kon.cfg.FreeBSD /usr/local/etc/kon.cfg
-+ install -g wheel -o root -m 0644 -c kon.cfg.FreeBSD ${LIBDIR}/kon.cfg
++ install -m 0644 -c kon.cfg.FreeBSD ${LIBDIR}/kon.cfg
+ @sh tools/makedir ${FONTDIR}
+ @for i in k14.bdf 7x14rk.bdf jiskan16.bdf 8x16rk.bdf; do\
-+ install -c -m 644 -o bin -g bin $(DISTDIR)/$$i ${FONTDIR};\
++ install -c -m 644 $(DISTDIR)/$$i ${FONTDIR};\
+ gzip -f -9 ${FONTDIR}/$$i;\
+ done
diff --git a/japanese/kon2-16dot/files/patch-font_Makefile.FreeBSD b/japanese/kon2-16dot/files/patch-font_Makefile.FreeBSD
index a054705ae737..33d67d6ffc34 100644
--- a/japanese/kon2-16dot/files/patch-font_Makefile.FreeBSD
+++ b/japanese/kon2-16dot/files/patch-font_Makefile.FreeBSD
@@ -1,5 +1,5 @@
--- font/Makefile.FreeBSD.orig 1997-01-25 19:08:44.000000000 +0900
-+++ font/Makefile.FreeBSD 2012-05-10 00:14:28.693551770 +0900
++++ font/Makefile.FreeBSD 2014-01-31 11:01:37.000000000 +0900
@@ -11,6 +11,7 @@
.endif
@@ -8,3 +8,11 @@
.if exists(${.OBJDIR}/../lib)
LIBOBJ= -L${.OBJDIR}/../lib
+@@ -20,4 +21,7 @@
+
+ LDADD= ${LIBOBJ} -lgon
+
++install: ${PROG}
++ /usr/bin/install -s ${PROG} ${BINDIR}
++
+ .include <bsd.prog.mk>
diff --git a/japanese/kon2-16dot/files/patch-src_Makefile.FreeBSD b/japanese/kon2-16dot/files/patch-src_Makefile.FreeBSD
index 5539529bd8e3..951777eb3315 100644
--- a/japanese/kon2-16dot/files/patch-src_Makefile.FreeBSD
+++ b/japanese/kon2-16dot/files/patch-src_Makefile.FreeBSD
@@ -1,14 +1,14 @@
--- src/Makefile.FreeBSD.orig 1997-01-30 10:29:25.000000000 +0900
-+++ src/Makefile.FreeBSD 2012-05-10 02:50:12.820551080 +0900
-@@ -1,12 +1,19 @@
++++ src/Makefile.FreeBSD 2014-01-31 10:53:18.000000000 +0900
+@@ -1,12 +1,17 @@
# FreeBSD makefile for kon
# Tatsumi Hosokawa <hosokawa@jp.FreeBSD.org>
+.include <bsd.own.mk>
+
PROG= kon
- BINOWN= root
- BINMODE= 4555
+-BINOWN= root
+-BINMODE= 4555
-SRCS= vt.c sock.c fnld.c vc.c mouse.c term.c main.c utmp.c errors.c child.c
+SRCS= vt.c sock.c fnld.c vc.c mouse.c term.c main.c errors.c child.c
+.if exists(${INCLUDEDIR}/utmpx.h)
@@ -21,4 +21,12 @@
+MK_MAN= no
CFLAGS+= -I${.CURDIR}/../include
CLEANFILES= Makefile
-
+
+@@ -28,4 +33,7 @@
+ .include "${.CURDIR}/../.config"
+ .endif
+
++install: ${PROG}
++ /usr/bin/install -s ${PROG} ${BINDIR}
++
+ .include <bsd.prog.mk>
diff --git a/japanese/kon2-16dot/pkg-descr b/japanese/kon2-16dot/pkg-descr
index 5a4977361bc5..0e7dea038f41 100644
--- a/japanese/kon2-16dot/pkg-descr
+++ b/japanese/kon2-16dot/pkg-descr
@@ -2,7 +2,7 @@ KON2 is a program for displaying Kanji (japanese characters) on the
console of Linux/FreeBSD. KON2 hooks the output of console and
redirects to pseudo tty, drawing on the VGA display.
-If KON2 would be going to somthing wrong, check shared-memories being
+If KON2 would be going to something wrong, check shared-memories being
loading or not. If not, add "options SYSVSHM" to
/usr/src/sys/i386/conf/GENERIC, and reconfigure the kernel.
diff --git a/japanese/kon2-16dot/pkg-plist b/japanese/kon2-16dot/pkg-plist
index 63cd22de2053..e7e258e08612 100644
--- a/japanese/kon2-16dot/pkg-plist
+++ b/japanese/kon2-16dot/pkg-plist
@@ -1,9 +1,16 @@
bin/fld
+@mode 4555
bin/kon
+@mode
etc/kon.cfg
+@owner bin
+@group bin
share/fonts/bdf/7x14rk.bdf.gz
share/fonts/bdf/k14.bdf.gz
share/fonts/bdf/8x16rk.bdf.gz
share/fonts/bdf/jiskan16.bdf.gz
+@owner
+@group
+man/ja/man1/kon.1.gz
@dirrm share/fonts/bdf
@dirrmtry share/fonts