aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/less/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1995-03-20 20:48:03 +0800
committerasami <asami@FreeBSD.org>1995-03-20 20:48:03 +0800
commit9b2e00dce03dcefa623f89598c3de228e1e7540c (patch)
tree8b54ca23eea9eaad2e558489a68a05ecae42b529 /japanese/less/Makefile
parent8e3f6e4271db0b8d41cd3d38ec6a5a05cb5b4679 (diff)
downloadfreebsd-ports-gnome-9b2e00dce03dcefa623f89598c3de228e1e7540c.tar.gz
freebsd-ports-gnome-9b2e00dce03dcefa623f89598c3de228e1e7540c.tar.zst
freebsd-ports-gnome-9b2e00dce03dcefa623f89598c3de228e1e7540c.zip
less-237 with patches to understand Japanese. It will install itself
with prefix "j" so as not to tramp on the regular less. Submitted by: Nobuhiro Yasutomi <nobu@psrc.isac.co.jp>
Diffstat (limited to 'japanese/less/Makefile')
-rw-r--r--japanese/less/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/japanese/less/Makefile b/japanese/less/Makefile
new file mode 100644
index 000000000000..54c68a4934dc
--- /dev/null
+++ b/japanese/less/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: jless
+# Version required: 237
+# Date created: 7 March 1995
+# Whom: Nobuhiro Yasutomi
+#
+# $Id$
+#
+DISTNAME= jless-237
+DISTFILES= less-237.tar.gz
+MASTER_SITES= ftp://ftp.aist-nara.ac.jp/pub/misc/less/
+HAS_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/less-237
+PATCHFILES= less-237-iso2022-patch2.gz less-237-iso2022-patch2.p1.gz
+.if !defined(MASTER_SITE_OVERRIDE)
+PATCHSITE= ftp://ftp.aist-nara.ac.jp/pub/misc/less/
+.else
+PATCHSITE= ${MASTER_SITE_OVERRIDE}
+.endif
+PREPATCH_COOKIE= ${.CURDIR}/work/.prepatch_done
+PREBUILD_COOKIE= ${.CURDIR}/work/.prebuild_done
+
+pre-fetch:
+ @if [ ! -d ${DISTDIR} ]; then mkdir -p ${DISTDIR}; fi
+ @(cd ${DISTDIR}; \
+ for file in ${PATCHFILES}; do \
+ if [ ! -f $$file ]; then \
+ echo ">> Fetching patch $$file from remote site..."; \
+ ${NCFTP} ${NCFTPFLAGS} ${PATCHSITE}$$file; \
+ fi \
+ done)
+
+pre-patch: ${PREPATCH_COOKIE}
+
+${PREPATCH_COOKIE}:
+ @echo "===> Applying ISO-2022 support patch"
+ @for file in ${PATCHFILES}; do \
+ gzip -c -d ${DISTDIR}/$$file | patch -d ${WRKSRC} -p1 -s; \
+ done
+ @${TOUCH} ${TOUCH_FLAGS} ${PREPATCH_COOKIE}
+
+pre-build: ${PREBUILD_COOKIE}
+
+${PREBUILD_COOKIE}:
+ find ${WRKSRC} -name \*.orig -exec /bin/rm -f \{} \;
+ @${TOUCH} ${TOUCH_FLAGS} ${PREBUILD_COOKIE}
+
+.include <bsd.port.mk>