aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/mecab/Makefile
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2013-08-11 13:20:29 +0800
committertota <tota@FreeBSD.org>2013-08-11 13:20:29 +0800
commita093ad4232e9fab13b548012dcd5b9422e8b9f72 (patch)
tree45bae5d952f650e43081fa2defc05dcaa375ed44 /japanese/mecab/Makefile
parent93bb62e80749e35204d614f975750a68fb84f68e (diff)
downloadfreebsd-ports-gnome-a093ad4232e9fab13b548012dcd5b9422e8b9f72.tar.gz
freebsd-ports-gnome-a093ad4232e9fab13b548012dcd5b9422e8b9f72.tar.zst
freebsd-ports-gnome-a093ad4232e9fab13b548012dcd5b9422e8b9f72.zip
- Update to 0.996
- Pass maintainership to submitter - Remove LICENSE_FILE for standard license PR: ports/177694 Submitted by: Yasuhiro KIMURA <yasu_AT_utahime_DOT_org>
Diffstat (limited to 'japanese/mecab/Makefile')
-rw-r--r--japanese/mecab/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/japanese/mecab/Makefile b/japanese/mecab/Makefile
index e670a443484c..2e936511f6bc 100644
--- a/japanese/mecab/Makefile
+++ b/japanese/mecab/Makefile
@@ -2,28 +2,28 @@
# $FreeBSD$
PORTNAME= mecab
-PORTVERSION= 0.995
+PORTVERSION= 0.996
CATEGORIES= japanese textproc
MASTER_SITES= GOOGLE_CODE
-MAINTAINER= clsung@FreeBSD.org
+MAINTAINER= yasu@utahime.org
COMMENT= Yet Another Part-of-Speech and Morphological Analyzer
LICENSE= BSD GPLv2 LGPL21
LICENSE_COMB= dual
-LICENSE_FILE_BSD= ${WRKSRC}/BSD
-LICENSE_FILE_GPLv2= ${WRKSRC}/GPL
-LICENSE_FILE_LGPL21= ${WRKSRC}/LGPL
-USE_AUTOTOOLS= libtool
-USES= iconv
-USE_PERL5_BUILD= yes
+USE_AUTOTOOLS= autoconf autoheader automake aclocal libtool
+USES= iconv gettext:build perl5
+USE_PERL5= build
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= ${PTHREAD_CFLAGS} -I ${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+ACLOCAL_ARGS= --system-acdir=${LOCALBASE}/share/aclocal
+AUTOMAKE_ARGS= --add-missing
+
MAN1= mecab.1
PORTDOCS= AUTHORS README *.html
@@ -34,8 +34,8 @@ OPTIONS_DEFINE= DOCS
post-patch:
${REINPLACE_CMD} -e 's/-lpthread/${PTHREAD_LIBS}/g' \
- -e 's/-O3/${CFLAGS}/' ${WRKSRC}/${CONFIGURE_SCRIPT}
- ${REINPLACE_CMD} -e 's/conf_DATA = mecabrc/conf_DATA = mecabrc.dist/' ${WRKSRC}/Makefile.in
+ -e 's/-O3/${CFLAGS}/' ${WRKSRC}/${CONFIGURE_SCRIPT}.in
+ ${REINPLACE_CMD} -e 's/conf_DATA = mecabrc/conf_DATA = mecabrc.dist/' ${WRKSRC}/Makefile.am
post-configure:
${CP} ${WRKSRC}/mecabrc ${WRKSRC}/mecabrc.dist