aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/mecab/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2003-04-23 14:51:56 +0800
committerknu <knu@FreeBSD.org>2003-04-23 14:51:56 +0800
commitcb9cffd4fe0b742a5e9d445134197decf77eeb94 (patch)
treeeb8c0511ffd0e0e0cd852d820fa59042b7d76a73 /japanese/mecab/Makefile
parent40aff5cf5c824007093830d94953b17808440066 (diff)
downloadfreebsd-ports-gnome-cb9cffd4fe0b742a5e9d445134197decf77eeb94.tar.gz
freebsd-ports-gnome-cb9cffd4fe0b742a5e9d445134197decf77eeb94.tar.zst
freebsd-ports-gnome-cb9cffd4fe0b742a5e9d445134197decf77eeb94.zip
Add mecab, yet another part-of-speech and morphological analyzer.
Diffstat (limited to 'japanese/mecab/Makefile')
-rw-r--r--japanese/mecab/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/japanese/mecab/Makefile b/japanese/mecab/Makefile
new file mode 100644
index 000000000000..d4c79565836a
--- /dev/null
+++ b/japanese/mecab/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: mecab
+# Date created: 2 April 2003
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mecab
+PORTVERSION= 0.74
+CATEGORIES= japanese textproc
+MASTER_SITES= http://cl.aist-nara.ac.jp/~taku-ku/software/mecab/src/ \
+ http://chasen.aist-nara.ac.jp/stable/ipadic/:dic
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ ${IPADIC_DISTNAME}${EXTRACT_SUFX}:dic
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= Yet Another Part-of-Speech and Morphological Analyzer
+
+IPADIC_DISTNAME= ipadic-2.5.0
+
+USE_PERL= yes
+
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+
+MAN1= mecab.1
+
+EXAMPLES= example/*
+DOCS= AUTHORS README doc/*.html doc/*.css
+
+post-extract:
+ ${LN} -s ${WRKDIR}/${IPADIC_DISTNAME} ${WRKSRC}/dic/
+
+post-install:
+ ${RM} -f ${PREFIX}/lib/libmecab.la
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${EXAMPLESDIR}
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${EXAMPLESDIR}/
+.endfor
+ ${MKDIR} ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>